View Issue Details

IDProjectCategoryView StatusLast Update
0001241Slicer4Core: GUIpublic2018-03-31 04:00
ReporterfinetjulAssigned Tofinetjul 
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.9.0 
Summary0001241: Weird popup behavior with mac
Description

After opening a QComboBox popup, clicking anywhere on the screen to close it and not moving the mouse can lead to reopening the popup once the button is clicked again

Additional Information

http://bugreports.qt.nokia.com/browse/QTBUG-15166

TagsNo tags attached.

Activities

jcfr

jcfr

2014-05-13 11:10

administrator   ~0011796

@Julien: Re-targetting minor issue from 4.4 to 4.5

lassoan

lassoan

2017-09-27 14:06

developer   ~0015194

Revisit this after Qt5 migration.

jcfr

jcfr

2018-03-31 03:17

administrator   ~0015640

Last edited: 2018-03-31 03:17

View 2 revisions

Updated reference: https://bugreports.qt.io/browse/QTBUG-15166

And it is indicated that it was fixed in Qt 4.8.0

jcfr

jcfr

2018-03-31 04:00

administrator   ~0015643

Since I can't reproduce using either the current nightly build, release 4.8.1 or even 4.6.2, I am closing.

Issue History

Date Modified Username Field Change
2011-07-01 17:32 finetjul New Issue
2011-07-01 17:32 finetjul Status new => assigned
2011-07-01 17:32 finetjul Assigned To => finetjul
2012-08-22 05:54 jcfr Target Version => Slicer 4.3.0
2013-08-09 04:37 finetjul Target Version Slicer 4.3.0 => Slicer 4.4.0
2014-05-13 11:10 jcfr Note Added: 0011796
2014-05-13 11:11 jcfr Target Version Slicer 4.4.0 => Slicer 4.5.0-1
2014-05-13 12:50 jcfr Status assigned => acknowledged
2015-11-02 11:58 jcfr Target Version Slicer 4.5.0-1 => Slicer 4.6.0
2016-10-12 03:56 jcfr Target Version Slicer 4.6.0 => Slicer 4.7.0
2017-09-27 14:06 lassoan Target Version Slicer 4.7.0 => Slicer 4.9.0
2017-09-27 14:06 lassoan Note Added: 0015194
2018-03-31 03:17 jcfr Note Added: 0015640
2018-03-31 03:17 jcfr Note Edited: 0015640 View Revisions
2018-03-31 04:00 jcfr Status acknowledged => resolved
2018-03-31 04:00 jcfr Resolution open => unable to reproduce
2018-03-31 04:00 jcfr Fixed in Version => Slicer 4.9.0
2018-03-31 04:00 jcfr Note Added: 0015643