View Issue Details

IDProjectCategoryView StatusLast Update
0001262Slicer4Module VolumeRenderingpublic2016-07-12 13:14
ReporterkikinisAssigned Tomsmolens 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0001262: annotations are not properly composited with volume rendering
Description

slicer 4 linux64 compiled Jul 6
the bidirectional and ruler annotations are not properly composited with the vtk gpu ray caster. As can be seen in the image, they seem to be suspended in front of the volume rendering

TagsNo tags attached.

Activities

2011-07-06 12:13

 

VR compositing problem.png (373,870 bytes)
VR compositing problem.png (373,870 bytes)
pieper

pieper

2011-12-12 09:03

administrator   ~0003439

This is probably because there are only 2D vtk widgets for these types of annotations and they don't exist in the 3D scene.

I've assigned this to Will to confirm and see if this is something he's got in the works.

jcfr

jcfr

2016-06-24 01:12

administrator   ~0014020

@Max: While working on updating Slicer to work with VTK7, consider checking if this is still an issue.

For reference: http://wiki.slicer.org/slicerWiki/index.php/Documentation/Labs/VTK7

msmolens

msmolens

2016-07-12 11:01

developer   ~0014037

This seems okay in Slicer-4.5.0-2016-07-10. Ruler annotations are rendered with the expected depth testing with the volume rendering.

jcfr

jcfr

2016-07-12 13:14

administrator   ~0014038

Great. Thanks for the note.

Issue History

Date Modified Username Field Change
2011-07-06 12:13 kikinis New Issue
2011-07-06 12:13 kikinis File Added: VR compositing problem.png
2011-08-25 09:48 finetjul Target Version => Slicer 4.0 RSNA
2011-12-12 09:03 pieper Note Added: 0003439
2011-12-12 09:03 pieper Assigned To => willschroeder
2011-12-12 09:03 pieper Status new => assigned
2012-10-22 07:36 jcfr Target Version Slicer 4.0.0 => Slicer 4.3.0
2013-07-05 06:34 pieper Target Version Slicer 4.3.0 =>
2016-06-24 01:11 jcfr Assigned To willschroeder => msmolens
2016-06-24 01:12 jcfr Note Added: 0014020
2016-07-12 11:01 msmolens Note Added: 0014037
2016-07-12 11:01 msmolens Status assigned => resolved
2016-07-12 11:01 msmolens Resolution open => fixed
2016-07-12 13:14 jcfr Note Added: 0014038