View Issue Details

IDProjectCategoryView StatusLast Update
0000014Slicer3Base Codepublic2017-06-10 08:51
ReporterhayesAssigned Toalexy 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Summary0000014: Node Selector for Fibers
Description

Lauren wants here node subclass not to be included in a general node selector (e.g. her fiber node shouldn't show up where there is a model selector). Generally subclasses do show up so people can select, for example, from a list of Transformable nodes. Fixed: Added ChildClassesEnabled flag to node selector that is On by default but if you don't want to select all super classes set it to Off.

Additional Information

added ChildClassesEnabled to node selector.
Together with changes in Fibers MRML it works ok now in Tracktography module.

TagsNo tags attached.

Activities

millerjv

millerjv

2007-01-19 07:37

developer   ~0000005

Does this fix address Lauren's request? The solution appears to be the reverse of the original request.

The bug said Lauren wanted her node subclass not to show in a node selector for general models. To maintain this capability with the proposed fix, every node selector in Slicer that is configured to select models would have to be configured to not select subclasses. As more node selectors are added to Slicer, we'll have to configure them not to select fibers.

What if there are two subclasses of models and you want to only show one of the subclasses in the general model list?

I think perhaps, Lauren wants to "hide" the fiber nodes from the selectors in general (which there is an ivar (HideFromEditors) to do this), and then enable particular node selectors to view these "hidden" fiber nodes whenever fiber nodes should be selected.

hayes

hayes

2007-01-25 07:08

administrator   ~0000017

Hi Lauren,

What's the status of this bug? Did the fix address your problem? Thanks! -K.

lauren

lauren

2007-01-25 08:51

developer   ~0000021

I went through this apparent reversal of the desired effect with Alex via email, and I believe it was fixed. I haven't had time to work on slicer3 and test yet, I will inform when I know for sure that it works. Thank you!

hayes

hayes

2007-02-13 06:29

administrator   ~0000048

Reminder sent to: lauren

Hey Lauren,

Sorry to pester you, but I'm trying to close out a bunch of bugs in the bug tracker. Did you have a chance to see if this bug was resolved? Thanks again, Katie

lauren

lauren

2007-02-13 06:48

developer   ~0000049

Last edited: 2007-02-13 06:57

Hi Katie,

Finally I am testing this. It does not work as expected for me. The fiber bundles are children of vtkMRMLModelNode, and they still show up on the menus in the Models GUI. To prevent this, those menus (in the Models module) would have to not show child classes. I think the fix was implemented as a menu option but not selected yet in Models.

Also, I suspect another bug. The effect is not as expected when I load the vtk model (fiber bundle) in the Slicer3/Modules/Tractography/Testing/TestData directory. I load it using the Tractography->Tractography->Load interface. It is displayed as a model (blue polylines always visible) and as a fiber bundle (as lines/tubes/glyphs when requested by my Tractography->Tractography interface). Strangely, changing model properties in the Models module affects the tubes or glyphs rather than the ever-present blue line (perhaps another bug with all these models having the same name, although the tubes/glyphs are supposed to be hidden from editors).

I realize that resolving this by the current method is asking the Models GUI to ignore its child classes. Is it likely that the Models module will want to pay attention to other child classes in the future? For now at least it would be great if the ignore child classes flag is set in the Models selectors.

I just reread Jim Miller's comments above. Currently I am not hiding the fiber bundles from editors, just the "fake models" used to display them. The idea is that all of my modules will want to see the fiber bundles so they shouldn't be hidden... Or, they should be hidden from everything not specifically trying to select a fiber bundle. However this isn't an option now?

hayes

hayes

2007-03-19 11:19

administrator   ~0000054

Reminder sent to: lauren

Hi Lauren,

Alex has fixed this bug, so I'm going to go ahead and close it. If you feel like your request still hasn't been addressed fully, let me know and I will reopen it.

Katie

Related Changesets

Slicer: 2145-support-for-installing-extension-from-file 29a04b80

2013-11-04 16:04:45

jcfr

Details Diff
BUG: OpenIGTLink - Fixes issue 0003454 - could not receive LBMETA messages.

// -------------------------
OpenIGTLink updates:

Bonny Biswas (2):
ENH: Added set/get methods for coordinate system in ImageMessage classes
BUG: LPS coordinate system value in ImageMessage does not match protocol

Isaiah Norton (2):
ENH: add StringEchoServer example
ENH: add PointListServer example

Junichi Tokuda (41):
ENH: start implementing session manager
ENH: MessageHandler and SessionManager classes are implemented and now working. Template-based MessageHandler class has been removed.
STYLE: adding comment in the source code for SessionManagerServer example program.
ENH: implement session manager with pseudo non-blocking messaging (receive only)
Merge pull request 0000003 from lchauvin/patch-1
Merge pull request 0000004 from lchauvin/patch-1
ENH: added the second argument for Process() in the message handler class to share data between the message handler class and other classes/functions outside the class.
Solve conflict.
ENH: Adding CapabilityMessage class
ENH: Adding the capability message type and examples.
ENH: Merging the fixes in the master branch to the development branch.
BUG: Fixed the compile error caused by the last commit.
STYLE: Merging the master repository with improved comments for Doxygen.
STYLE: Merge changes in the master repository.
STYLE: Merge updates in the master repository.
STYLE: Merge master repository.
ENH: Add igtlCreateDefaultQueryMessageClass() macro to help defining a class for query message.
ENH: Create HeaderOnlyMessageBase as a base class for query message types.
BUG: merge labonny's changes
Merge pull request 0000013 from perim/master
BUG: Fix Issue 0000014 Linker error in VS2012.
STYLE: Fix wrong statement in help (coordinate -> string)
Merge pull request 0000018 from ihnorton/add_pointlistserver_example
ENH: Add a class for GET_STATUS message type.
ENH: Add TrajectoryMessage example.
ENH: Merge changes in master.
STYLE: Fixed revision number
COMP: Fix warning 'converting to non-pointer type int from NULL'.
STYLE: Update version number.
ENH: Merge github.com:tokjun/OpenIGTLink.git.
BUG: Avoid * ((igtl_uint16 *) ptr) = <value> to address issue 0000020. Need testing.
STYLE: Format README using Markdown
STYLE: Rename README to README.md
BUG: Address issue 0000021.. replace this->m_DefaultBodyType = this->DefaultBodyType() with this->m_DefaultBodyType = ""
BUG: Reset changes in Example/Status/StatusClient
BUG: Fixing Issue 0000020. 'signed' is explicitly specified for igtl_int8. Tested on Ubuntu + armv7l.
STYLE: Use C-style comments in .c files.
Merge pull request 0000022 from tokjun/master
ENH: Add LBMETA message to ImageDatabaseServer example.
BUG: Fixed bug in LabelMetaMessage. It could not extract owner image information from a LBMETA message.
Merge pull request 0000024 from tokjun/23-LBMETA-example

Laurent Chauvin (3):
Modified GetMode method
Add igtlMessageHandlerMacro.h to the list of files
ENH: Removed the sleep

Per Inge Mathisen (3):
Fix wrong use of delete operator
Fix wrong bitwise and operator
Fix compile warnings under clang

// -------------------------
OpenIGTLinkIF updates:

Isaiah Norton (1):
COMP: partially fix 0000009, and a leak

Junichi Tokuda (3):
Merge pull request 0000010 from ihnorton/issue9_partial_fix
ENH: Implement LableMetaList function. This commit requires OpenIGTLink library commit 661d4bd.
Merge pull request 0000012 from tokjun/0003454-lbmeta

From: Jean-Christophe Fillion-Robin <jchris.fillionr@kitware.com>

git-svn-id: http://svn.slicer.org/Slicer4/trunk@22679 3bd1e089-480b-0410-8dfb-8563597acbee
mod - SuperBuild/External_OpenIGTLink.cmake Diff File
mod - SuperBuild/External_OpenIGTLinkIF.cmake Diff File

Import 2017-06-07 23:51:09: master 29a04b80

2013-11-04 16:04:45

jcfr

Details Diff
BUG: OpenIGTLink - Fixes issue 0003454 - could not receive LBMETA messages.

// -------------------------
OpenIGTLink updates:

Bonny Biswas (2):
ENH: Added set/get methods for coordinate system in ImageMessage classes
BUG: LPS coordinate system value in ImageMessage does not match protocol

Isaiah Norton (2):
ENH: add StringEchoServer example
ENH: add PointListServer example

Junichi Tokuda (41):
ENH: start implementing session manager
ENH: MessageHandler and SessionManager classes are implemented and now working. Template-based MessageHandler class has been removed.
STYLE: adding comment in the source code for SessionManagerServer example program.
ENH: implement session manager with pseudo non-blocking messaging (receive only)
Merge pull request 0000003 from lchauvin/patch-1
Merge pull request 0000004 from lchauvin/patch-1
ENH: added the second argument for Process() in the message handler class to share data between the message handler class and other classes/functions outside the class.
Solve conflict.
ENH: Adding CapabilityMessage class
ENH: Adding the capability message type and examples.
ENH: Merging the fixes in the master branch to the development branch.
BUG: Fixed the compile error caused by the last commit.
STYLE: Merging the master repository with improved comments for Doxygen.
STYLE: Merge changes in the master repository.
STYLE: Merge updates in the master repository.
STYLE: Merge master repository.
ENH: Add igtlCreateDefaultQueryMessageClass() macro to help defining a class for query message.
ENH: Create HeaderOnlyMessageBase as a base class for query message types.
BUG: merge labonny's changes
Merge pull request 0000013 from perim/master
BUG: Fix Issue 0000014 Linker error in VS2012.
STYLE: Fix wrong statement in help (coordinate -> string)
Merge pull request 0000018 from ihnorton/add_pointlistserver_example
ENH: Add a class for GET_STATUS message type.
ENH: Add TrajectoryMessage example.
ENH: Merge changes in master.
STYLE: Fixed revision number
COMP: Fix warning 'converting to non-pointer type int from NULL'.
STYLE: Update version number.
ENH: Merge github.com:tokjun/OpenIGTLink.git.
BUG: Avoid * ((igtl_uint16 *) ptr) = <value> to address issue 0000020. Need testing.
STYLE: Format README using Markdown
STYLE: Rename README to README.md
BUG: Address issue 0000021.. replace this->m_DefaultBodyType = this->DefaultBodyType() with this->m_DefaultBodyType = ""
BUG: Reset changes in Example/Status/StatusClient
BUG: Fixing Issue 0000020. 'signed' is explicitly specified for igtl_int8. Tested on Ubuntu + armv7l.
STYLE: Use C-style comments in .c files.
Merge pull request 0000022 from tokjun/master
ENH: Add LBMETA message to ImageDatabaseServer example.
BUG: Fixed bug in LabelMetaMessage. It could not extract owner image information from a LBMETA message.
Merge pull request 0000024 from tokjun/23-LBMETA-example

Laurent Chauvin (3):
Modified GetMode method
Add igtlMessageHandlerMacro.h to the list of files
ENH: Removed the sleep

Per Inge Mathisen (3):
Fix wrong use of delete operator
Fix wrong bitwise and operator
Fix compile warnings under clang

// -------------------------
OpenIGTLinkIF updates:

Isaiah Norton (1):
COMP: partially fix 0000009, and a leak

Junichi Tokuda (3):
Merge pull request 0000010 from ihnorton/issue9_partial_fix
ENH: Implement LableMetaList function. This commit requires OpenIGTLink library commit 661d4bd.
Merge pull request 0000012 from tokjun/0003454-lbmeta

From: Jean-Christophe Fillion-Robin <jchris.fillionr@kitware.com>

git-svn-id: http://svn.slicer.org/Slicer4/trunk@22679 3bd1e089-480b-0410-8dfb-8563597acbee
mod - SuperBuild/External_OpenIGTLink.cmake Diff File
mod - SuperBuild/External_OpenIGTLinkIF.cmake Diff File

Import 2017-06-07 23:51:09: master f1c371b7

2016-11-15 10:13:32

jcfr

Details Diff
ENH: Update python-cmake-buildsystem

This the first step toward the support of Python 3

$ git shortlog b012e1e..39ccab0 --no-merges
David Brooks (3):
Allow a Python build to be part of a larger CMake project.
Make it easier to specify the version of Python to build.
Update the default Python to 2.7.12.

Isaiah Norton (1):
pyconfig: guard '_LARGEFILE_SOURCE' to reduce warnings

Jean-Christophe Fillion-Robin (99):
Do not install test scripts if BUILD_TESTING is OFF. Fixes 0000110
Update travis and appveyor settings to specify major/minor/patch versions.
Fix setting of HAVE_LCHMOD
Reorganize libpython sources
Add "generate_graminit" target
Add "generate_python_ast_h" and "generate_python_ast_c" targets
Add "generate_opcode_h" target
Sort test list alphabetically
Fix execution of "test_doctest"
libpython: Remove redundant settings of POSITION_INDEPENDENT_CODE property
Set minimum required version of OpenSSL to 0.9.7
Fix "test_gdb" configuring and installing "python-gdb.py"
Fix test_asdl_parser
Add option WITH_COMPUTED_GOTOS for Python >= 2.7.11
Update "add_python_extension" function adding "ALWAYS_BUILTIN" option.
bdist_wininst: Fix configuration error due to not found ZLIB_LIBRARIES
extensions/CMakeLists.txt: Add comments
Add /Zm200 microsoft compiler flag
add_python_extension: Re-organize code to call target_link_libraries once.
Ensure extension include directories are associated with only one extension
Fix "test_asdl_parser" on windows
Add USE_BUILTIN_ZLIB option. Fixes 0000014
add_python_extension: Add support for NO_INSTALL option.
Add support for building Python 3.5.1
python3: Fix tests like "test_loads_recursion" failing on windows
python3: Fix "test_no_comdat_folding" disabling COMDAT folding.
python3: Add support for _decimal extension
python3: Fix build of _scproxy
python3: Support building xxlimited extension
python3: Build "python3dll" and fix msvc "xxlimited" link issue.
python3: Add target to run "Argument Clinic"
python3: Associate ABIFLAGS with shared/static libraries
python3: Export and install libpython3-shared
python3: Build libpython3-shared on unix
appveyor: Disable Debug configuration
appveyor: Associate python "3.5.1" with "Visual Studio 12 2013" generator
python3: Fix MaxOSX build
python3: Fix HAVE_READV and HAVE_WRITEV configuration check on MacOSX
python3: Fix windows error when building 32-bit by excluding vcdiv64.asm
python3: Associate correct architecture with python3stub.lib
python3: Fix windows build of _decimal extension
python3: Fix build of decimal extension
Add configure check for HAVE_UCS4_TCL
python2: Support setting Py_UNICODE_SIZE. Fixes 0000106
Install LICENSE file. Fixes 0000029
Install man pages. Fixes 0000030
Generate and install grammar tables. Fixes 0000028
Add configure check for MACOSX_DEPLOYMENT_TARGET.
extension_ctypes: Simplify code introducing ctypes_COMMON_SOURCES var
extension_ctypes: Support MacOSX build. Fixes 0000018
Fix configure check HAVE_READLINE_READLINE_H on MacOSX
python3: Do not include system processor when setting SOABI on MacOSX
python3: Fix name of crypt extension
Cache results of CMake checks
Use CMake module "CheckTypeSize" and remove custom "CheckTypeExists"
libpython-static: Use CMAKE_DL_LIBS instead to initialize CMAKE_DL_LIBS
Add WITH_STATIC_DEPENDENCIES option (available only on Unix)
Add INSTALL_DEVELOPMENT option
Add INSTALL_MANUAL option
Add INSTALL_TEST option
Support system where libutil and libm are builtin the standard library
Support building with HAVE_LIBDL set to False
Build threadmodule only if WITH_THREAD is ON
Associate "semaphore.c" with multiprocessing module only if it applies
decimal: Display selected libmpdec_config
python2: Add option to build threadmodule
Exclude targets not relevant when cross compiling
libmpdec_config: Add note for possible tweak
circle: Add initial configuration
circle: Cache docker images
Associate cross-compiling emulator with custom commands & targets and tests
Fix compilation of getpath.c crosscompiling using MinGW
extension_datetime: Fix reference to MSVC_BUILTIN
extensions: Generalize the built-in of Windows extensions to all compilers
extension_ctypes: Fix indent
Add BUILD_LIBPYTHON_SHARED option, deprecate BUILD_SHARED and BUILD_STATIC
Consistently set LIBPYTHON_VERSION checking for WIN32 instead of MSVC
bdist_wininst: Do not build by default if crosscompiling.
config-mingw: Create copy of "PC/pyconfig.h"
config-mingw: Replace "tab" with "2 spaces"
config-mingw: Remove WINCE related config
config-mingw: Remove support for older version of Visual Studio
config-mingw: Remove support for Borland, egcs/gnu-win32 and lcc-win32 compiler
config-mingw: Remove support for Intel compiler
config-mingw: Add (i686|x86_64)-w64-mingw32 toolchain support from MXE
fficonfig: Add test to set HAVE_MMAP_FILE
fficonfig: Fix HAVE_AS_CFI_PSEUDO_OP test
fficonfig: Update package metadata and fix typos
fficonfig: Add missing SIZEOF_SIZE_T define
fficonfig: Add test placeholders for new options introduced in libffi >= 3.0.13
fficonfig: Add HAVE_AS_ASCII_PSEUDO_OP test
fficonfig: Add HAVE_AS_STRING_PSEUDO_OP test
fficonfig: Ensure HAVE_RO_EH_FRAME value is configured
python3: Fix setting of WITH_HASH_ALGORITHM option properties
sqlite3: Always expect the library and headers top be on the system
circle: Fix build renaming all image references
CMakeLists: Tweak "unknown python version" error message text
gitignore: Ignore python source archives
README: Minor tweaks

Jonathan White (2):
Set target properties only if decimal/readline extensions are builtin.
Fixed error in naming of dbm and gdbm modules when compiling for Python 3.x

Marcel Metz (1):
Remove arguments from else and end* block termination commands

Matt McCormick (5):
Add Python 2.7.12 MD5
ci: Add Python 2.7.12 support
test_coding and test_pep263 renamed to test_source_coding in 2.7.12
test_pep293 rename to test_string in Python 2.7.12
circle: Use dockcross images

Max Smolens (1):
Support Python 3.5.2

Tony Narlock (7):
Fix 0000132 libffi directory on FreeBSD 11-CURRENT
Prevent BSD systems from being tagged as Linux
ConfigureChecks: Correct HAVE_SYS_SYS_DOMAIN_H include check
makefile-variables: Remove obsolete OTHER_LIBTOOL_OPT
Rename fficonfig.h to fficonfig.h.in and configure it during configuration
pyconfig.h: Add missing test for SETPGRP_HAVE_ARG
Configure fficonfig.h using system introspection. See 0000135

bamboo (1):
README: Fix typo.

git-svn-id: http://svn.slicer.org/Slicer4/trunk@25537 3bd1e089-480b-0410-8dfb-8563597acbee
mod - SuperBuild/External_python.cmake Diff File

Issue History

Date Modified Username Field Change
2007-01-19 06:44 hayes New Issue
2007-01-19 06:44 hayes Status new => assigned
2007-01-19 06:44 hayes Assigned To => lauren
2007-01-19 06:44 hayes Status assigned => closed
2007-01-19 06:44 hayes Resolution open => fixed
2007-01-19 07:37 millerjv Status closed => feedback
2007-01-19 07:37 millerjv Resolution fixed => reopened
2007-01-19 07:37 millerjv Note Added: 0000005
2007-01-25 07:07 hayes Status feedback => assigned
2007-01-25 07:08 hayes Note Added: 0000017
2007-01-25 08:51 lauren Note Added: 0000021
2007-02-13 06:29 hayes Note Added: 0000048
2007-02-13 06:48 lauren Note Added: 0000049
2007-02-13 06:54 lauren Note Edited: 0000049
2007-02-13 06:54 lauren Note Edited: 0000049
2007-02-13 06:57 lauren Note Edited: 0000049
2007-02-13 07:34 hayes Assigned To lauren => alexy
2007-02-13 07:35 hayes Resolution reopened => open
2007-03-19 09:30 alexy Resolution open => fixed
2007-03-19 09:30 alexy Additional Information Updated
2007-03-19 11:19 hayes Note Added: 0000054
2007-03-19 11:19 hayes Status assigned => closed
2017-06-07 23:27 jcfr Changeset attached => Slicer 2145-support-for-installing-extension-from-file 29a04b80
2017-06-10 08:51 jcfr Changeset attached => Slicer master f1c371b7
2017-06-10 08:51 jcfr Changeset attached => Slicer master 29a04b80