View Issue Details

IDProjectCategoryView StatusLast Update
0000015Slicer3Command Line Modules (Applications/CLI)public2007-01-25 07:10
ReporterpieperAssigned Tomillerjv 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformwindowsOSOS Version
Summary0000015: model building fails with space in command line (temp dir)
Description

If the applications setting for the module temp dir is for a directory with a space in the path an error is generated in the command line parser.

Additional Information

vtkCommandLineModuleLogic (13BDEDF0): Model Maker standard error:

PARSE ERROR:

         One or more required arguments missing!

Brief USAGE:

For complete USAGE and HELP type:

c:/pieper/bwh/slicer3/debug/Slicer3-build/bin/Debug/../../lib/Slicer3/Plugins/Debug/ModelMaker.exe --help

Type: Information
Time: 01/23/07 12:31:23
Description: Model Maker standard output:

c:/pieper/bwh/slicer3/debug/Slicer3-build/bin/Debug/../../lib/Slicer3/Pl

                                    ugins/Debug/ModelMaker.exe 

                                    [--processinformationaddress

                                    <std::string>] [--xml] [--echo]

                                    [-j] [-e <int>] [--filtertype <Sinc

                                    |Laplacian>] [--pointnormals]

                                    [--splitnormals] [--decimate

                                    <float>] [--smooth <int>]

                                    [--anatomyLabelFile <std::string>]

                                    [--generateAll] [-n <std::string>]

                                    [-s <int>] [--] [--version] [-h]

                                    <std::string> <std::string>

Type: Information
Time: 01/23/07 12:31:21
Description: Model Maker command line:

c:/pieper/bwh/slicer3/debug/Slicer3-build/bin/Debug/../../lib/Slicer3/Plugins/Debug/ModelMaker.exe --start 1 --name Model --anatomyLabelFile NoneSpecified --smooth 15 --decimate 0.25 --splitnormals --pointnormals --filtertype Sinc --end 1 C:/Documents and Settings/pieper/Slicer3/vtkMRMLScalarVolumeNodeC_EDEI.nrrd

TagsNo tags attached.

Activities

pieper

pieper

2007-01-23 08:14

administrator   ~0000007

Oops, sorry - turns out it was a different issue. The spaces don't seem to be the problem.

The actual issue was that the output dir for the model maker wasn't specified -- but I had no way of getting this from the error message I got (below). Shouldn't the message be: "No output directory specified" instead of:

PARSE ERROR:

         One or more required arguments missing!

I've changed this to a feature request for a better error mesage :)

millerjv

millerjv

2007-01-24 08:10

developer   ~0000014

I added additional error checking of parameter values for the index parameters (required parameters).

millerjv

millerjv

2007-01-24 08:13

developer   ~0000015

I added additional error checking of parameter values for the index parameters (required parameters).

hayes

hayes

2007-01-25 07:10

administrator   ~0000018

Changing status from resolved -> closed.

Issue History

Date Modified Username Field Change
2007-01-23 07:56 pieper New Issue
2007-01-23 07:56 pieper Status new => assigned
2007-01-23 07:56 pieper Assigned To => millerjv
2007-01-23 08:14 pieper Note Added: 0000007
2007-01-23 08:14 pieper Severity major => feature
2007-01-23 08:14 pieper Status assigned => confirmed
2007-01-24 08:10 millerjv Note Added: 0000014
2007-01-24 08:13 millerjv Status confirmed => resolved
2007-01-24 08:13 millerjv Resolution open => fixed
2007-01-24 08:13 millerjv Note Added: 0000015
2007-01-25 07:10 hayes Note Added: 0000018
2007-01-25 07:10 hayes Status resolved => closed