View Issue Details

IDProjectCategoryView StatusLast Update
0000016Slicer3GUIpublic2007-03-29 12:17
ReporterhayesAssigned Towjp 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinux, others?OSOS Version
Summary0000016: Problem with tooltips for FG/BG
Description

When you start Slicer3, if you mouse over the FG and BG controls above the slice views, the tooltip for FG is: "Select the foreground" and BG is: "Select the background". If you load in two volumes, e.g. fixed.nrrd in the FG and moving.nrrd in the background, when you mouse over FG, it reads: "Select the foreground" (correct) and when you mouse over BG, it reads: "moving.nrrd" (incorrect). If you set the BG to 'none', it still reads "moving.nrrd". Even if you close/delete all the volumes from the MRML tree, it still reads "moving.nrrd".

Also, the tooltip only appears for FG if you mouse over the little 'F' logo, but the tooltip for BG appears if you mouse over the 'B' logo, or the drop-down menu to the right of it.

TagsNo tags attached.

Activities

pieper

pieper

2007-01-27 11:38

administrator   ~0000024

Alex - this looks like an issue with the node selector widget and how it mananages the tooltips. Can you have a look? thanks, Steve

wjp

wjp

2007-03-29 12:14

administrator   ~0000087

Now when any of the foreground, background or label node selector widgets are used to select a node, the vtkSlicerSliceControllerWidget observes this event, and resets the ToolTip.

Issue History

Date Modified Username Field Change
2007-01-25 10:10 hayes New Issue
2007-01-27 11:38 pieper Note Added: 0000024
2007-01-27 11:38 pieper Assigned To => alexy
2007-01-27 11:38 pieper Status new => assigned
2007-03-19 09:47 alexy Assigned To alexy => wjp
2007-03-29 12:14 wjp Note Added: 0000087
2007-03-29 12:14 wjp Status assigned => resolved
2007-03-29 12:17 hayes Status resolved => closed
2007-03-29 12:17 hayes Resolution open => fixed