View Issue Details

IDProjectCategoryView StatusLast Update
0001614Slicer4Core: Base Codepublic2014-05-13 11:06
ReporterjcfrAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityhave not tried
Status acknowledgedResolutionopen 
Product VersionSlicer 4.0.0 
Target VersionFixed in Version 
Summary0001614: Naming convention - Scripted vs ScriptedLoadable
Description

From Steve Pieper - Dec 6 2011:
I'd prefer the name 'Modules/Scripted' rather than 'Modules/ScriptedLoadable' (which seems redundant) -- also I don't foresee a category of ScriptedCLI, because the logic of the Scripted module can be written such that the same code can be used as either a CLI or a GUI module (i.e. the slicelet concept) so Scripted seems to cover the topic well.

TagsNo tags attached.

Relationships

related to 0001615 acknowledgedjcfr Naming convention - Widget, Widgets, Logic, Logics, DisplayableManagers ... 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2011-12-06 06:49 jcfr New Issue
2011-12-06 06:49 jcfr Status new => assigned
2011-12-06 06:49 jcfr Assigned To => finetjul
2012-03-12 16:54 finetjul Relationship added related to 0001615
2012-08-22 05:56 jcfr Target Version => Slicer 4.3.0
2013-08-09 04:37 finetjul Target Version Slicer 4.3.0 => Slicer 4.4.0
2014-05-13 11:06 jcfr Assigned To finetjul => jcfr
2014-05-13 11:06 jcfr Status assigned => acknowledged
2014-05-13 11:06 jcfr Target Version Slicer 4.4.0 =>