View Issue Details

IDProjectCategoryView StatusLast Update
0001615Slicer4Core: Base Codepublic2014-05-13 11:06
ReporterjcfrAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityhave not tried
Status acknowledgedResolutionopen 
Product VersionSlicer 4.0.0 
Target VersionFixed in Version 
Summary0001615: Naming convention - Widget, Widgets, Logic, Logics, DisplayableManagers ...
Description

// ---------------------
From Jc - Dec 6, 2011:
Within the Libs folder, I moved the MRML related library into one folder. We would have now:

Libs/MRML/Core ......... MRML library have been renamed into MRMLCore
Libs/MRML/DisplayableManager
Libs/MRML/IDImageIO
Libs/MRML/Logic
Libs/MRML/Widgets

// ---------------------
From J2:

If Widgets is plural, maybe Logic and DisplayableManager should probably be plural as well.

TagsNo tags attached.

Relationships

related to 0001614 acknowledgedjcfr Naming convention - Scripted vs ScriptedLoadable 

Activities

finetjul

finetjul

2012-03-01 18:08

administrator   ~0003760

Current inconsistency in Base:
Base/Logic/ -> SlicerBaseLogic
Base/Logic/Testing BaseLogicCxxTests
Base/QTCore -> qSlicerBaseQTCore

Issue History

Date Modified Username Field Change
2011-12-06 06:52 jcfr New Issue
2011-12-06 06:52 jcfr Status new => assigned
2011-12-06 06:52 jcfr Assigned To => finetjul
2012-03-01 18:08 finetjul Note Added: 0003760
2012-03-12 16:54 finetjul Relationship added related to 0001614
2012-08-22 05:56 jcfr Target Version => Slicer 4.3.0
2013-08-09 04:37 finetjul Target Version Slicer 4.3.0 => Slicer 4.4.0
2014-05-13 11:06 jcfr Assigned To finetjul => jcfr
2014-05-13 11:06 jcfr Status assigned => acknowledged
2014-05-13 11:06 jcfr Target Version Slicer 4.4.0 =>