View Issue Details

IDProjectCategoryView StatusLast Update
0001636Slicer4Core: Usabilitypublic2014-03-07 06:53
ReporterfedorovAssigned Toalexy 
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionreopened 
Product Version 
Target VersionFixed in Version 
Summary0001636: "Harden transform" on ROI is incorrect when tfm has rotation
Description

Hardening transform on ROI annotation is not handled correctly when the transform has a rotation component.

Additional Information

Attached are screenshots of the ROI before and after hardening. Appearance of the ROI widget in 3d viewer also changed.

TagsNo tags attached.

Relationships

related to 0002670 closedalexy Applying a transform to a ROI 

Activities

2011-12-19 12:16

 

2011-12-19 12:16

 

alexy

alexy

2013-08-09 11:49

developer   ~0009444

Since current 2D ROI widget implementation does not support local CS rotation, log an Error on ROI rotation attempt. Also made 3D ROI widget not to rotated on hardening transform to keep in sync with 2D widgets.
http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=22277

fedorov

fedorov

2013-08-09 15:11

developer   ~0009453

I do not understand the previous comment.

What does it mean "log an Error on ROI rotation attempt" ? At the very least, this should be a popup message. I do not see any errors in the error log -- but anyway who looks at the error log?

Can @pieper or someone comment on this? I am just not sure this is optimal. Can we disable hardening completely if there is rotation in the transform?

inorton

inorton

2013-09-06 06:24

developer   ~0009896

Bump. We need ROIs to support arbitrary rotations. The most useful ROIs are very often not RAS-aligned.

alexy

alexy

2013-09-17 05:21

developer   ~0009965

Sine there is no currently support for local transform in ROI (both MRML node and the widget) this project is too large for 4.3.1. Moving to future.

I am still not convinced the ROI has to support local transform since it works ok under MRML transform node (except for hardening). What is the use case when it presents a problem?

pieper

pieper

2014-03-07 06:32

administrator   ~0011330

Since ROIs are not inherently able to be hardened, probably we should add a CanBeHardened attribute or virtual method to vtkMRMLTransformableNode and set it true by default but false for ROIs. Then the popup menu could then disable the option contingent on this. This should be integrated with the nonlinear checks on hardening.

pieper

pieper

2014-03-07 06:37

administrator   ~0011331

Libs/MRML/Core/vtkMRMLROINode.h: virtual bool CanApplyNonLinearTransforms()const;

pieper

pieper

2014-03-07 06:38

administrator   ~0011332

This needs more work.

inorton

inorton

2014-03-07 06:53

developer   ~0011340

My comment on this issue was motivated by usage with the crop module. I wrote my own crop module that takes the parent rotation into account, so disabling "harden tfm" sounds good as it will eliminate any confusion. Thanks.

Issue History

Date Modified Username Field Change
2011-12-19 12:16 fedorov New Issue
2011-12-19 12:16 fedorov File Added: Screen shot 2011-12-19 at 9.15.18 .png
2011-12-19 12:16 fedorov File Added: Screen shot 2011-12-19 at 9.15.41 .png
2012-01-04 20:08 finetjul Status new => assigned
2012-01-04 20:08 finetjul Assigned To => alexy
2012-08-22 05:56 jcfr Target Version => Slicer 4.3.0
2012-10-25 13:31 millerjv Relationship added related to 0001959
2012-10-25 13:31 millerjv Relationship deleted related to 0001959
2012-12-18 05:43 alexy Relationship added related to 0002670
2013-08-09 11:49 alexy Note Added: 0009444
2013-08-09 11:49 alexy Status assigned => resolved
2013-08-09 11:49 alexy Resolution open => fixed
2013-08-09 15:11 fedorov Note Added: 0009453
2013-08-09 15:11 fedorov Status resolved => feedback
2013-08-09 15:11 fedorov Resolution fixed => reopened
2013-09-03 10:34 jcfr Target Version Slicer 4.3.0 => Slicer 4.3.1
2013-09-06 06:24 inorton Note Added: 0009896
2013-09-11 12:19 fedorov Status feedback => assigned
2013-09-17 05:21 alexy Note Added: 0009965
2013-09-17 05:21 alexy Target Version Slicer 4.3.1 => Slicer 4.4.0
2014-03-07 06:32 pieper Note Added: 0011330
2014-03-07 06:37 pieper Note Added: 0011331
2014-03-07 06:38 pieper Note Added: 0011332
2014-03-07 06:38 pieper Target Version Slicer 4.4.0 =>
2014-03-07 06:53 inorton Note Added: 0011340