View Issue Details

IDProjectCategoryView StatusLast Update
0001792Slicer4Core: GUIpublic2018-03-31 00:37
ReporterinortonAssigned Tofinetjul 
PrioritylowSeveritytweakReproducibilityN/A
Status confirmedResolutionopen 
PlatformOSMacOSXOS Version
Product Version 
Target VersionSlicer 4.11.0Fixed in Version 
Summary0001792: popup competes with modal dialog for priority
Description

ss1: save dialog
ss2: dragged save dialog down over slice view; persistent slice widget popup disappears

ss3: dragged save dialog back up above slice view -- save dialog disappears.

Additional Information

ss4: the file selector comes up "under" the slice widget popup.

TagsNo tags attached.

Relationships

has duplicate 0002474 closedfinetjul Popup window disappears if a slice view control is pinned 
related to 0001763 closedfinetjul Slide down menu to select background image and foreground image appears on top of other windows 
related to 0001768 closedfinetjul Toolbar popup cropped 
related to 0004426 acknowledged Changing window focus in OS moves focus from python sub-window 

Activities

2012-03-07 06:46

 

ss1.jpg (133,985 bytes)
ss1.jpg (133,985 bytes)

2012-03-07 06:47

 

ss2.jpg (130,588 bytes)
ss2.jpg (130,588 bytes)

2012-03-07 06:47

 

ss3.jpg (116,593 bytes)
ss3.jpg (116,593 bytes)

2012-03-07 06:47

 

ss4.jpg (119,644 bytes)
ss4.jpg (119,644 bytes)
inorton

inorton

2013-01-10 07:25

developer   ~0007655

Another example.

2013-01-10 07:26

 

slicer-bug.png (462,573 bytes)
slicer-bug.png (462,573 bytes)
finetjul

finetjul

2014-04-03 16:26

administrator   ~0011534

Fixed in r23044

inorton

inorton

2014-04-14 13:24

developer   ~0011591

The "Slicer competes with world" issue has been fixed, so now Slicer popups don't sit in front of other application windows when Slicer is thinking. This is great, thanks!!!

However the "Slicer competes with itself" in this specific issue report still exists. For example, the Save window can become hidden behind the main Slicer window; the only way to raise it again is to click on one of the slice viewer popups.

Windows x64, 2014-04-13 nightly

inorton

inorton

2014-04-23 08:19

developer   ~0011648

This is especially annoying with the DICOM query tool.

jcfr

jcfr

2014-09-26 17:33

administrator   ~0012600

@Julien: Do you have any "developer hint" that could help us address this particular issue ?

lassoan

lassoan

2017-09-27 12:03

developer   ~0015174

Cannot reproduce in Slicer 4.7.0-2017-09-26 on Windows10.

inorton

inorton

2017-09-29 10:50

developer   ~0015213

Still reproducible on Mac.



Picture1.png (110,846 bytes)
Picture1.png (110,846 bytes)
lassoan

lassoan

2017-09-29 11:00

developer   ~0015214

Thanks for testing. We'll revisit this after Qt5 migration.

Issue History

Date Modified Username Field Change
2012-03-07 06:46 inorton New Issue
2012-03-07 06:46 inorton Status new => assigned
2012-03-07 06:46 inorton Assigned To => finetjul
2012-03-07 06:46 inorton File Added: ss1.jpg
2012-03-07 06:47 inorton File Added: ss2.jpg
2012-03-07 06:47 inorton File Added: ss3.jpg
2012-03-07 06:47 inorton File Added: ss4.jpg
2012-03-07 06:47 inorton Summary popup competes with model dialog for priority => popup competes with modal dialog for priority
2012-03-12 05:42 finetjul Relationship added related to 0001763
2012-05-17 21:36 finetjul Tag Attached: ctkPopupWidget
2012-08-22 05:56 jcfr Target Version => Slicer 4.3.0
2012-09-10 23:47 finetjul Relationship added has duplicate 0002474
2013-01-10 07:25 inorton Note Added: 0007655
2013-01-10 07:26 inorton File Added: slicer-bug.png
2013-01-27 12:28 jcfr Tag Detached: ctkPopupWidget
2013-08-09 04:51 finetjul Target Version Slicer 4.3.0 => Slicer 4.4.0
2014-04-03 15:00 finetjul Relationship added related to 0001768
2014-04-03 16:26 finetjul Note Added: 0011534
2014-04-03 16:26 finetjul Status assigned => resolved
2014-04-03 16:26 finetjul Fixed in Version => Slicer 4.4.0
2014-04-03 16:26 finetjul Resolution open => fixed
2014-04-14 13:24 inorton Note Added: 0011591
2014-04-14 13:24 inorton Status resolved => feedback
2014-04-14 13:24 inorton Resolution fixed => reopened
2014-04-23 08:19 inorton Note Added: 0011648
2014-09-26 17:32 jcfr Target Version Slicer 4.4.0 => Slicer 4.4.1
2014-09-26 17:33 jcfr Note Added: 0012600
2015-09-09 08:29 jcfr Target Version Slicer 4.4.1 => Slicer 4.5.0-1
2015-11-02 11:27 jcfr Target Version Slicer 4.5.0-1 => Slicer 4.6.0
2016-10-12 04:33 jcfr Target Version Slicer 4.6.0 => Slicer 4.7.0
2017-09-27 12:03 lassoan Status feedback => resolved
2017-09-27 12:03 lassoan Resolution reopened => unable to reproduce
2017-09-27 12:03 lassoan Note Added: 0015174
2017-09-29 10:50 inorton File Added: Picture1.png
2017-09-29 10:50 inorton Note Added: 0015213
2017-09-29 11:00 lassoan Status resolved => confirmed
2017-09-29 11:00 lassoan Resolution unable to reproduce => open
2017-09-29 11:00 lassoan OS => MacOSX
2017-09-29 11:00 lassoan Fixed in Version Slicer 4.4.0 =>
2017-09-29 11:00 lassoan Target Version Slicer 4.7.0 => Slicer 4.9.0
2017-09-29 11:00 lassoan Note Added: 0015214
2017-09-29 11:31 inorton Relationship added related to 0004426
2018-03-31 00:37 jcfr Target Version Slicer 4.9.0 => Slicer 4.11.0