View Issue Details

IDProjectCategoryView StatusLast Update
0001839Slicer4Core: GUIpublic2014-09-10 11:13
ReporterkikinisAssigned Tojcfr 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
PlatformAppleOSOS XOS Version10.7.3
Product VersionSlicer 4.0.1 
Target VersionSlicer 4.4.0Fixed in VersionSlicer 4.4.0 
Summary0001839: cosmetics for the welcome module
Description

The welcome module needs updating after all the changes in Slicer 4.1:
-General: Each section should have a pointer to the corresponding wiki documentation at the top
-Loading and Saving: Explain the Load/Save toolbar. Then the file menu.
-Display: Should be renamed to Layouts. Remove all that overlaps with "The Main Window"
-Mouse&Keybord: We know what platform we are on. We should only display the mouse/keyboard actions for that platform. This means platform specific help? The current text is too wordy. Needs compression.
-Documentation and Tutorials: Just insert links to those two pages.

Tagshelp-wanted

Relationships

related to 0003832 resolvedjcfr Welcome: Documentation & Tutorial panel: Update and simplify 
related to 0003833 resolvedjcfr Welcome: Mouse&Keybord: Only display information for the current platform 
related to 0003834 resolvedpieper Welcome: Rename "Display" panel to "Layouts" 
related to 0003835 resolvedjcfr Welcome: Load&Save - Update icon 
related to 0003836 resolvedjcfr Welcome: Load&Save: Add missing entry and be more explicit. 
related to 0003837 resolvedjcfr Welcome: Each section should have a link to the associated wiki page. 
related to 0003230 acknowledgedpieper Welcome: Refactor the Welcome module to be only html. 

Activities

kikinis

kikinis

2012-03-27 03:51

developer   ~0003917

For instance, the mouse and Keyboard section on the Mac should look as follows:

Mouse and Keyboard bindings documentation (this would be the link)

Window & Level adjustment: Left-click and drag the mouse in any Slice viewer. Move the mouse up or down to adjust the level and left or right to adjust the window size. The Volumes Module provides a slider interface for more precise adjustments.

Cross reference: Hold down the Shift-Key while moving the mouse in any Slice Viewer will cause other Slice Viewers to scroll to the same position.

Zoom In & Out:
Mac with 3-Button Mouse: Right-Click & drag down & up
Mac with 2-Button Mouse: Right-Click & drag down & up
Mac with 1-Button Mouse: Ctrl+Left-Click & drag down & up (or two-finger click & drag in the trackpad)

Pan (Translate) in Slice & 3D Viewers:
Mac with 3-Button Mouse: Middle-Click & drag
Mac with 2-Button Mouse: Shift+Left-Click & drag
Mac with 1-Button Mouse: Shift+Left-Click & drag

Rotate in 3D Viewers:
Mac with 3-Button Mouse: Left-click & drag
Mac with 2-Button Mouse: Left-click & drag
Mac with 1-Button Mouse: Left-click & drag

kikinis

kikinis

2012-03-27 04:06

developer   ~0003918

I forgot:

Command & Left-click & drag in a Slice Viewer adjusts opacity.
Move the mouse up or down to adjust the the foreground opacity and left or right to adjust the labelmap opacity. The Slice View Controller provides a slider interface for more precise adjustments.

jcfr

jcfr

2014-09-10 11:12

administrator   ~0012501

Closing this issue because it is too general. Instead more specific issue capturing each problem have been created. It will allow to have more concise code change and facilitate the review process.

  • General: Each section should have a pointer to the corresponding wiki documentation at the top. This is now captured by issue 0003837

  • Loading and Saving: Explain the Load/Save toolbar. Then the file menu. This is now captured by issue 0003836, 0003835

  • Display: Should be renamed to Layouts. Remove all that overlaps with "The Main Window". This is now captured by 0003834

  • Mouse&Keybord: We know what platform we are on. We should only display the mouse/keyboard actions for that platform. This means platform specific help? The current text is too wordy. Needs compression. This is now captured by 0003833

  • Documentation and Tutorials: Just insert links to those two pages. This is now captured by 0003832

  • Update to shortcut documentation added in r18585

  • Update mentioning cross reference added in r18573

Issue History

Date Modified Username Field Change
2012-03-27 03:37 kikinis New Issue
2012-03-27 03:37 kikinis Status new => assigned
2012-03-27 03:37 kikinis Assigned To => finetjul
2012-03-27 03:51 kikinis Note Added: 0003917
2012-03-27 04:06 kikinis Note Added: 0003918
2012-03-27 06:03 finetjul Assigned To finetjul => wjp
2012-08-22 05:56 jcfr Target Version => Slicer 4.3.0
2013-07-05 06:36 pieper Target Version Slicer 4.3.0 => Slicer 4.4.0
2013-07-16 15:31 jcfr Relationship added related to 0003230
2013-07-16 15:33 jcfr Assigned To wjp => yuzheng
2014-05-13 15:41 jcfr Assigned To yuzheng => jcfr
2014-05-13 15:42 jcfr Tag Attached: help-wanted
2014-09-10 11:12 jcfr Note Added: 0012501
2014-09-10 11:12 jcfr Status assigned => resolved
2014-09-10 11:12 jcfr Fixed in Version => Slicer 4.4.0
2014-09-10 11:12 jcfr Resolution open => fixed
2014-09-10 11:12 jcfr Relationship added related to 0003832
2014-09-10 11:13 jcfr Relationship added related to 0003833
2014-09-10 11:13 jcfr Relationship added related to 0003834
2014-09-10 11:13 jcfr Relationship added related to 0003835
2014-09-10 11:13 jcfr Relationship added related to 0003836
2014-09-10 11:13 jcfr Relationship added related to 0003837
2014-09-10 11:13 jcfr Status resolved => closed