View Issue Details

IDProjectCategoryView StatusLast Update
0001930Slicer4Core: Usabilitypublic2017-06-07 23:27
ReporterfedorovAssigned Topieper 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionSlicer 4.4.0Fixed in VersionSlicer 4.3.0 
Summary0001930: Scrolling volume slices past the last slice
Description

I noticed that if I scroll to the first or last slice in the volume, and then press arrow key to go beyond that, the slice turns black, although the slice position reported in the slice viewer control next to the slider remains the same.

I think it would be more friendly and intuitive behavior if pressing arrow key at the last slice would not change the slice display.

TagsNo tags attached.

Relationships

parent of 0003263 closedpieper Slice view not updated on Rotate to volume 
parent of 0003264 assignedpieper Scrolling past first/last slice 
Not all the children of this issue are yet resolved or closed.

Activities

2012-04-23 15:23

 

2012-04-23 15:23

 

pieper

pieper

2013-07-09 04:43

administrator   ~0008921

Hi Andrey - Please test this one out with your off-axis prostate datasets and make sure you can still get to the edges of the volumes.

http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=22157

fedorov

fedorov

2013-07-11 13:07

developer   ~0009015

Steve, the issue is not resolved. See the demo here: https://www.dropbox.com/s/hsb0t4qxnw1ys8o/issue1930_demo.mov

When I scroll past last (and now also - first) slice in the volume, the scroller does not stop, and I have black/gray slice.

Also, a separate perhaps issue - when I click "Rotate to volume plane" button, the slice does not update until I move the slider. Is this a known bug? Demonstrated in the beginning of the video.

fedorov

fedorov

2013-07-11 13:08

developer   ~0009016

Tilted T2 axial is available in the RSNA prostate demo MRB.

pieper

pieper

2013-07-12 07:25

administrator   ~0009024

Hi Andrey -

The two issues are are both different from the original one for this report. This report was about the arrow keys and scroll wheel going past the end. Can you doublecheck that one?

The other two issues should be fixed as well - can you make independent reports for them?

Thanks,
Steve

pieper

pieper

2013-07-30 11:23

administrator   ~0009282

Rotate to slice plane fixed with r22248

pieper

pieper

2013-07-30 11:43

administrator   ~0009284

Regarding the other issue raised by @fedorov - it's true that for rotated volumes the slider's extent goes beyond the volume. This should be trimmed back so that it corresponds to the end of the volume, but this seems like a minor issue. Currently the slider always includes the full volume plus a margin; it would be worse if it cut off some of the volume.

So I will keep this bug open, but re-target it for 4.4 since the remaining issue is low priority.

fedorov

fedorov

2013-07-31 06:22

developer   ~0009295

Steve: independent reports for the two other issues raised have been submitted.

pieper

pieper

2013-07-31 09:34

administrator   ~0009304

Closing this since the original issue is fixed and new child issues exist.

Related Changesets

Slicer: 2145-support-for-installing-extension-from-file ba0eff3e

2013-07-30 15:23:06

pieper

Details Diff
BUG: 0001930 ensure redraw after rotate to volume plane

Make sure matrices reflect current orientation of the slice
plane.

git-svn-id: http://svn.slicer.org/Slicer4/trunk@22248 3bd1e089-480b-0410-8dfb-8563597acbee
mod - Libs/MRML/Core/vtkMRMLSliceNode.cxx Diff File

Issue History

Date Modified Username Field Change
2012-04-23 15:23 fedorov New Issue
2012-04-23 15:23 fedorov File Added: Screen shot 2012-04-23 at 19.22.41 .png
2012-04-23 15:23 fedorov File Added: Screen shot 2012-04-23 at 19.22.53 .png
2012-08-20 07:52 nicole Assigned To => pieper
2012-08-20 07:52 nicole Status new => assigned
2012-08-20 07:52 nicole Target Version => Slicer 4.3.0
2013-07-09 04:43 pieper Note Added: 0008921
2013-07-09 04:43 pieper Status assigned => resolved
2013-07-09 04:43 pieper Fixed in Version => Slicer 4.3.0
2013-07-09 04:43 pieper Resolution open => fixed
2013-07-11 13:07 fedorov Note Added: 0009015
2013-07-11 13:07 fedorov Status resolved => feedback
2013-07-11 13:07 fedorov Resolution fixed => reopened
2013-07-11 13:08 fedorov Note Added: 0009016
2013-07-12 07:25 pieper Note Added: 0009024
2013-07-30 11:23 pieper Note Added: 0009282
2013-07-30 11:43 pieper Note Added: 0009284
2013-07-30 11:43 pieper Fixed in Version Slicer 4.3.0 =>
2013-07-30 11:43 pieper Target Version Slicer 4.3.0 => Slicer 4.4.0
2013-07-31 06:20 fedorov Relationship added parent of 0003263
2013-07-31 06:21 fedorov Relationship added parent of 0003264
2013-07-31 06:22 fedorov Note Added: 0009295
2013-07-31 09:34 pieper Note Added: 0009304
2013-07-31 09:34 pieper Status feedback => closed
2013-07-31 09:34 pieper Resolution reopened => fixed
2013-07-31 09:34 pieper Fixed in Version => Slicer 4.3.0
2017-06-07 23:27 pieper Changeset attached => Slicer 2145-support-for-installing-extension-from-file ba0eff3e