View Issue Details

IDProjectCategoryView StatusLast Update
0001996Slicer4Module VolumeRenderingpublic2018-05-26 22:20
ReporterkikinisAssigned Tolassoan 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformAppleOSOS XOS Version10.7.3
Product VersionSlicer 4.1.0 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.9.0 
Summary0001996: the vtk gpu raycaster does not render in full quality
Description

see attached. Both engines were set to render at maximum quality. the vtk gpu renders the same way no matter what setting I choose.

TagsNo tags attached.

Relationships

duplicate of 0001752 resolvedfinetjul volume rendering is adaptive, even if the quality control is set to maximum 

Activities

2012-05-08 02:02

 

2012-05-08 02:02

 

kikinis

kikinis

2012-05-08 02:03

developer   ~0004193

you have to look at the images at their full resolution in order to appreciate the difference.

jcfr

jcfr

2014-05-13 10:41

administrator   ~0011778

As discussed during May 13th hangout, considering you focus on VTK6 integration. We are re-targeting this issue for 4.5 release.

In case you plan on addressing some of these for 4.4, consider re-targeting.

lassoan

lassoan

2017-07-25 22:38

developer   ~0014986

Re-evaluate this after Slicer switches to VTK8.

jcfr

jcfr

2018-03-03 00:55

administrator   ~0015523

@kikinis Using the nightly build, is this still an issue ?

kikinis

kikinis

2018-03-03 11:12

developer   ~0015525

This particular issue is gone. However, when I switch from GPU to CPU Volume rendering, the rendering gets darker

lassoan

lassoan

2018-03-03 11:35

developer   ~0015526

Last edited: 2018-03-03 11:35

View 2 revisions

I still see a very significant difference in image quality when I switch between adaptive/max quality. See attached files.

lassoan

lassoan

2018-03-03 11:36

developer  

lassoan

lassoan

2018-03-03 11:37

developer  

lassoan

lassoan

2018-03-03 11:40

developer   ~0015527

The screenshots above were created on Windows 10, latest nightly build downloaded from download.slicer.org.
CTACardio sample data set, CT-Cardiac3 preset.

lassoan

lassoan

2018-03-03 11:51

developer   ~0015528

Somewhat related: on my laptop (Windows 10, Surface book), if I switch to 3D-only layout and enable maximum quality volume rendering, then the application windows stops updating. Popups are still displayed, mouse cursor changes shape, etc. but no content update. The same problem is not reproducible on my desktop (Windows 10, NVidia GTX 1060).

lassoan

lassoan

2018-05-26 22:19

developer   ~0015743

We've switched to VTK9 and improved rendering techniques (adaptive, normal, maximum quality). Adaptive and normal should provide very good quality rendering for general use, while maximum quality can be used for generating screenshots.

Issue History

Date Modified Username Field Change
2012-05-08 02:02 kikinis New Issue
2012-05-08 02:02 kikinis Status new => assigned
2012-05-08 02:02 kikinis Assigned To => finetjul
2012-05-08 02:02 kikinis File Added: VTK-GPU 2012-05-08 at 5.58.12 PM.png
2012-05-08 02:02 kikinis File Added: NCI-GPU 2012-05-08 at 5.57.51 PM.png
2012-05-08 02:03 kikinis Note Added: 0004193
2012-08-22 05:56 jcfr Target Version => Slicer 4.3.0
2013-08-09 04:28 finetjul Relationship added duplicate of 0001752
2013-08-27 11:58 jcfr Target Version Slicer 4.3.0 => Slicer 4.4.0
2014-05-13 10:41 jcfr Note Added: 0011778
2014-05-13 10:44 jcfr Target Version Slicer 4.4.0 =>
2017-07-25 22:38 lassoan Target Version => Slicer 4.9.0
2017-07-25 22:38 lassoan Note Added: 0014986
2018-03-03 00:55 jcfr Note Added: 0015523
2018-03-03 00:55 jcfr Status assigned => feedback
2018-03-03 00:55 jcfr Assigned To finetjul => jcfr
2018-03-03 11:12 kikinis Note Added: 0015525
2018-03-03 11:12 kikinis Status feedback => assigned
2018-03-03 11:35 lassoan Note Added: 0015526
2018-03-03 11:35 lassoan Note Edited: 0015526 View Revisions
2018-03-03 11:36 lassoan File Added: VolumeRenderingAdaptive-Slicer-4.9.0-2018-03-02.png
2018-03-03 11:37 lassoan File Added: VolumeRenderingMaxQuality-Slicer-4.9.0-2018-03-02.png
2018-03-03 11:40 lassoan Note Added: 0015527
2018-03-03 11:51 lassoan Note Added: 0015528
2018-05-26 22:19 lassoan Assigned To jcfr => lassoan
2018-05-26 22:19 lassoan Status assigned => resolved
2018-05-26 22:19 lassoan Resolution open => duplicate
2018-05-26 22:19 lassoan Fixed in Version => Slicer 4.9.0
2018-05-26 22:19 lassoan Note Added: 0015743
2018-05-26 22:20 lassoan Resolution duplicate => fixed