View Issue Details

IDProjectCategoryView StatusLast Update
0000020Slicer3MRMLpublic2017-06-10 08:51
ReporterspujolAssigned Toalexy 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Summary0000020: Importing an xml scene tutorial.xml crashes Slicer3
Description

I tried to import the tutorial scene tutorial.xml from the training dataset tutorial-with-dicom of the Slicer 101 page: Slicer crashes and I have to kill the process to exit the software.

Additional Information

version 3.0.2007.01.17 on Windows XP

TagsNo tags attached.

Activities

hayes

hayes

2007-01-31 10:11

administrator   ~0000030

I was able to reproduce this problem with a 1/31 build of Slicer3 on Linux 64. I didn't have to kill the process; it segfaulted for me.

alexy

alexy

2007-02-06 15:44

developer   ~0000036

Fixed loading volumes, added model colors and volumes selection

hayes

hayes

2007-02-12 13:16

administrator   ~0000037

Loading tutorial.xml no longer crashes Slicer3.

Related Changesets

Slicer: 2145-support-for-installing-extension-from-file 29a04b80

2013-11-04 16:04:45

jcfr

Details Diff
BUG: OpenIGTLink - Fixes issue 0003454 - could not receive LBMETA messages.

// -------------------------
OpenIGTLink updates:

Bonny Biswas (2):
ENH: Added set/get methods for coordinate system in ImageMessage classes
BUG: LPS coordinate system value in ImageMessage does not match protocol

Isaiah Norton (2):
ENH: add StringEchoServer example
ENH: add PointListServer example

Junichi Tokuda (41):
ENH: start implementing session manager
ENH: MessageHandler and SessionManager classes are implemented and now working. Template-based MessageHandler class has been removed.
STYLE: adding comment in the source code for SessionManagerServer example program.
ENH: implement session manager with pseudo non-blocking messaging (receive only)
Merge pull request 0000003 from lchauvin/patch-1
Merge pull request 0000004 from lchauvin/patch-1
ENH: added the second argument for Process() in the message handler class to share data between the message handler class and other classes/functions outside the class.
Solve conflict.
ENH: Adding CapabilityMessage class
ENH: Adding the capability message type and examples.
ENH: Merging the fixes in the master branch to the development branch.
BUG: Fixed the compile error caused by the last commit.
STYLE: Merging the master repository with improved comments for Doxygen.
STYLE: Merge changes in the master repository.
STYLE: Merge updates in the master repository.
STYLE: Merge master repository.
ENH: Add igtlCreateDefaultQueryMessageClass() macro to help defining a class for query message.
ENH: Create HeaderOnlyMessageBase as a base class for query message types.
BUG: merge labonny's changes
Merge pull request 0000013 from perim/master
BUG: Fix Issue 0000014 Linker error in VS2012.
STYLE: Fix wrong statement in help (coordinate -> string)
Merge pull request 0000018 from ihnorton/add_pointlistserver_example
ENH: Add a class for GET_STATUS message type.
ENH: Add TrajectoryMessage example.
ENH: Merge changes in master.
STYLE: Fixed revision number
COMP: Fix warning 'converting to non-pointer type int from NULL'.
STYLE: Update version number.
ENH: Merge github.com:tokjun/OpenIGTLink.git.
BUG: Avoid * ((igtl_uint16 *) ptr) = <value> to address issue 0000020. Need testing.
STYLE: Format README using Markdown
STYLE: Rename README to README.md
BUG: Address issue 0000021.. replace this->m_DefaultBodyType = this->DefaultBodyType() with this->m_DefaultBodyType = ""
BUG: Reset changes in Example/Status/StatusClient
BUG: Fixing Issue 0000020. 'signed' is explicitly specified for igtl_int8. Tested on Ubuntu + armv7l.
STYLE: Use C-style comments in .c files.
Merge pull request 0000022 from tokjun/master
ENH: Add LBMETA message to ImageDatabaseServer example.
BUG: Fixed bug in LabelMetaMessage. It could not extract owner image information from a LBMETA message.
Merge pull request 0000024 from tokjun/23-LBMETA-example

Laurent Chauvin (3):
Modified GetMode method
Add igtlMessageHandlerMacro.h to the list of files
ENH: Removed the sleep

Per Inge Mathisen (3):
Fix wrong use of delete operator
Fix wrong bitwise and operator
Fix compile warnings under clang

// -------------------------
OpenIGTLinkIF updates:

Isaiah Norton (1):
COMP: partially fix 0000009, and a leak

Junichi Tokuda (3):
Merge pull request 0000010 from ihnorton/issue9_partial_fix
ENH: Implement LableMetaList function. This commit requires OpenIGTLink library commit 661d4bd.
Merge pull request 0000012 from tokjun/0003454-lbmeta

From: Jean-Christophe Fillion-Robin <jchris.fillionr@kitware.com>

git-svn-id: http://svn.slicer.org/Slicer4/trunk@22679 3bd1e089-480b-0410-8dfb-8563597acbee
mod - SuperBuild/External_OpenIGTLink.cmake Diff File
mod - SuperBuild/External_OpenIGTLinkIF.cmake Diff File

Import 2017-06-07 23:51:09: master 29a04b80

2013-11-04 16:04:45

jcfr

Details Diff
BUG: OpenIGTLink - Fixes issue 0003454 - could not receive LBMETA messages.

// -------------------------
OpenIGTLink updates:

Bonny Biswas (2):
ENH: Added set/get methods for coordinate system in ImageMessage classes
BUG: LPS coordinate system value in ImageMessage does not match protocol

Isaiah Norton (2):
ENH: add StringEchoServer example
ENH: add PointListServer example

Junichi Tokuda (41):
ENH: start implementing session manager
ENH: MessageHandler and SessionManager classes are implemented and now working. Template-based MessageHandler class has been removed.
STYLE: adding comment in the source code for SessionManagerServer example program.
ENH: implement session manager with pseudo non-blocking messaging (receive only)
Merge pull request 0000003 from lchauvin/patch-1
Merge pull request 0000004 from lchauvin/patch-1
ENH: added the second argument for Process() in the message handler class to share data between the message handler class and other classes/functions outside the class.
Solve conflict.
ENH: Adding CapabilityMessage class
ENH: Adding the capability message type and examples.
ENH: Merging the fixes in the master branch to the development branch.
BUG: Fixed the compile error caused by the last commit.
STYLE: Merging the master repository with improved comments for Doxygen.
STYLE: Merge changes in the master repository.
STYLE: Merge updates in the master repository.
STYLE: Merge master repository.
ENH: Add igtlCreateDefaultQueryMessageClass() macro to help defining a class for query message.
ENH: Create HeaderOnlyMessageBase as a base class for query message types.
BUG: merge labonny's changes
Merge pull request 0000013 from perim/master
BUG: Fix Issue 0000014 Linker error in VS2012.
STYLE: Fix wrong statement in help (coordinate -> string)
Merge pull request 0000018 from ihnorton/add_pointlistserver_example
ENH: Add a class for GET_STATUS message type.
ENH: Add TrajectoryMessage example.
ENH: Merge changes in master.
STYLE: Fixed revision number
COMP: Fix warning 'converting to non-pointer type int from NULL'.
STYLE: Update version number.
ENH: Merge github.com:tokjun/OpenIGTLink.git.
BUG: Avoid * ((igtl_uint16 *) ptr) = <value> to address issue 0000020. Need testing.
STYLE: Format README using Markdown
STYLE: Rename README to README.md
BUG: Address issue 0000021.. replace this->m_DefaultBodyType = this->DefaultBodyType() with this->m_DefaultBodyType = ""
BUG: Reset changes in Example/Status/StatusClient
BUG: Fixing Issue 0000020. 'signed' is explicitly specified for igtl_int8. Tested on Ubuntu + armv7l.
STYLE: Use C-style comments in .c files.
Merge pull request 0000022 from tokjun/master
ENH: Add LBMETA message to ImageDatabaseServer example.
BUG: Fixed bug in LabelMetaMessage. It could not extract owner image information from a LBMETA message.
Merge pull request 0000024 from tokjun/23-LBMETA-example

Laurent Chauvin (3):
Modified GetMode method
Add igtlMessageHandlerMacro.h to the list of files
ENH: Removed the sleep

Per Inge Mathisen (3):
Fix wrong use of delete operator
Fix wrong bitwise and operator
Fix compile warnings under clang

// -------------------------
OpenIGTLinkIF updates:

Isaiah Norton (1):
COMP: partially fix 0000009, and a leak

Junichi Tokuda (3):
Merge pull request 0000010 from ihnorton/issue9_partial_fix
ENH: Implement LableMetaList function. This commit requires OpenIGTLink library commit 661d4bd.
Merge pull request 0000012 from tokjun/0003454-lbmeta

From: Jean-Christophe Fillion-Robin <jchris.fillionr@kitware.com>

git-svn-id: http://svn.slicer.org/Slicer4/trunk@22679 3bd1e089-480b-0410-8dfb-8563597acbee
mod - SuperBuild/External_OpenIGTLink.cmake Diff File
mod - SuperBuild/External_OpenIGTLinkIF.cmake Diff File

Issue History

Date Modified Username Field Change
2007-01-30 08:13 spujol New Issue
2007-01-31 10:11 hayes Note Added: 0000030
2007-01-31 10:11 hayes Status new => confirmed
2007-01-31 10:11 hayes Summary Importing an xml scene => Importing an xml scene tutorial.xml crashes Slicer3
2007-02-05 11:21 pieper Assigned To => alexy
2007-02-06 15:44 alexy Note Added: 0000036
2007-02-06 15:44 alexy Resolution open => fixed
2007-02-12 13:16 hayes Status confirmed => closed
2007-02-12 13:16 hayes Note Added: 0000037
2017-06-07 23:27 jcfr Changeset attached => Slicer 2145-support-for-installing-extension-from-file 29a04b80
2017-06-10 08:51 jcfr Changeset attached => Slicer master 29a04b80