View Issue Details

IDProjectCategoryView StatusLast Update
0002014Slicer4Module DICOMpublic2017-10-06 16:57
ReporterinortonAssigned Tomehrtash 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionSlicer 4.7.0Fixed in VersionSlicer 4.7.0 
Summary0002014: allow selection of subset of directories for dicom import
Description

I'd like to be able to select subsets of directories to import. our top-level directories frequently have 10000+ images in 8-12 subdirectories, so I don't want to import the whole top level directory. At present I need to select each of the 4-7 subdirectories I actually want, one at a time, wait 30-60s for import to complete, then select the next one, etc.

It would be very helpful to be able to select a set of subdirectories at the main "import dicom files from directory prompt"

TagsNo tags attached.

Relationships

related to 0002818 closedmehrtash make the 'copy on import' checkbox more obvious on dicom import dialog 

Activities

pieper

pieper

2013-07-08 10:32

administrator   ~0008898

This would need to be changed in CTK. Looks like it's possible to multi-select directories:

http://qt-project.org/forums/viewthread/10291

http://qt-project.org/doc/qt-4.8/qfiledialog.html#filesSelected

pieper

pieper

2014-03-06 12:26

administrator   ~0011276

Alireza - this should be fairly easy but is not as critical as some of the other issues - so it's a 'nice to have' for the release.

jcfr

jcfr

2017-10-05 15:10

administrator   ~0015256

See https://github.com/commontk/CTK/pull/753

jcfr

jcfr

2017-10-06 16:57

administrator   ~0015275

Fixed in r26428
See http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=26428

Issue History

Date Modified Username Field Change
2012-05-10 16:46 inorton New Issue
2012-05-10 16:46 inorton Status new => assigned
2012-05-10 16:46 inorton Assigned To => pieper
2012-08-22 05:56 jcfr Target Version => Slicer 4.3.0
2013-07-08 10:32 pieper Note Added: 0008898
2013-08-29 11:13 pieper Target Version Slicer 4.3.0 => Slicer 4.4.0
2014-03-06 12:25 pieper Assigned To pieper => mehrtash
2014-03-06 12:26 pieper Note Added: 0011276
2014-03-07 09:22 pieper Relationship added related to 0002818
2014-09-25 12:51 jcfr Target Version Slicer 4.4.0 => Slicer 4.4.1
2015-09-09 08:28 jcfr Target Version Slicer 4.4.1 => Slicer 4.5.0-1
2015-11-02 11:27 jcfr Target Version Slicer 4.5.0-1 => Slicer 4.6.0
2016-10-12 14:42 jcfr Target Version Slicer 4.6.0 => Slicer 4.7.0
2017-10-05 15:10 jcfr Note Added: 0015256
2017-10-05 15:11 jcfr Status assigned => feedback
2017-10-06 16:57 jcfr Status feedback => resolved
2017-10-06 16:57 jcfr Resolution open => fixed
2017-10-06 16:57 jcfr Fixed in Version => Slicer 4.7.0
2017-10-06 16:57 jcfr Note Added: 0015275