View Issue Details

IDProjectCategoryView StatusLast Update
0000021Slicer3GUIpublic2017-06-10 08:51
ReporterkikinisAssigned Towjp 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinux 64OSOS Version
Summary0000021: Clicking the full screen icon doesn't work on Linux 64
Description

Clicking the full screen icon doesn't work on Linux 64. (Reported by Ron)

TagsNo tags attached.

Activities

barre

barre

2007-02-01 08:31

developer   ~0000032

I can not reproduce it on my Linux system.

barre

barre

2007-03-28 05:49

developer   ~0000080

I've never seen that problem occurring on any of my systems.
I just tried on different Linux, including a Linux 64, and it maximimizes just fine on them.

Now remember that the maximizing is not done by the application, we don't have any code for that per se, it's not actually even done by Tk, it's a task that is left to the window manager: you may be running Gnome or KDE, and that is the component responsible for drawing the window decoration, the maximize/minimize buttons, and the corresponding functionalities.

The only unknown here is the size of the screen, which I've heard is huge. It could be possible that this version of your window manager just can not handle such a large resolution (is it about 2500x1024?). When maximizing, the window manager may find that value either too large to be "real" and not do anything besides disabling the button, or maybe there isn't enough resources to create such a large window with a 3D context, I don't really know, but this is possible.

One thing you could do:

  • take a "normal" screen, hook it up to that Linux 64 system, reboot, check that screen resolution is back to normal (say around 1200x1024), and try maximizing. That sounds like a valid test to perform.

And here are a few other tidbits that would help:

  • on the big screen, try creating any Tk window/toplevel, and see if it maximizes
  • report the Linux version and operating system kernel
  • which version of KDE or Gnome are you using so that we can google if people have reported such problems on large screen as well
  • make sure you are using the Tcl/Tk in Slicer3, i.e. that Slicer3 is not picking another shared library (try 'ldd')
wjp

wjp

2007-03-28 10:58

administrator   ~0000082

I've tried a few things this morning using:

  • Linux-64 (fedora)
  • KDE 3.0
  • Gnome 2.14.3
  • monitor has resolution 1900x1200, can be reset to 1280x1024:

The same results occur with KDE and Gnome. Using KDE,
Slicer's and KWWidgetTourExample's windows don't display
the 'maximize' icon, and the option to maximize is disabled
in the window's pulldown. Tk toplevels (and other application
windows) appear fine. Here's the rundown:

                            MAXIMIZE?  

Slicer3 with 1900x1200 no
Slicer3 with 1280x1024 no
KWWidgetsTour with 1900x1200 no
KWWidgetsTour with 1280x1024 no
tk toplevel with 1900x1200 yes
tk toplevel with 1280x1024 yes
other application windows yes

wjp

wjp

2007-03-28 11:17

administrator   ~0000083

One additional experiment: Slicer2 also runs under KDE with the same problem! I get a Slicer2 window without a maximize icon, and with no maximize option in the pulldown.

wjp

wjp

2007-03-29 10:32

administrator   ~0000086

We've determined that this is a problem with the Tcl/Tk version we're using with Slicer3. (The problem seems to have been fixed in Tcl/Tk 8.4.7). Rather than move to a new version of Tcl/Tk before release, we've decided to defer this until we have a chance to test it out on all platforms.

pieper

pieper

2007-11-20 09:16

administrator   ~0000147

Related to the version of Tk - need to doublecheck. getbuildtest2 uses latest TK and need to move that to the release getbuildtest also.

Related Changesets

Slicer: 2145-support-for-installing-extension-from-file 29a04b80

2013-11-04 16:04:45

jcfr

Details Diff
BUG: OpenIGTLink - Fixes issue 0003454 - could not receive LBMETA messages.

// -------------------------
OpenIGTLink updates:

Bonny Biswas (2):
ENH: Added set/get methods for coordinate system in ImageMessage classes
BUG: LPS coordinate system value in ImageMessage does not match protocol

Isaiah Norton (2):
ENH: add StringEchoServer example
ENH: add PointListServer example

Junichi Tokuda (41):
ENH: start implementing session manager
ENH: MessageHandler and SessionManager classes are implemented and now working. Template-based MessageHandler class has been removed.
STYLE: adding comment in the source code for SessionManagerServer example program.
ENH: implement session manager with pseudo non-blocking messaging (receive only)
Merge pull request 0000003 from lchauvin/patch-1
Merge pull request 0000004 from lchauvin/patch-1
ENH: added the second argument for Process() in the message handler class to share data between the message handler class and other classes/functions outside the class.
Solve conflict.
ENH: Adding CapabilityMessage class
ENH: Adding the capability message type and examples.
ENH: Merging the fixes in the master branch to the development branch.
BUG: Fixed the compile error caused by the last commit.
STYLE: Merging the master repository with improved comments for Doxygen.
STYLE: Merge changes in the master repository.
STYLE: Merge updates in the master repository.
STYLE: Merge master repository.
ENH: Add igtlCreateDefaultQueryMessageClass() macro to help defining a class for query message.
ENH: Create HeaderOnlyMessageBase as a base class for query message types.
BUG: merge labonny's changes
Merge pull request 0000013 from perim/master
BUG: Fix Issue 0000014 Linker error in VS2012.
STYLE: Fix wrong statement in help (coordinate -> string)
Merge pull request 0000018 from ihnorton/add_pointlistserver_example
ENH: Add a class for GET_STATUS message type.
ENH: Add TrajectoryMessage example.
ENH: Merge changes in master.
STYLE: Fixed revision number
COMP: Fix warning 'converting to non-pointer type int from NULL'.
STYLE: Update version number.
ENH: Merge github.com:tokjun/OpenIGTLink.git.
BUG: Avoid * ((igtl_uint16 *) ptr) = <value> to address issue 0000020. Need testing.
STYLE: Format README using Markdown
STYLE: Rename README to README.md
BUG: Address issue 0000021.. replace this->m_DefaultBodyType = this->DefaultBodyType() with this->m_DefaultBodyType = ""
BUG: Reset changes in Example/Status/StatusClient
BUG: Fixing Issue 0000020. 'signed' is explicitly specified for igtl_int8. Tested on Ubuntu + armv7l.
STYLE: Use C-style comments in .c files.
Merge pull request 0000022 from tokjun/master
ENH: Add LBMETA message to ImageDatabaseServer example.
BUG: Fixed bug in LabelMetaMessage. It could not extract owner image information from a LBMETA message.
Merge pull request 0000024 from tokjun/23-LBMETA-example

Laurent Chauvin (3):
Modified GetMode method
Add igtlMessageHandlerMacro.h to the list of files
ENH: Removed the sleep

Per Inge Mathisen (3):
Fix wrong use of delete operator
Fix wrong bitwise and operator
Fix compile warnings under clang

// -------------------------
OpenIGTLinkIF updates:

Isaiah Norton (1):
COMP: partially fix 0000009, and a leak

Junichi Tokuda (3):
Merge pull request 0000010 from ihnorton/issue9_partial_fix
ENH: Implement LableMetaList function. This commit requires OpenIGTLink library commit 661d4bd.
Merge pull request 0000012 from tokjun/0003454-lbmeta

From: Jean-Christophe Fillion-Robin <jchris.fillionr@kitware.com>

git-svn-id: http://svn.slicer.org/Slicer4/trunk@22679 3bd1e089-480b-0410-8dfb-8563597acbee
mod - SuperBuild/External_OpenIGTLink.cmake Diff File
mod - SuperBuild/External_OpenIGTLinkIF.cmake Diff File

Import 2017-06-07 23:51:09: master 29a04b80

2013-11-04 16:04:45

jcfr

Details Diff
BUG: OpenIGTLink - Fixes issue 0003454 - could not receive LBMETA messages.

// -------------------------
OpenIGTLink updates:

Bonny Biswas (2):
ENH: Added set/get methods for coordinate system in ImageMessage classes
BUG: LPS coordinate system value in ImageMessage does not match protocol

Isaiah Norton (2):
ENH: add StringEchoServer example
ENH: add PointListServer example

Junichi Tokuda (41):
ENH: start implementing session manager
ENH: MessageHandler and SessionManager classes are implemented and now working. Template-based MessageHandler class has been removed.
STYLE: adding comment in the source code for SessionManagerServer example program.
ENH: implement session manager with pseudo non-blocking messaging (receive only)
Merge pull request 0000003 from lchauvin/patch-1
Merge pull request 0000004 from lchauvin/patch-1
ENH: added the second argument for Process() in the message handler class to share data between the message handler class and other classes/functions outside the class.
Solve conflict.
ENH: Adding CapabilityMessage class
ENH: Adding the capability message type and examples.
ENH: Merging the fixes in the master branch to the development branch.
BUG: Fixed the compile error caused by the last commit.
STYLE: Merging the master repository with improved comments for Doxygen.
STYLE: Merge changes in the master repository.
STYLE: Merge updates in the master repository.
STYLE: Merge master repository.
ENH: Add igtlCreateDefaultQueryMessageClass() macro to help defining a class for query message.
ENH: Create HeaderOnlyMessageBase as a base class for query message types.
BUG: merge labonny's changes
Merge pull request 0000013 from perim/master
BUG: Fix Issue 0000014 Linker error in VS2012.
STYLE: Fix wrong statement in help (coordinate -> string)
Merge pull request 0000018 from ihnorton/add_pointlistserver_example
ENH: Add a class for GET_STATUS message type.
ENH: Add TrajectoryMessage example.
ENH: Merge changes in master.
STYLE: Fixed revision number
COMP: Fix warning 'converting to non-pointer type int from NULL'.
STYLE: Update version number.
ENH: Merge github.com:tokjun/OpenIGTLink.git.
BUG: Avoid * ((igtl_uint16 *) ptr) = <value> to address issue 0000020. Need testing.
STYLE: Format README using Markdown
STYLE: Rename README to README.md
BUG: Address issue 0000021.. replace this->m_DefaultBodyType = this->DefaultBodyType() with this->m_DefaultBodyType = ""
BUG: Reset changes in Example/Status/StatusClient
BUG: Fixing Issue 0000020. 'signed' is explicitly specified for igtl_int8. Tested on Ubuntu + armv7l.
STYLE: Use C-style comments in .c files.
Merge pull request 0000022 from tokjun/master
ENH: Add LBMETA message to ImageDatabaseServer example.
BUG: Fixed bug in LabelMetaMessage. It could not extract owner image information from a LBMETA message.
Merge pull request 0000024 from tokjun/23-LBMETA-example

Laurent Chauvin (3):
Modified GetMode method
Add igtlMessageHandlerMacro.h to the list of files
ENH: Removed the sleep

Per Inge Mathisen (3):
Fix wrong use of delete operator
Fix wrong bitwise and operator
Fix compile warnings under clang

// -------------------------
OpenIGTLinkIF updates:

Isaiah Norton (1):
COMP: partially fix 0000009, and a leak

Junichi Tokuda (3):
Merge pull request 0000010 from ihnorton/issue9_partial_fix
ENH: Implement LableMetaList function. This commit requires OpenIGTLink library commit 661d4bd.
Merge pull request 0000012 from tokjun/0003454-lbmeta

From: Jean-Christophe Fillion-Robin <jchris.fillionr@kitware.com>

git-svn-id: http://svn.slicer.org/Slicer4/trunk@22679 3bd1e089-480b-0410-8dfb-8563597acbee
mod - SuperBuild/External_OpenIGTLink.cmake Diff File
mod - SuperBuild/External_OpenIGTLinkIF.cmake Diff File

Issue History

Date Modified Username Field Change
2007-01-30 09:20 hayes New Issue
2007-02-01 05:57 pieper Assigned To => wjp
2007-02-01 05:57 pieper Status new => assigned
2007-02-01 05:57 pieper Category Base Code => GUI
2007-02-01 07:35 hayes Reporter hayes => kikinis
2007-02-01 08:31 barre Note Added: 0000032
2007-03-28 05:49 barre Note Added: 0000080
2007-03-28 10:58 wjp Note Added: 0000082
2007-03-28 11:17 wjp Note Added: 0000083
2007-03-29 10:29 wjp Status assigned => acknowledged
2007-03-29 10:29 wjp Resolution open => suspended
2007-03-29 10:32 wjp Note Added: 0000086
2007-11-20 09:16 pieper Note Added: 0000147
2008-05-30 10:31 pieper Status acknowledged => closed
2008-05-30 10:31 pieper Resolution suspended => fixed
2017-06-07 23:27 jcfr Changeset attached => Slicer 2145-support-for-installing-extension-from-file 29a04b80
2017-06-10 08:51 jcfr Changeset attached => Slicer master 29a04b80