View Issue Details

IDProjectCategoryView StatusLast Update
0002327Slicer4Module ModelMakerpublic2015-09-01 10:24
ReportertorstenrohlfingAssigned Tonicole 
PrioritynormalSeveritytrivialReproducibilityalways
Status assignedResolutionsuspended 
Product VersionSlicer 4.1.1 
Target VersionFixed in Version 
Summary0002327: "Generate All Models" in sub-optimal parameter group
Description

The "Generate All Models" toggle in the "Create Multiple"
group overrides the label range and "Skip Unnamed Labels" options in the
"Model Maker Parameters" group.

As a matter of clear UI design, I would suggest making the "Generate
All" member of the same parameter group as the remaining options related
to selecting labels.

TagsNo tags attached.

Relationships

child of 0002328 assignedmillerjv Extend command line executable auto GUI generation to support mutually exclusive sets of parameters 

Activities

jcfr

jcfr

2012-07-19 10:03

administrator   ~0005202

Nicole> Does it sound reasonable to target this for 4.2 ?

nicole

nicole

2012-07-19 10:29

administrator   ~0005204

The design of the UI was driven by Ron's feedback, I'm unwilling to change it unless he agrees. The tooltip clearly explains what is over ridden when the generate all box is checked, and because it's a CLI with the GUI auto generated from an XML file it's not possible to make parameter groups that are exclusive.

jcfr

jcfr

2012-07-19 10:31

administrator   ~0005205

Reminder sent to: kikinis

Hi Ron, would be great if you could comment on the issue entered by Torsten. Thanks

jcfr

jcfr

2012-07-19 11:05

administrator   ~0005208

From Ron:

The thinking was, that by default all populated labels will be used to create models. The assumption was that that is what a standard user wants to do. If you just need one label, you can do it out of the editor.

All other options are not presented initially. I am trying to do this in all modules, because we get a lot of complaints that slicer presents to many options and that this is confusing.

Looking at this, the check box for make all models should be unchecked automatically, when I am specifying a list or range.

nicole

nicole

2012-07-19 11:22

administrator   ~0005209

Parent bug has to be resolved first.

jcfr

jcfr

2012-07-19 11:27

administrator   ~0005210

From Nicole:

Unfortunately, the current implementation of the command line module auto generation of GUIs doesn't support this. I talked to Jim Miller and he said that I could make a feature request for this in Mantis, I've done that and made this bug a child of it:
http://www.na-mic.org/Bug/view.php?id=2328

nicole

nicole

2012-07-30 09:23

administrator   ~0005458

oops, resetting the status to assigned, I can fix this after the CLI infrastructure is updated.

Issue History

Date Modified Username Field Change
2012-07-19 10:02 torstenrohlfing New Issue
2012-07-19 10:02 torstenrohlfing Status new => assigned
2012-07-19 10:02 torstenrohlfing Assigned To => nicole
2012-07-19 10:03 jcfr Note Added: 0005202
2012-07-19 10:29 nicole Note Added: 0005204
2012-07-19 10:30 nicole Status assigned => resolved
2012-07-19 10:30 nicole Resolution open => won't fix
2012-07-19 10:31 jcfr Note Added: 0005205
2012-07-19 11:05 jcfr Note Added: 0005208
2012-07-19 11:21 nicole Relationship added child of 0002328
2012-07-19 11:22 nicole Note Added: 0005209
2012-07-19 11:27 jcfr Note Added: 0005210
2012-07-30 09:23 nicole Note Added: 0005458
2012-07-30 09:23 nicole Status resolved => assigned
2012-07-30 09:23 nicole Resolution won't fix => suspended
2012-08-20 10:35 nicole Target Version => Slicer 4.4.0
2014-07-22 10:15 nicole Target Version Slicer 4.4.0 => Slicer 4.5.0-1
2015-09-01 10:24 nicole Target Version Slicer 4.5.0-1 =>