View Issue Details

IDProjectCategoryView StatusLast Update
0000024Slicer3GUIpublic2008-06-27 06:46
ReporterkikinisAssigned Tobarre 
PrioritynormalSeverityfeatureReproducibilityalways
Status feedbackResolutionreopened 
Summary0000024: Make fonts resizeable or make better font-size setting based on the system resolution.
Description

Ron: Fonts: does slicer pick up system default fonts/sizes? Alternately, Is there a way to set them manually? On my big screen, the font is almost unreadable.

Wendy: This is a good point. Right now one font-size fits all. I will look into
making some reasonable and better font-size setting based on the system resolution.

TagsNo tags attached.

Activities

wjp

wjp

2007-08-16 10:54

administrator   ~0000113

This is a difficult issue to resolve elegantly, as far as I can see since we can't know in advance what fonts are on any user's machine, and we're not bundling our own open source fonts with Slicer yet. For now, there are a few new ways to coarsely change your font family and font size. You can access these under the Application Settings Interface under font settings; or from the View-> menu. It's not guaranteed that all the font family options are available on your machine, but at least there're a few to choose from. For best results, you may have to select a new font family and size, then restart slicer so that all widgets pick up the settings. For some reason, not all widgets reconfigure themselves live. I'm marking this resolved for now, but not closed. We may think of better ways to accomplish this...

barre

barre

2008-06-27 06:46

developer   ~0000369

I'm taking over this one

http://www.slicer.org/slicerWiki/index.php/User:Barre/TODO

Starting the font cleanup, will keep only the default font size, and a smaller one computed from the system default (instead of hardcoding everything), and possibility of increasing from there.

Issue History

Date Modified Username Field Change
2007-01-31 09:37 hayes New Issue
2007-01-31 09:37 hayes Status new => assigned
2007-01-31 09:37 hayes Assigned To => wjp
2007-01-31 09:37 hayes Reporter hayes => kikinis
2007-08-16 10:54 wjp Note Added: 0000113
2007-08-16 10:54 wjp Status assigned => resolved
2007-08-16 10:54 wjp Resolution open => fixed
2008-06-27 06:46 barre Assigned To wjp => barre
2008-06-27 06:46 barre Status resolved => feedback
2008-06-27 06:46 barre Resolution fixed => reopened
2008-06-27 06:46 barre Note Added: 0000369