View Issue Details

IDProjectCategoryView StatusLast Update
0002529Slicer4Module VolumeRenderingpublic2017-07-25 00:33
ReporterkikinisAssigned Tofinetjul 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformMacOSOS XOS Version10.8.1
Product VersionSlicer 4.1.1 
Target VersionFixed in Version 
Summary0002529: transfer function is unstable in multivolume explorer
Description

I am using a ct data set with cardiac perfusion post contrast loaded into multivolume explorer and configured to volume render. I am using the NCI GPU raycast volume renderer. The transfer function seems to have problems and the color of the structures changes. See attached movie.

TagsNo tags attached.

Activities

2012-09-17 06:08

 

VolumeRenderingBadColor 9.08.51 AM.mov (1,920,159 bytes)
jcfr

jcfr

2012-09-17 08:58

administrator   ~0006109

Should this issue be targeted for 4.2 ? Is this critical for the demos/tutorials ?

kikinis

kikinis

2012-09-17 09:18

developer   ~0006110

Not absolutely critical

jcfr

jcfr

2014-05-13 10:41

administrator   ~0011782

As discussed during May 13th hangout, considering you focus on VTK6 integration. We are re-targeting this issue for 4.5 release.

In case you plan on addressing some of these for 4.4, consider re-targeting.

lassoan

lassoan

2017-07-25 00:33

developer   ~0014957

Color is probably changing because density is changing (as contrast agent is diluted) and usually different densities are assigned different colors.

Visualization of this perfusion CT works fine:
http://slicer.kitware.com/midas3/item/299877

I don't think anybody would remember now what else did not work exactly as expected.

Issue History

Date Modified Username Field Change
2012-09-17 06:08 kikinis New Issue
2012-09-17 06:08 kikinis Status new => assigned
2012-09-17 06:08 kikinis Assigned To => finetjul
2012-09-17 06:08 kikinis File Added: VolumeRenderingBadColor 9.08.51 AM.mov
2012-09-17 08:57 jcfr Target Version => Slicer 4.3.0
2012-09-17 08:58 jcfr Note Added: 0006109
2012-09-17 09:18 kikinis Note Added: 0006110
2013-08-09 04:30 finetjul Target Version Slicer 4.3.0 => Slicer 4.4.0
2014-05-13 10:41 jcfr Note Added: 0011782
2014-05-13 10:43 jcfr Target Version Slicer 4.4.0 =>
2017-07-25 00:33 lassoan Status assigned => resolved
2017-07-25 00:33 lassoan Resolution open => no change required
2017-07-25 00:33 lassoan Note Added: 0014957