View Issue Details

IDProjectCategoryView StatusLast Update
0002766Slicer4Core: MRMLpublic2014-03-07 09:38
ReporterjcfrAssigned Toalexy 
PrioritynormalSeverityminorReproducibilityhave not tried
Status assignedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0002766: Refactor SliceModelDisplayableManager
Description

Look at VolumeGlyphDisplayableManager
See also 0001536

TagsNo tags attached.

Relationships

related to 0001536 closedalexy Model slice intersections do not work 
related to 0002769 acknowledgedalexy Refactor ModelDisplayableManager 

Activities

alexy

alexy

2012-11-25 08:15

developer   ~0007365

Fixed showing of slice intersections, made it more efficient. Full vtkMRMLModelSliceDisplayableManager::UpdateFromMRML() is only called when batch processing is done.

svn at revision: 21461

jcfr

jcfr

2012-12-08 09:04

administrator   ~0007475

This issue exists to capture the fact code common to displayable manager should be factor out.

alexy

alexy

2014-03-07 09:38

developer   ~0011361

Untargetting for 4.4 since it will not happen in that time frame.

Issue History

Date Modified Username Field Change
2012-11-16 05:12 jcfr New Issue
2012-11-16 05:12 jcfr Status new => assigned
2012-11-16 05:12 jcfr Assigned To => alexy
2012-11-16 05:13 jcfr Target Version => Slicer 4.3.0
2012-11-16 05:56 jcfr Summary Refactor ModelDisplayableManager => Refactor SliceModelDisplayableManager
2012-11-16 05:57 jcfr Relationship added related to 0001536
2012-11-16 05:57 jcfr Relationship added related to 0002769
2012-11-25 08:15 alexy Note Added: 0007365
2012-11-25 08:15 alexy Status assigned => resolved
2012-11-25 08:15 alexy Resolution open => fixed
2012-12-08 09:04 jcfr Note Added: 0007475
2012-12-08 09:04 jcfr Status resolved => assigned
2013-08-02 09:29 alexy Target Version Slicer 4.3.0 => Slicer 4.4.0
2014-03-07 09:38 alexy Note Added: 0011361
2014-03-07 09:38 alexy Target Version Slicer 4.4.0 =>