View Issue Details

IDProjectCategoryView StatusLast Update
0002830Slicer4Core: MRMLpublic2017-06-14 13:09
Reporterbks_2005Assigned Topieper 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product VersionSlicer 4.2.0 
Target VersionFixed in Version 
Summary0002830: Error reading NRRD files
Description

The ERROR during loading nrrd data files. I loaded Slicer4 tutorial files MR-head.nrrd from the 3DVisualizationData dataset succesfully but I can`t load another files. For example, grayscale.nrrd from the tumorbase dataset. Only one difference between these files is endiannes.
The way to load this file (grayscale.nrrd) is convert .nrrd to .mhd (and zraw, respectively) by means Slicer3.6.3. How can I fix this very unusual problem in Slicer4? IMHO, this issue may be redirected to VTK library.

Additional Information

OS Ubuntu 12.04 LTS.
Slicer4.2.0 was built from source without any erros.
ERROR: In /home/bks/Slicer/Libs/MRML/Core/vtkMRMLVolumeArchetypeStorageNode.cxx, line 367
vtkMRMLVolumeArchetypeStorageNode (0x5a8c5f0): ReadData: Cannot read file as a volume of type DiffusionTensorVolume[fullName = /home/bks/Data/case1/grayscale.nrrd]
Number of files listed in the node = 0.
File reader says it was able to read 1 files.
File reader used the archetype file name of /home/bks/Data/case1/grayscale.nrrd [reader 0th file name = /home/bks/Data/case1/grayscale.nrrd]

ERROR: In /home/bks/Slicer/Libs/MRML/Core/vtkMRMLVolumeArchetypeStorageNode.cxx, line 317
vtkMRMLVolumeArchetypeStorageNode (0x5a9b5b0): ReadData: Failed to instantiate a file reader

ERROR: In /home/bks/Slicer/Libs/MRML/Core/vtkMRMLVolumeArchetypeStorageNode.cxx, line 367
vtkMRMLVolumeArchetypeStorageNode (0x5a897e0): ReadData: Cannot read file as a volume of type Volume[fullName = /home/bks/Data/case1/grayscale.nrrd]
Number of files listed in the node = 0.
File reader says it was able to read 1 files.
File reader used the archetype file name of /home/bks/Data/case1/grayscale.nrrd [reader 0th file name = /home/bks/Data/case1/grayscale.nrrd]

TagsNo tags attached.

Activities

pieper

pieper

2012-12-18 02:56

administrator   ~0007516

Hi -

For the files that don't load: could you attach them to this bug report, and could you provide the steps you used to create them?

Thanks

bks_2005

bks_2005

2012-12-18 08:12

reporter   ~0007527

Sorry, its my mistake, the file size is 6Mb (a slightly bigger of limit).
This file is placed in
http://www.spl.harvard.edu/publications/item/view/1180
Tumorbase.zip on the bottom of the page. After unzipping, please see case1 folder or any other case from this dataset.
Moreover, this error appears even in case I trying to load the file that just has been saved from Analyze or DICOM formats in nrrd format using Slicer4 menu.
Thank you for you attention to my problem.

alexy

alexy

2012-12-18 09:14

developer   ~0007531

I was able to read greyscale.nrrd on Windows fine.
Steve, can you try on other systems?

pieper

pieper

2012-12-18 09:16

administrator   ~0007532

I was just looking at this too - I was able to load all the files that I tried on a mac using slicer 4.2.2.

bks_2005: can you give us any more clues on how to reproduce the issue?

bks_2005

bks_2005

2012-12-18 18:34

reporter   ~0007553

I use Ubuntu 12.04 LTS with latest update. This error appears only in the Ubuntu in different computers and Ubuntu configurations.

alexy

alexy

2012-12-21 06:18

developer   ~0007565

Steve, could you take a look or reassign to somebody with an access to Ubuntu

pieper

pieper

2012-12-21 07:16

administrator   ~0007567

I tried loading nrrd volumes from the tumorbase data on a ubuntu 12.04 machine and had no problems.

Are you sure there's not something else going on? Do you get any diagnostic information in the error log window?

pieper

pieper

2012-12-27 05:34

administrator   ~0007588

Since this tested okay on my Ubuntu (12.04) installation there must be something else going on. Do you have an ITK_AUTOLOAD_PATH or something similar set in your environment?

bks_2005

bks_2005

2012-12-28 00:58

reporter   ~0007589

Ok, I am grateful to collegues! The ITK_AUTOLOAD_PATH variable is not defined in my enviroment. I think it must be path to ITK shared libraries location.

pieper

pieper

2012-12-28 03:51

administrator   ~0007590

Yes, it may be something else in your path. If you run the following in the slicer python console it will show the environment and maybe we can debug with that:

import os; print(os.environ)

Most of the values are set by the slicer launcher.

Here's what I get on my Ubuntu 12.04 machine:

import os; print(os.environ)
{'ITK_AUTOLOAD_PATH': '/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/Slicer-4.2/ITKFactories', 'GNOME_DESKTOP_SESSION_ID': 'this-is-deprecated', 'XDG_CURRENT_DESKTOP': 'Unity', 'LOGNAME': 'pieper', 'USER': 'pieper', 'GNOME_KEYRING_CONTROL': '/tmp/keyring-eThrS4', 'PATH': '/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/./bin:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/./lib/Slicer-4.2/cli-modules:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/./lib/Slicer-4.2/qt-loadable-modules:/home/pieper/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/cuda/bin:/home/pieper/bin', 'DISPLAY': ':0.0', 'SSH_AGENT_PID': '2294', 'LANG': 'en_US.UTF-8', 'TK_LIBRARY': '/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/TclTk/lib/tk8.4', 'TERM': 'xterm', 'SHELL': '/bin/bash', 'XDG_SESSION_PATH': '/org/freedesktop/DisplayManager/Session0', 'XAUTHORITY': '/home/pieper/.Xauthority', 'SESSION_MANAGER': 'local/flint:@/tmp/.ICE-unix/2250,unix/flint:/tmp/.ICE-unix/2250', 'SHLVL': '1', 'LESSCLOSE': '/usr/bin/lesspipe %s %s', 'MANDATORY_PATH': '/usr/share/gconf/ubuntu.mandatory.path', 'LD_LIBRARY_PATH': '/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/./bin:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/./lib/Slicer-4.2:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/./lib/Slicer-4.2/cli-modules:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/./lib/Slicer-4.2/qt-loadable-modules:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/Teem-1.10.0:../lib/Slicer-4.2/qt-loadable-modules:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/igtl:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/Python/lib:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/PythonQt:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/TclTk/lib:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/TclTk/lib/itcl3.2:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/TclTk/lib/itk3.2:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/Python/lib/python2.6/site-packages/numpy/core:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/Python/lib/python2.6/site-packages/numpy/lib::/usr/local/cuda/lib64', 'COMPIZ_CONFIG_PROFILE': 'ubuntu', 'WINDOWID': '62914566', 'TCLLIBPATH': '/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/TclTk/lib/itcl3.2 /media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/TclTk/lib/itk3.2', 'GPG_AGENT_INFO': '/tmp/keyring-eThrS4/gpg:0:1', 'HOME': '/home/pieper', 'SLICER_HOME': '/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64', 'QT_PLUGIN_PATH': '/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/./lib/QtPlugins', 'PYTHONPATH': '/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/./lib/Slicer-4.2:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/Python/lib/python2.6/site-packages:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/./lib/Slicer-4.2/qt-scripted-modules:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/./lib/Slicer-4.2/qt-loadable-modules:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/vtkTeem:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/bin/Python:/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/Slicer-4.2/qt-loadable-modules/Python', 'SSH_AUTH_SOCK': '/tmp/keyring-eThrS4/ssh', 'TCL_LIBRARY': '/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/TclTk/lib/tcl8.4', 'GDMSESSION': 'ubuntu', 'GNOME_KEYRING_PID': '2239', 'XDG_SEAT_PATH': '/org/freedesktop/DisplayManager/Seat0', 'XDG_SESSION_COOKIE': 'a702ae30bd577cf32bfcbf5500000003-1355958915.808605-52076941', 'LESSOPEN': '| /usr/bin/lesspipe %s', 'DBUS_SESSION_BUSADDRESS': 'unix:abstract=/tmp/dbus-CbsHTZre1i,guid=1b0c65b0823717b0e291a56c00000056', '': './Slicer', 'DEFAULTS_PATH': '/usr/share/gconf/ubuntu.default.path', 'DESKTOP_SESSION': 'ubuntu', 'XDG_CONFIG_DIRS': '/etc/xdg/xdg-ubuntu:/etc/xdg', 'GTK_MODULES': 'canberra-gtk-module:canberra-gtk-module', 'UBUNTU_MENUPROXY': 'libappmenu.so', 'OLDPWD': '/home/pieper/Downloads/slicer', 'PYTHONHOME': '/media/extra650/Downloads/slicer/Slicer-4.2.2-1-linux-amd64/lib/Python', 'XDG_DATA_DIRS': '/usr/share/ubuntu:/usr/share/gnome:/usr/local/share/:/usr/share/', 'PWD': '/home/pieper/Downloads/slicer/Slicer-4.2.2-1-linux-amd64', 'COLORTERM': 'gnome-terminal', 'SLICER_SHARE_DIR': 'share/Slicer-4.2', 'LS_COLORS': 'rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:.tar=01;31:.tgz=01;31:.arj=01;31:.taz=01;31:.lzh=01;31:.lzma=01;31:.tlz=01;31:.txz=01;31:.zip=01;31:.z=01;31:.Z=01;31:.dz=01;31:.gz=01;31:.lz=01;31:.xz=01;31:.bz2=01;31:.bz=01;31:.tbz=01;31:.tbz2=01;31:.tz=01;31:.deb=01;31:.rpm=01;31:.jar=01;31:.war=01;31:.ear=01;31:.sar=01;31:.rar=01;31:.ace=01;31:.zoo=01;31:.cpio=01;31:.7z=01;31:.rz=01;31:.jpg=01;35:.jpeg=01;35:.gif=01;35:.bmp=01;35:.pbm=01;35:.pgm=01;35:.ppm=01;35:.tga=01;35:.xbm=01;35:.xpm=01;35:.tif=01;35:.tiff=01;35:.png=01;35:.svg=01;35:.svgz=01;35:.mng=01;35:.pcx=01;35:.mov=01;35:.mpg=01;35:.mpeg=01;35:.m2v=01;35:.mkv=01;35:.webm=01;35:.ogm=01;35:.mp4=01;35:.m4v=01;35:.mp4v=01;35:.vob=01;35:.qt=01;35:.nuv=01;35:.wmv=01;35:.asf=01;35:.rm=01;35:.rmvb=01;35:.flc=01;35:.avi=01;35:.fli=01;35:.flv=01;35:.gl=01;35:.dl=01;35:.xcf=01;35:.xwd=01;35:.yuv=01;35:.cgm=01;35:.emf=01;35:.axv=01;35:.anx=01;35:.ogv=01;35:.ogx=01;35:.aac=00;36:.au=00;36:.flac=00;36:.mid=00;36:.midi=00;36:.mka=00;36:.mp3=00;36:.mpc=00;36:.ogg=00;36:.ra=00;36:.wav=00;36:.axa=00;36:.oga=00;36:.spx=00;36:.xspf=00;36:'}

ango

ango

2013-07-17 03:26

reporter   ~0009094

Had the same Problem with the stable Version. The nightly build works for me.
import os; print(os.environ) print nothing in both Versions.

best regards

lassoan

lassoan

2017-06-14 13:09

developer   ~0014838

Reporter confirmed that it was fixed in a nightly version.

Issue History

Date Modified Username Field Change
2012-12-17 03:38 bks_2005 New Issue
2012-12-17 03:38 bks_2005 Status new => assigned
2012-12-17 03:38 bks_2005 Assigned To => alexy
2012-12-18 02:56 pieper Note Added: 0007516
2012-12-18 08:12 bks_2005 Note Added: 0007527
2012-12-18 09:14 alexy Note Added: 0007531
2012-12-18 09:14 alexy Assigned To alexy => pieper
2012-12-18 09:16 pieper Note Added: 0007532
2012-12-18 09:17 pieper Assigned To pieper => alexy
2012-12-18 18:34 bks_2005 Note Added: 0007553
2012-12-21 06:18 alexy Note Added: 0007565
2012-12-21 06:18 alexy Assigned To alexy => pieper
2012-12-21 07:16 pieper Note Added: 0007567
2012-12-27 05:34 pieper Note Added: 0007588
2012-12-27 05:34 pieper Status assigned => feedback
2012-12-28 00:58 bks_2005 Note Added: 0007589
2012-12-28 03:51 pieper Note Added: 0007590
2013-07-17 03:26 ango Note Added: 0009094
2017-06-14 13:09 lassoan Status feedback => resolved
2017-06-14 13:09 lassoan Resolution open => unable to reproduce
2017-06-14 13:09 lassoan Note Added: 0014838