View Issue Details

IDProjectCategoryView StatusLast Update
0002854Slicer4Core: GUIpublic2017-06-15 00:11
ReporterpieperAssigned Topieper 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0002854: Rotate to Volume Plane option does not trigger slice view render
Description

Using the button on the slice controller does change the slice node, but the display does not update. Doing another slice operation like pan or zoom does trigger an update and shows the new orientation of the slice.

Steps To Reproduce

Load a volume with non-axis aligned volume data, like this one:

https://dl.dropbox.com/u/3770904/editor_pencil_bug.nrrd

Go to the slice controller and click the button to rotate to volume plane. Nothing appears to have happened. Now pan or zoom the slice and rotation is displayed.

TagsNo tags attached.

Relationships

child of 0002852 closedpieper Unable to edit volume 

Activities

pieper

pieper

2013-01-07 08:27

administrator   ~0007624

Hi Julien -

Do you know exactly where to look for this? It seems the slice view is ignoring a modified event from the slice node.

If you don't know, you can assign it back to me or Jc.

-Steve

lassoan

lassoan

2017-06-15 00:11

developer   ~0014844

It is not reproducible anymore in Slicer 4.7.0-2017-06-02 (Windows 10)

Issue History

Date Modified Username Field Change
2013-01-07 04:54 pieper New Issue
2013-01-07 04:54 pieper Status new => assigned
2013-01-07 04:54 pieper Assigned To => kikinis
2013-01-07 04:54 pieper Relationship added child of 0002852
2013-01-07 07:40 kikinis Assigned To kikinis => pieper
2013-01-07 08:27 pieper Note Added: 0007624
2014-05-13 12:52 jcfr Status assigned => acknowledged
2017-06-15 00:11 lassoan Status acknowledged => resolved
2017-06-15 00:11 lassoan Resolution open => unable to reproduce
2017-06-15 00:11 lassoan Note Added: 0014844