View Issue Details

IDProjectCategoryView StatusLast Update
0002860Slicer4Core: Building (CMake, Superbuild)public2014-03-06 04:54
ReportermarkmichalskiAssigned Tojcfr 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product VersionSlicer 4.2.2-1 
Target VersionSlicer 4.3.0Fixed in VersionSlicer 4.3.0 
Summary0002860: Build Fail during libPythonQt, cannot recognize QtWebKit
Description

Experiencing a build fail during linking libPythonQt:

1 warning generated.
1 warning generated.
1 warning generated.
Linking CXX shared library libPythonQt.dylib
ld: framework not found QtWebKit
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[8]: [libPythonQt.dylib] Error 1
make[7]:
[CMakeFiles/PythonQt.dir/all] Error 2
make[6]: [all] Error 2
make[5]:
[PythonQt-cmake/src/PythonQt-stamp/PythonQt-install] Error 2
make[4]: [CMakeFiles/PythonQt.dir/all] Error 2
make[3]:
[all] Error 2
make[2]: [CTK-prefix/src/CTK-stamp/CTK-build] Error 2
make[1]:
[CMakeFiles/CTK.dir/all] Error 2
make: *** [all] Error 2

Not certain what the problem is - I installed Qt via the binary, and a QtWebKit framework is present under Library/Frameworks/QtWebKit.framework . Anyone else having this issue?

Additional Information

Slicer 4.2.2
Running Os X 10.8.2

TagsNo tags attached.

Activities

jcfr

jcfr

2013-01-08 19:16

administrator   ~0007632

Wiki has been updated to reference the workaround / solution.
See http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/Build_Instructions#ld:_framework_not_found_QtWebKit

jcfr

jcfr

2014-03-06 04:53

administrator   ~0010771

Closing resolved issues that have not been updated in more than 3 months

Issue History

Date Modified Username Field Change
2013-01-08 15:44 markmichalski New Issue
2013-01-08 15:44 markmichalski Status new => assigned
2013-01-08 15:44 markmichalski Assigned To => jcfr
2013-01-08 19:15 jcfr Target Version => Slicer 4.2.3
2013-01-08 19:16 jcfr Note Added: 0007632
2013-01-08 19:16 jcfr Status assigned => resolved
2013-01-08 19:16 jcfr Fixed in Version => Slicer 4.2.3
2013-01-08 19:16 jcfr Resolution open => fixed
2013-02-12 09:39 jcfr Target Version Slicer 4.2.3 => Slicer 4.3.0
2013-02-12 09:40 jcfr Fixed in Version Slicer 4.2.3 => Slicer 4.3.0
2014-03-06 04:53 jcfr Note Added: 0010771
2014-03-06 04:54 jcfr Status resolved => closed