View Issue Details

IDProjectCategoryView StatusLast Update
0002925Slicer4Module Annotationspublic2014-03-06 06:15
ReportergregsharpAssigned Tonicole 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product VersionSlicer 4.2.2-1 
Target VersionSlicer 4.3.0Fixed in VersionSlicer 4.3.0 
Summary0002925: Slicer crashes when centering fiducial
Description

Steps to reproduce:

(1) Load sample data
(2) Go to annotations module
(3) Highlight fiducial "F"
(4) Click icon to center slice views on highlighted fiducial

Reproduced on Windows 64 (4.2.2), and linux (svn HEAD, 2013-02-08)

TagsNo tags attached.

Activities

2013-02-08 07:11

 

2013-02-05-Scene.mrb (152,298 bytes)
pieper

pieper

2013-02-08 07:39

administrator   ~0007844

I could reproduce this - there are missing control points in the scene. This should be investigated further, but for now I fixed the crash.

http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21672

Here is the error log when loading the scene:

Show module (name): "Annotations"
unpacking to /var/folders/5g/8696sbjd1blch9pwpqwzq8c40000gn/T/__BundleLoadTemp2013-02-08_12+24+01.250
Warning: In /Users/pieper/slicer4/latest/Slicer/Libs/MRML/CLI/vtkMRMLCommandLineModuleNode.cxx, line 192
vtkMRMLCommandLineModuleNode (0x1488c5760): Command line module Affine Registration is version "0.1.0.$Revision$(alpha)" but parameter set from MRML file is version "0.1.0.$Revision: 21227 $(alpha)". Parameter set may not load properly,

Warning: In /Users/pieper/slicer4/latest/Slicer/Libs/MRML/CLI/vtkMRMLCommandLineModuleNode.cxx, line 192
vtkMRMLCommandLineModuleNode (0x1488b24b0): Command line module Affine Registration is version "0.1.0.$Revision$(alpha)" but parameter set from MRML file is version "0.1.0.$Revision: 21227 $(alpha)". Parameter set may not load properly,

Warning: In /Users/pieper/slicer4/latest/Slicer/Libs/MRML/CLI/vtkMRMLCommandLineModuleNode.cxx, line 192
vtkMRMLCommandLineModuleNode (0x148809fd0): Command line module Affine Registration is version "0.1.0.$Revision$(alpha)" but parameter set from MRML file is version "0.1.0.$Revision: 21227 $(alpha)". Parameter set may not load properly,

ERROR: In /Users/pieper/slicer4/latest/Slicer/Modules/Loadable/Annotations/MRML/vtkMRMLAnnotationControlPointsNode.cxx, line 406
vtkMRMLAnnotationFiducialNode (0x14430b2c0): vtkMRMLAnnotationControlPointsNode::GetControlPointWorldCoordinates() no control point with index0

<last error repeated many, many times...>

nicole

nicole

2013-02-08 07:44

administrator   ~0007845

Thanks Steve, sorry I missed that null pointer check!

gregsharp

gregsharp

2013-02-08 08:25

developer   ~0007849

Confirmed no crash. Centering scene view still doesn't work.

The fiducials are located outside of the foreground volume. Is it required that fiducials be within volume to center?

Also, I notice that the scene has an annotation snapshot within the second point list. Is that supposed to happen?

nicole

nicole

2013-02-08 08:46

administrator   ~0007851

Last edited: 2013-02-08 08:51

Are you using the "Reset slice views to the first coordinate of the selected annotation" button in the Annotations GUI? If the fiducial location is invalid as seems to be the case with this mrb (downloading to test now), it can't center on an invalid coordinate.

There are no coordinates in the .acsv files in the .mrb.

And yes, screen captures are valid annotation types, and can appear in any annotation list.

gregsharp

gregsharp

2013-02-08 08:57

developer   ~0007852

Hi Nicole, yes, that is the button that I refer to.

The coordinates are outside of the scene's current foreground volume. That makes them invalid?

nicole

nicole

2013-02-08 08:59

administrator   ~0007853

When I load the attached mrb file there are no fiducials successfully loaded, the files don't have coordinates in them.

2013-02-08 09:02

 

2013-02-05-Scene.mrml (64,892 bytes)

2013-02-08 09:02

 

startStack.tif (156,920 bytes)

2013-02-08 09:03

 

endStack.tif (156,926 bytes)
gregsharp

gregsharp

2013-02-08 09:04

developer   ~0007854

Ah..., maybe they got deleted when I re-saved, because they weren't loaded correctly. I'm now attaching the original files.

nicole

nicole

2013-02-08 09:32

administrator   ~0007855

Last edited: 2013-02-08 09:36

Could you please attach the .acsv files that contain coordinates? The mrml file has coordinates, but they're over ridden by the annotation storage nodes trying to load files from the wrong directory (same as mrml file rather than in Data subdir).
Also: are the tiff files only one slice? That might affect the centering operation.

pieper

pieper

2013-08-27 11:45

administrator   ~0009633

Has this been resolved?

gregsharp

gregsharp

2013-08-28 08:44

developer   ~0009664

Resolved. Bug is not reproduced in new markup module.

Issue History

Date Modified Username Field Change
2013-02-08 07:11 gregsharp New Issue
2013-02-08 07:11 gregsharp Status new => assigned
2013-02-08 07:11 gregsharp Assigned To => hjmjohnson
2013-02-08 07:11 gregsharp File Added: 2013-02-05-Scene.mrb
2013-02-08 07:39 pieper Note Added: 0007844
2013-02-08 07:40 pieper Assigned To hjmjohnson => nicole
2013-02-08 07:40 pieper Status assigned => acknowledged
2013-02-08 07:44 nicole Note Added: 0007845
2013-02-08 08:25 gregsharp Note Added: 0007849
2013-02-08 08:26 gregsharp Category Module BRAINS => Module Annotations
2013-02-08 08:46 nicole Note Added: 0007851
2013-02-08 08:51 nicole Note Edited: 0007851
2013-02-08 08:51 nicole Note Edited: 0007851
2013-02-08 08:57 gregsharp Note Added: 0007852
2013-02-08 08:59 nicole Note Added: 0007853
2013-02-08 09:02 gregsharp File Added: 2013-02-05-Scene.mrml
2013-02-08 09:02 gregsharp File Added: startStack.tif
2013-02-08 09:03 gregsharp File Added: endStack.tif
2013-02-08 09:04 gregsharp Note Added: 0007854
2013-02-08 09:32 nicole Note Added: 0007855
2013-02-08 09:36 nicole Note Edited: 0007855
2013-08-27 11:45 pieper Note Added: 0009633
2013-08-28 08:44 gregsharp Note Added: 0009664
2013-08-28 08:45 gregsharp Status acknowledged => closed
2013-08-28 08:45 gregsharp Resolution open => fixed
2014-03-06 05:59 jcfr Fixed in Version => Slicer 4.3.0
2014-03-06 06:15 jcfr Target Version => Slicer 4.3.0