View Issue Details

IDProjectCategoryView StatusLast Update
0002957Slicer4Core: Building (CMake, Superbuild)public2014-04-07 14:52
ReportergregsharpAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version 
Target VersionSlicer 4.3.0Fixed in VersionSlicer 4.3.0 
Summary0002957: CMake hangs on OSX
Description

OSX 10.7
xcode 4.6 (4H127)
cmake-2.8.10.20130213-g7665b (built from source)

The cmake nightly successfully solves problem with finding QtWebKit framework on mac with newer xcode versions.

However, instead, cmake goes into an infinite loop when compiling using "make".

TagsNo tags attached.

Relationships

related to 0002025 closedjcfr Build errors when using wrong CMake 

Activities

gregsharp

gregsharp

2013-02-15 10:15

developer   ~0007952

Here is where cmake goes into the infinite loop

-- Configuring SEM CLI module: DWIConvert
-- Configuring SEM CLI module: BRAINSCreateLabelMapFromProbabilityMaps
-- Enabling Slicer launcher option: --xterm
-- Enabling Slicer launcher option: --gdb
-- Configuring done

jcfr

jcfr

2013-02-15 10:17

administrator   ~0007953

Please report this issue on the CMake developer list / bug tracker. Thanks

Make also sure to add a comment on the dedicated CMake issue. See http://www.cmake.org/Bug/view.php?id=13765

jcfr

jcfr

2013-02-15 10:20

administrator   ~0007954

Few questions:
1) Did you run your test from a clean build ?
2) If CMake loop during the configuration, it means that you were not able to build/link. It means don't understand how you could confirm that the link error doesn't occur.

Thanks
Jc

gregsharp

gregsharp

2013-02-15 10:31

developer   ~0007956

Yes, good idea. I decided to make a separate issue on cmake, and cross-referenced them.

1) Clean build. Reproduced multiple times.
2) Correct, build didn't complete.

My memory is that the framework error happens earlier in the build process, maybe PythonQt or CTK. But it's possible that I didn't remember correctly. Would it help that I confirm?

gregsharp

gregsharp

2013-02-15 10:32

developer   ~0007957

Cross reference to cmake bug report

http://www.cmake.org/Bug/view.php?id=13926

jcfr

jcfr

2013-02-15 10:39

administrator   ~0007958

On the CMake issue, simply describe the set of command leading to the issue. For example:

$ git clone ...
$ mkdir Slicer-build-test
$ cd Slicer-build-test
$ cmake -DQT_QMAKE_EXECTUABLE:FILEPATH=/path/to/qmake -blah -blah ../Slicer
Begin of configure
blah blah
[...]
End of config
$ make
Building ...
nalh blah
[...]
some context before error
The error

Within out more details, it will be near impossible to solve the problem. Provide details, does it occur when doing parallel build -j5 ? doing serial build ...

Attaching meaningful snipper of log file is also nice. Obtained for example using VERBOSE=1

Thanks
Jc

jcfr

jcfr

2013-02-15 11:26

administrator   ~0007961

AS suggested by Bill Hoffman, using cmake --trace could also be useful. Easier approach that what I just suggested :)

See http://www.cmake.org/cmake/help/v2.8.10/cmake.html#opt:--trace

jcfr

jcfr

2013-02-17 06:36

administrator   ~0007971

Using the nightly version reported on the following page is known to work. Make sure to use this one. See http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/Build_Instructions/Prerequisites#MacOSX

Note: I suspect the following commit to cause the hang: http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=ccfeefae

For reference, I also copied below the email I sent to the list:

I just updated both Slicer build system [1] and the wiki [2] to support Qt 4.8.4 so that Mountain Lion can be build out of the box.

In other word, on mountain lion, you simply download a recent nightly CMake version, install Qt 4.8.4 using the dmg referenced in [2]. And it should work out of the box.

On Mountain Lion [3], I did a clean build using cmake [4] and a Release build was done without any issue in 26mins.

$ git clone git://github.com/Slicer/Slicer
$ mkdir Slicer-Superbuild-Release-cmake-2.8.10.20130121-g92bd8
$ cd Slicer-Superbuild-Release-cmake-2.8.10.20130121-g92bd8
$ ../../Support/CMake\ 2.8-10.20130121-g92bd8.app/Contents/bin/cmake -DCMAKE_BUILD_TYPE:STRING=Release ../Slicer && time make -j14
[...]
[100%] Built target vtkSlicerEMSegmentModuleLogicPython
[100%] No install step for 'Slicer'
[100%] Completed 'Slicer'
[100%] Built target Slicer

real 26m54.266s
user 192m2.358s
sys 49m32.995s

That said, it failed using the latest nightly "cmake-2.8.10.20130215-g4c900". Make sure you used CMake version 2.8.10.20130121-g92bd8.

Wiki has been updated to reference the version of CMake know to work. See [5]

[1] http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=21727
[2] http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/Build_Instructions/Prerequisites/Qt#Download_links
[3] Xcode 4.6 / Build version 4H127 - Apple clang version 4.1 (tags/Apple/clang-421.11.66) (based on LLVM 3.1svn)
[4] CMake 2.8.10.20130121-g92bd8
[5] http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/Build_Instructions/Prerequisites#MacOSX

jcfr

jcfr

2013-02-18 08:59

administrator   ~0007980

As a follow up, building on MacOSX should work out of the box using the specific version of CMake discussed on the mailing list [1] and also reported on the wiki [2]

[1] http://slicer-devel.65872.n3.nabble.com/How-to-build-Slicer-on-10-8-tp4027602p4027604.html
[2] http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/Build_Instructions#MacOSX

All that said, CMake folks (Thanks Brad King :)) just fixed an issue that was preventing the most recent nightly from being used to successfully compile Slicer. The fix has been tested and is known to work. Tomorrow nightly build of CMake and by extension the coming release of CMake 2.8.11 will work.

Thanks again for reporting the issue.

If you are curious about the details, check the commit message:

http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=1df09e57

The associated CMake test have also been updated:

http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=bff3d9ce

jcfr

jcfr

2014-04-07 14:52

administrator   ~0011549

Closing resolved issues that have not been updated in more than 3 months

Issue History

Date Modified Username Field Change
2013-02-15 10:13 gregsharp New Issue
2013-02-15 10:13 gregsharp Status new => assigned
2013-02-15 10:13 gregsharp Assigned To => jcfr
2013-02-15 10:15 gregsharp Note Added: 0007952
2013-02-15 10:17 jcfr Note Added: 0007953
2013-02-15 10:17 jcfr Status assigned => feedback
2013-02-15 10:18 jcfr Target Version => Slicer 4.3.0
2013-02-15 10:20 jcfr Note Added: 0007954
2013-02-15 10:31 gregsharp Note Added: 0007956
2013-02-15 10:32 gregsharp Note Added: 0007957
2013-02-15 10:39 jcfr Note Added: 0007958
2013-02-15 11:26 jcfr Note Added: 0007961
2013-02-17 06:36 jcfr Note Added: 0007971
2013-02-17 06:36 jcfr Status feedback => resolved
2013-02-17 06:36 jcfr Fixed in Version => Slicer 4.3.0
2013-02-17 06:36 jcfr Resolution open => fixed
2013-02-18 08:59 jcfr Note Added: 0007980
2013-09-02 11:19 jcfr Relationship added related to 0002025
2014-01-07 14:28 bronson Resolution fixed => reopened
2014-01-07 20:03 bronson Resolution reopened => unable to reproduce
2014-04-07 14:52 jcfr Note Added: 0011549
2014-04-07 14:52 jcfr Status resolved => closed