View Issue Details

IDProjectCategoryView StatusLast Update
0003039Slicer4Module VolumeRenderingpublic2018-03-22 00:39
ReportermuratmagaAssigned Tofinetjul 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product VersionSlicer 4.2.2-1 
Target VersionSlicer 4.9.0Fixed in VersionSlicer 4.9.0 
Summary0003039: Image resolution alters the quality of the volume rendering
Description

These are rendering from same dataset imported with image spacing 1,1,1, and 0.02, 0.02,0.02 (which is the actual spacing on the dataset).

Additional Information

Sorry turns out I can't upload two files. The other one is opaque with the identical settings, and shows the whole surface of the head with any of the internal structures.

TagsNo tags attached.

Relationships

duplicate of 0003033 acknowledgedfinetjul Add support for vtkVolumeProperty::ScalarOpacityUnitDistance 

Activities

2013-03-29 08:23

 

0.02.png (231,693 bytes)
0.02.png (231,693 bytes)

2013-03-29 08:24

 

1.0.png (250,224 bytes)
1.0.png (250,224 bytes)
finetjul

finetjul

2013-03-29 09:00

administrator   ~0008264

As a temporary work around, you can set ScalarOpacityUnitDistance on the VolumeProperty of the VolumePropertyNode.

muratmaga

muratmaga

2013-04-16 14:57

reporter   ~0008414

I wasn't able to locate that option. I see X coordinate, opacity, mid point, sharpness but no ScalarOpacityUnitDistance

finetjul

finetjul

2013-04-16 15:59

administrator   ~0008418

you need to set it via the python console

muratmaga

muratmaga

2013-04-16 20:43

reporter   ~0008421

That's unfortunately beyond my experience with Slicer. Can you give me an idea or a pointer about how to set that in python interactor.

Simply typing ScalarOpacityUnitDistance= some value doesn't do anything for me.

pieper

pieper

2013-04-23 05:39

administrator   ~0008465

You can use commands like this:

vpn = getNode('VolumeProp')
vp = vpn.GetVolumeProperty()
vp.SetScalarOpacityUnitDistance(3)
vp.SetScalarOpacityUnitDistance(.3)

lassoan

lassoan

2017-07-25 22:36

developer   ~0014985

Re-evaluate this after Slicer switches to VTK8.

jcfr

jcfr

2018-03-22 00:25

administrator   ~0015579

Last edited: 2018-03-22 00:26

View 2 revisions

@pinter @lassoan Do you know if this is still an issue with the latest Slicer ?

lassoan

lassoan

2018-03-22 00:39

developer   ~0015580

I confirm that it is fixed in the latest nightly version.

Verified by loading MRHead and setting spacing to [0.02,0.02,0.02]. In Slicer 4.8.1 volume renderer the image appears semi-transparent, while in latest nightly the image appears correctly (the same way as with the original spacing values).

Issue History

Date Modified Username Field Change
2013-03-29 08:23 muratmaga New Issue
2013-03-29 08:23 muratmaga Status new => assigned
2013-03-29 08:23 muratmaga Assigned To => finetjul
2013-03-29 08:23 muratmaga File Added: 0.02.png
2013-03-29 08:24 muratmaga File Added: 1.0.png
2013-03-29 08:57 finetjul Relationship added duplicate of 0003033
2013-03-29 09:00 finetjul Note Added: 0008264
2013-04-16 14:57 muratmaga Note Added: 0008414
2013-04-16 15:59 finetjul Note Added: 0008418
2013-04-16 20:43 muratmaga Note Added: 0008421
2013-04-23 05:39 pieper Note Added: 0008465
2017-07-25 22:36 lassoan Target Version => Slicer 4.9.0
2017-07-25 22:36 lassoan Note Added: 0014985
2018-03-22 00:25 jcfr Note Added: 0015579
2018-03-22 00:26 jcfr Note Edited: 0015579 View Revisions
2018-03-22 00:26 jcfr Status assigned => feedback
2018-03-22 00:39 lassoan Status feedback => resolved
2018-03-22 00:39 lassoan Resolution open => duplicate
2018-03-22 00:39 lassoan Fixed in Version => Slicer 4.9.0
2018-03-22 00:39 lassoan Note Added: 0015580