View Issue Details

IDProjectCategoryView StatusLast Update
0003180Slicer4Core: Base Codepublic2017-06-15 09:00
ReporterpieperAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0003180: need better warning for unwritable temp folder
Description

There is a startup message to the console when slicer cannot write to the selected temp, but the user can easily not notice this.

Then later none of the CLI modules work because they cannot write to the temp directory but the underlying error is not really clear.

Ideally we should gracefully recover by picking new temp directory, or if not we should have a dialog telling the user what to do.

Steps To Reproduce

Lauren ran into this because she migrated her user account from one mac to another and it brought with it the old temp path which is not valid in the new slicer.

TagsSummer AHM 2013

Relationships

duplicate of 0004340 resolvedjcfr Impossible to use Slicer in multi-user setting on Linux 
parent of 0003587 closedmillerjv Resetting the temporary directory doesn't prompt a restart, CLI logic uses old value 

Activities

lassoan

lassoan

2017-06-15 01:42

developer   ~0014848

duplicate

jcfr

jcfr

2017-06-15 09:00

administrator   ~0014858

Hi Andras, Could you link the duplicate ?

Issue History

Date Modified Username Field Change
2013-06-19 09:15 pieper New Issue
2013-06-19 09:15 pieper Status new => assigned
2013-06-19 09:15 pieper Assigned To => jcfr
2013-06-19 21:55 jcfr Tag Attached: Summer AHM 2013
2013-07-02 09:44 jcfr Target Version => Slicer 4.3.0
2013-08-30 13:06 jcfr Target Version Slicer 4.3.0 => Slicer 4.3.1
2013-10-01 11:49 jcfr Target Version Slicer 4.3.1 => Slicer 4.3.2
2014-02-12 10:59 nicole Relationship added parent of 0003587
2014-03-06 10:15 nicole Target Version Slicer 4.3.2 => Slicer 4.4.0
2014-04-22 10:06 jcfr Status assigned => acknowledged
2014-04-22 10:06 jcfr Target Version Slicer 4.4.0 =>
2017-06-15 01:41 lassoan Relationship added related to 0004340
2017-06-15 01:42 lassoan Relationship replaced duplicate of 0004340
2017-06-15 01:42 lassoan Status acknowledged => closed
2017-06-15 01:42 lassoan Resolution open => duplicate
2017-06-15 01:42 lassoan Note Added: 0014848
2017-06-15 09:00 jcfr Note Added: 0014858