View Issue Details

IDProjectCategoryView StatusLast Update
0003216Slicer4Module Markupspublic2017-06-10 08:51
ReporterkotwiczAssigned Tonicole 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product VersionSlicer 4.2.0 
Target VersionSlicer 4.4.0Fixed in VersionSlicer 4.4.0 
Summary0003216: adding/removing view node ids does not work for 3d viewer
Description

It is not possible to show a fiducial in one of the 2d viewers and not the 3d viewer

TagsNo tags attached.

Relationships

parent of 0003196 acknowledgednicole customization options for fiducials and rulers 
child of 0003217 closednicole Not possible to show fiducial/ruler projections in only select 2d viewers 
Not all the children of this issue are yet resolved or closed.

Activities

pieper

pieper

2014-03-07 10:22

administrator   ~0011378

Need to implement fix in 0003217 for IsDisplayableInView.

nicole

nicole

2014-03-07 12:14

administrator   ~0011390

Did a first pass on this, the markup fiducial isn't disappearing when the view node id is added/removed in the 2 up 3d view:

fid = getNode("F")
disp = fid.GetDisplayNode()
disp.AddViewNodeID("vtkMRMLViewNode1")
disp.AddViewNodeID("vtkMRMLViewNode2")
disp.RemoveViewNodeID("vtkMRMLViewNode2")

nicole

nicole

2014-03-26 15:53

administrator   ~0011466

Reminder sent to: finetjul

Tried to add a GUI element for testing, and finding the logic of IsDisplayableInView a bit tricky to translate to a checkable drop down list of view node ids. The method returns true if there are no view node ids set on the display node, but when presenting a list of view nodes to the user, "all unchecked" doesn't seem to map logically to "see in all", and unchecking / removing one doesn't really do anything since it wasn't there to begin with.

Also for feedback from Julien: vtkMRMLDisplayNode::RemoveViewNodeID throws a vtk error if you try to remove an id that isn't present, but vtkMRMLDisplayNode::AddViewNodeID doesn't complain if you try to add one that's already there. I'd vote for the methods to respond to these cases in the same way, either both returning silently, or both calling the vtk error macro.

I just noticed that vtkMRMLDisplayNode::GetVisibility checks the view node ids as well, I'll try using that call in the 3d displayable manager and see if it works better.

nicole

nicole

2014-04-11 12:37

administrator   ~0011580

Topic branch to merge:
https://github.com/naucoin/Slicer/commits/3216-Markups-with-views

nicole

nicole

2014-04-11 14:15

administrator   ~0011585

Added support for setting view node ids for fiducials so can show in selected 2d and 3d views, as of svn 23087:
http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=23087

nicole

nicole

2014-04-14 13:15

administrator   ~0011590

Ported to the models module as of svn 23098:
http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=23098

jcfr

jcfr

2014-09-17 23:01

administrator   ~0012557

Closing resolved issues that have not been updated in more than 3 months.

Related Changesets

Import 2017-06-07 23:51:09: master 6355e268

2014-04-11 18:03:32

naucoin

Details Diff
BUG: unify how add/remove handle error cases

Remove the error print out when removing a view node that
is not in the list, since when adding a view node that is
already in the list no error is printed. The code recovers
gracefully, no need to post an error.

Issue 0003216



git-svn-id: http://svn.slicer.org/Slicer4/trunk@23085 3bd1e089-480b-0410-8dfb-8563597acbee
mod - Libs/MRML/Core/vtkMRMLDisplayNode.cxx Diff File

Import 2017-06-07 23:51:09: master ef3bf47a

2014-04-11 18:06:19

naucoin

Details Diff
ENH: expand the view combo box to work on abstract view nodes

Removed the limitation on the display node view combo box that
only allowed selecting 3D view nodes, now all subclasses of
abstract view nodes can be used. Slice nodes and chart view
nodes are now allowed. This fixes the issue that while a
display node could have a slice node added to it's list of
view nodes, this combo box would remove it as it wasn't a
3d view node.
Update the volume rendering module widget to use the new combo
box code, limiting the view nodes to 3d ones since volume
rendering can't be shown in slice views.

Issue 0003216



git-svn-id: http://svn.slicer.org/Slicer4/trunk@23086 3bd1e089-480b-0410-8dfb-8563597acbee
mod - Libs/MRML/Widgets/Testing/qMRMLDisplayNodeViewComboBoxTest.cxx Diff File
mod - Libs/MRML/Widgets/qMRMLDisplayNodeViewComboBox.cxx Diff File
mod - Libs/MRML/Widgets/qMRMLDisplayNodeViewComboBox.h Diff File
mod - Modules/Loadable/VolumeRendering/Widgets/qSlicerVolumeRenderingModuleWidget.cxx Diff File

Import 2017-06-07 23:51:09: master 4210b9d6

2014-04-11 18:11:18

naucoin

Details Diff
ENH: add support for markups in different views

Added support in the displayable managers to check if
a markup is visible in a given view. Added testing.
Added a GUI drop down box to allow the user to
manipulate the view node settings (in the Advanced
Display group)

Resolves Issue 0003216



git-svn-id: http://svn.slicer.org/Slicer4/trunk@23087 3bd1e089-480b-0410-8dfb-8563597acbee
mod - Modules/Loadable/Markups/MRMLDM/vtkMRMLMarkupsDisplayableManager2D.cxx Diff File
mod - Modules/Loadable/Markups/MRMLDM/vtkMRMLMarkupsDisplayableManager3D.cxx Diff File
mod - Modules/Loadable/Markups/MRMLDM/vtkMRMLMarkupsFiducialDisplayableManager3D.cxx Diff File
mod - Modules/Loadable/Markups/Resources/UI/qSlicerMarkupsModule.ui Diff File
mod - Modules/Loadable/Markups/Testing/Python/CMakeLists.txt Diff File
add - Modules/Loadable/Markups/Testing/Python/MarkupsInViewsSelfTest.py Diff File
mod - Modules/Loadable/Markups/qSlicerMarkupsModuleWidget.cxx Diff File

Import 2017-06-07 23:51:09: master 5f625e63

2014-04-14 17:11:00

naucoin

Details Diff
ENH: add view node combo box for models

Gives users a GUI element to set models visible in selected
views.
Updated the displayable manager so that the model slice intersection
honors the overall display node visibility setting.

Issue 0003216



git-svn-id: http://svn.slicer.org/Slicer4/trunk@23098 3bd1e089-480b-0410-8dfb-8563597acbee
mod - Libs/MRML/DisplayableManager/vtkMRMLModelSliceDisplayableManager.cxx Diff File
mod - Libs/MRML/Widgets/Resources/UI/qMRMLDisplayNodeWidget.ui Diff File
mod - Libs/MRML/Widgets/qMRMLDisplayNodeWidget.cxx Diff File

Issue History

Date Modified Username Field Change
2013-07-10 08:54 kotwicz New Issue
2013-07-10 08:54 kotwicz Status new => assigned
2013-07-10 08:54 kotwicz Assigned To => nicole
2013-09-03 12:18 nicole Category Module Annotations => Module Markups
2013-09-03 12:18 nicole Target Version => Slicer 4.4.0
2013-09-03 12:19 nicole Relationship added child of 0003217
2013-09-03 12:21 nicole Relationship added parent of 0003196
2014-03-07 10:22 pieper Note Added: 0011378
2014-03-07 12:14 nicole Note Added: 0011390
2014-03-26 15:53 nicole Note Added: 0011466
2014-04-11 12:37 nicole Note Added: 0011580
2014-04-11 14:15 nicole Note Added: 0011585
2014-04-11 14:15 nicole Status assigned => resolved
2014-04-11 14:15 nicole Resolution open => fixed
2014-04-11 14:17 nicole Fixed in Version => Slicer 4.4.0
2014-04-14 13:15 nicole Note Added: 0011590
2014-09-17 22:59 jcfr Status resolved => closed
2014-09-17 23:01 jcfr Note Added: 0012557
2017-06-10 08:51 Changeset attached => Slicer master 5f625e63
2017-06-10 08:51 Changeset attached => Slicer master 4210b9d6
2017-06-10 08:51 Changeset attached => Slicer master ef3bf47a
2017-06-10 08:51 Changeset attached => Slicer master 6355e268