View Issue Details

IDProjectCategoryView StatusLast Update
0003295Slicer4Core: MRMLpublic2017-06-11 23:48
Reportercho591Assigned Toalexy 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product VersionSlicer 4.2.2-1 
Target VersionFixed in Version 
Summary0003295: RemoveNode doesn't free main memory
Description

RemoveNode (a function of vtkMRMLScene) doesn't free main memory. I confirmed that it clears a node from the scene.

TagsNo tags attached.

Activities

lassoan

lassoan

2017-06-11 23:48

developer   ~0014775

Remove node from the scene actually frees up all allocated memory. Memory leaks are caused by faulty modules that keep reference to nodes or data members in nodes. No memory leaks are found by automatic nightly tests, so the most likely source of issues are custom modules.

Issue History

Date Modified Username Field Change
2013-08-13 14:54 cho591 New Issue
2013-08-13 14:54 cho591 Status new => assigned
2013-08-13 14:54 cho591 Assigned To => alexy
2017-06-11 23:48 lassoan Status assigned => resolved
2017-06-11 23:48 lassoan Resolution open => unable to reproduce
2017-06-11 23:48 lassoan Note Added: 0014775