View Issue Details

IDProjectCategoryView StatusLast Update
0003332Slicer4Core: Building (CMake, Superbuild)public2017-09-12 09:53
ReporterjcfrAssigned Todzenanz 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0003332: Rename file "SlicerMacroBuildQtModule.cmake" into "SlicerMacroBuildLoadableModule.cmake"
Description

After deprecating macro "SlicerMacroBuildQtModule" and adding macro "SlicerMacroBuildLoadableModule", renaming the associated CMake file is the logical following step.

TagsNo tags attached.

Relationships

duplicate of 0004180 assigneddzenanz Extension template is incorrect for loadable module generator 
related to 0002648 closedjcfr Rename macro "slicerMacroBuildQtModule" into "slicerMacroBuildLoadableModule" 
related to 0003353 acknowledgedjcfr Create develeper package / SDK 

Activities

dzenanz

dzenanz

2017-04-27 15:08

developer   ~0014451

Fix submitted: https://github.com/Slicer/Slicer/pull/715

Issue History

Date Modified Username Field Change
2013-08-27 11:14 jcfr New Issue
2013-08-27 11:14 jcfr Status new => assigned
2013-08-27 11:14 jcfr Assigned To => jcfr
2013-08-27 11:14 jcfr Relationship added related to 0002648
2013-08-27 11:14 jcfr Target Version => Slicer 4.4.0
2013-08-27 11:24 jcfr Status assigned => resolved
2013-08-27 11:24 jcfr Fixed in Version => Slicer 4.3.0
2013-08-27 11:24 jcfr Resolution open => fixed
2013-08-27 11:24 jcfr Status resolved => closed
2013-08-27 11:40 jcfr Status closed => assigned
2013-08-27 11:40 jcfr Fixed in Version Slicer 4.3.0 =>
2014-05-13 12:51 jcfr Status assigned => acknowledged
2014-07-29 09:46 jcfr Target Version Slicer 4.4.0 => Slicer 4.5.0-1
2015-09-22 09:59 jcfr Target Version Slicer 4.5.0-1 =>
2015-09-22 09:59 jcfr Relationship added related to 0003353
2017-04-27 15:08 dzenanz Note Added: 0014451
2017-04-27 15:08 dzenanz Assigned To jcfr => dzenanz
2017-09-12 09:52 dzenanz Relationship added duplicate of 0004180
2017-09-12 09:53 dzenanz Status acknowledged => closed