View Issue Details

IDProjectCategoryView StatusLast Update
0003338Slicer4Core: Diffusion and Tractography (Any modules)public2017-03-02 15:47
ReporterjcfrAssigned Tospujol 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0003338: CLI - DTIexport module has no test
Description

Would it make sens to add some test ?

Test data should be hosted on midas. See http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/Tutorials/UploadTestData

Tagshelp-wanted

Relationships

related to 0003339 closedspujol CLI - DTIimport module has no test 

Activities

spujol

spujol

2013-08-28 12:33

developer   ~0009672

Last edited: 2013-08-28 12:34

I did manual testing of the module when I wrote it using a DTI-TK Nifti file that I converted in Nrrd file.

Au automated test of the module would definitively be great!

Both datasets (Nrrd and Nifti) are are available at the link below:

http://www.na-mic.org/Wiki/index.php/DTI_Import_Export

jcfr

jcfr

2013-08-28 13:12

administrator   ~0009680

See r22351 - http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=22351

// ------------------------------
COMP: Disable configure time message mentioning some CLIs have NO tests

These messages (introduced by r20160 more than a year ago) didn't have
the intended effect. Despite the fact developer were systematically
looking at these warning message, they became "noise" and have been ignored.

This commit disables the warning message and reference a mantis issue
tracking the fact there is no test.

See 0001619, 0003333, 0003334, 0003335, 0003336, 0003337, 0003338, 0003339, 0003340, 0003341

jcfr

jcfr

2017-03-02 15:47

administrator   ~0014357

Since the development of these modules have been moved into https://github.com/SlicerDMRI/SlicerDMRI, I am closing these issues.

Issue History

Date Modified Username Field Change
2013-08-28 12:29 jcfr New Issue
2013-08-28 12:29 jcfr Status new => assigned
2013-08-28 12:29 jcfr Assigned To => spujol
2013-08-28 12:29 jcfr Target Version => Slicer 4.4.0
2013-08-28 12:31 jcfr Relationship added related to 0003339
2013-08-28 12:33 spujol Note Added: 0009672
2013-08-28 12:33 spujol Note Edited: 0009672
2013-08-28 12:34 spujol Note Edited: 0009672
2013-08-28 12:34 spujol Note Edited: 0009672
2013-08-28 12:34 jcfr Description Updated
2013-08-28 13:12 jcfr Note Added: 0009680
2013-08-28 13:13 jcfr Relationship added child of 0003341
2013-08-28 13:14 jcfr Relationship deleted child of 0003341
2014-05-13 15:34 jcfr Status assigned => acknowledged
2014-05-13 15:34 jcfr Target Version Slicer 4.4.0 =>
2014-05-13 15:34 jcfr Tag Attached: help-wanted
2016-02-29 13:50 jcfr Category Module DTI Export/Import => Core: Diffusion & Tractography
2016-02-29 14:05 jcfr Category Core: Diffusion & Tractography => Core: Diffusion & Tractography (Any modules)
2016-06-20 14:14 jcfr Category Core: Diffusion & Tractography (Any modules) => Core: Diffusion and Tractography (Any modules)
2017-03-02 15:47 jcfr Note Added: 0014357
2017-03-02 15:47 jcfr Status acknowledged => closed