View Issue Details

IDProjectCategoryView StatusLast Update
0003340Slicer4Module (Any modules)public2017-06-07 23:27
ReporterjcfrAssigned Toaylward 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionSlicer 4.4.0Fixed in VersionSlicer 4.4.0 
Summary0003340: CLI - FiducialRegistration module has no test
Description

Would it make sens to add some test ?

Test data should be hosted on midas. See http://www.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/Tutorials/UploadTestData

TagsNo tags attached.

Activities

jcfr

jcfr

2013-08-28 13:12

administrator   ~0009682

See r22351 - http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=22351

// ------------------------------
COMP: Disable configure time message mentioning some CLIs have NO tests

These messages (introduced by r20160 more than a year ago) didn't have
the intended effect. Despite the fact developer were systematically
looking at these warning message, they became "noise" and have been ignored.

This commit disables the warning message and reference a mantis issue
tracking the fact there is no test.

See 0001619, 0003333, 0003334, 0003335, 0003336, 0003337, 0003338, 0003339, 0003340, 0003341

nicole

nicole

2013-08-30 10:43

administrator   ~0009732

Test added in svn 22369:
http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=22369

jcfr

jcfr

2014-03-06 05:22

administrator   ~0011179

Closing resolved issues that have not been updated in more than 3 months

Related Changesets

Slicer: 2145-support-for-installing-extension-from-file 20882931

2013-08-30 14:41:01

naucoin

Details Diff
BUG: update WriteCLI to fill a vector of strings, honor mutiple = false

Because Markups define multiple markups (with potentially multiple points) in one node,
it was writting multiple instances of a string + coordinates to the string stream passed
in to WriteCLI. This causes a problem for the parsing of the arguments in CLIs such as
FiducialRegistration which needed a separate string for each point.
With this change, the markup points are writen into a vector of strings, one string
for each point in each Markup.
Added the multipleFlag to be passed to WriteCLI, and if it's false, only write the
first selected markup to the output vector. If that markup has multiple points, it will
write all of those points.
Updated the Annotation control point to use the new WriteCLI signature, but because
of the way the points are written, it will only write the first point in a multi point
annotation (such as a ruler) if multiple is false, so it ignores it and the
CLI module logic takes care of ensuring that only the first child in an
annotation hierachy is written out. Write out a warning message if this is the case.
Added a test for FiducialRegistration, updated the Markups node test 1 to test the single point flag.
Removed trailing white spaces.

Issue 0001910 0003345 0003340



git-svn-id: http://svn.slicer.org/Slicer4/trunk@22369 3bd1e089-480b-0410-8dfb-8563597acbee
mod - Base/QTCLI/vtkSlicerCLIModuleLogic.cxx Diff File
mod - Libs/MRML/Core/vtkMRMLDisplayableNode.h Diff File
mod - Modules/CLI/FiducialRegistration/FiducialRegistration.cxx Diff File
mod - Modules/CLI/FiducialRegistration/Testing/CMakeLists.txt Diff File
add - Modules/CLI/FiducialRegistration/Testing/FiducialRegistrationTest.cxx Diff File
mod - Modules/Loadable/Annotations/MRML/vtkMRMLAnnotationControlPointsNode.cxx Diff File
mod - Modules/Loadable/Annotations/MRML/vtkMRMLAnnotationControlPointsNode.h Diff File
mod - Modules/Loadable/Markups/MRML/vtkMRMLMarkupsNode.cxx Diff File
mod - Modules/Loadable/Markups/MRML/vtkMRMLMarkupsNode.h Diff File
mod - Modules/Loadable/Markups/Testing/Cxx/vtkMRMLMarkupsNodeTest1.cxx Diff File

Issue History

Date Modified Username Field Change
2013-08-28 12:32 jcfr New Issue
2013-08-28 12:32 jcfr Status new => assigned
2013-08-28 12:32 jcfr Assigned To => aylward
2013-08-28 12:32 jcfr Target Version => Slicer 4.4.0
2013-08-28 12:34 jcfr Description Updated
2013-08-28 13:12 jcfr Note Added: 0009682
2013-08-28 13:13 jcfr Relationship added related to 0003341
2013-08-28 13:14 jcfr Relationship deleted related to 0003341
2013-08-30 10:43 nicole Note Added: 0009732
2013-08-30 10:43 nicole Status assigned => resolved
2013-08-30 10:43 nicole Fixed in Version => Slicer 4.4.0
2013-08-30 10:43 nicole Resolution open => fixed
2014-03-06 05:22 jcfr Note Added: 0011179
2014-03-06 05:23 jcfr Status resolved => closed
2015-11-30 18:04 jcfr Category Module FiducialRegistration => Module (Any CLI modules)
2017-06-07 23:27 Changeset attached => Slicer 2145-support-for-installing-extension-from-file 20882931