View Issue Details

IDProjectCategoryView StatusLast Update
0003341Slicer4Core: Diffusion and Tractography (Any modules)public2016-03-01 10:20
ReporterjcfrAssigned Tofbudin 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionSlicer 4.4.0Fixed in VersionSlicer 4.4.0 
Summary0003341: CLI - ResampleDTIVolume - Fix itkTestMainExtendedScalarTest
Description

Test named 'itkTestMainExtendedScalarTest' associated with ResampleDTIVolume should be reviewed !

The baseline associated with each command line module has been moved within
the Data/Baseline subdirectory of each module. For that reason, ResampleDTIVolume shouldn't reference the baseline 'AddTest_DOUBLE.mha' as input data.

TagsNo tags attached.

Relationships

child of 0003156 acknowledgedjcfr Automatic conversion of ExternalData to MD5 

Activities

jcfr

jcfr

2013-08-28 13:13

administrator   ~0009683

See r22351 - http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=22351

// ------------------------------
COMP: Disable configure time message mentioning some CLIs have NO tests

These messages (introduced by r20160 more than a year ago) didn't have
the intended effect. Despite the fact developer were systematically
looking at these warning message, they became "noise" and have been ignored.

This commit disables the warning message and reference a mantis issue
tracking the fact there is no test.

See 0001619, 0003333, 0003334, 0003335, 0003336, 0003337, 0003338, 0003339, 0003340, 0003341

fbudin

fbudin

2014-03-06 10:30

developer   ~0011251

ResampleDTIVolume tests should pass after this pull request:
https://github.com/Slicer/Slicer/pull/112

jcfr

jcfr

2014-03-06 12:45

administrator   ~0011287

Thanks for contributing these patches. It turns out that they can't be integrated because they are not based on a recent slicer.

Could you rebase them on top of the current master ?

See https://github.com/Slicer/Slicer/pull/112#issuecomment-36947113

jcfr

jcfr

2014-03-26 12:38

administrator   ~0011465

Fixed in r23025
See http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=23025

Issue History

Date Modified Username Field Change
2013-08-28 12:53 jcfr New Issue
2013-08-28 12:53 jcfr Target Version => Slicer 4.4.0
2013-08-28 13:13 jcfr Note Added: 0009683
2013-08-28 13:13 jcfr Relationship added related to 0003340
2013-08-28 13:13 jcfr Relationship added related to 0003339
2013-08-28 13:13 jcfr Relationship added parent of 0003338
2013-08-28 13:14 jcfr Relationship added parent of 0003337
2013-08-28 13:14 jcfr Relationship deleted parent of 0003337
2013-08-28 13:14 jcfr Relationship deleted parent of 0003338
2013-08-28 13:14 jcfr Relationship deleted related to 0003339
2013-08-28 13:14 jcfr Relationship deleted related to 0003340
2014-03-06 06:32 jcfr Relationship added child of 0003156
2014-03-06 06:47 jcfr Status new => assigned
2014-03-06 06:47 jcfr Assigned To => fbudin
2014-03-06 10:30 fbudin Note Added: 0011251
2014-03-06 12:45 jcfr Note Added: 0011287
2014-03-26 12:38 jcfr Note Added: 0011465
2014-03-26 12:38 jcfr Status assigned => resolved
2014-03-26 12:38 jcfr Fixed in Version => Slicer 4.4.0
2014-03-26 12:38 jcfr Resolution open => fixed
2014-03-26 12:38 jcfr Status resolved => closed
2016-03-01 10:20 jcfr Category Module ResampleDTIVolume => Core: Diffusion & Tractography (Any modules)
2016-06-20 14:14 jcfr Category Core: Diffusion & Tractography (Any modules) => Core: Diffusion and Tractography (Any modules)