View Issue Details

IDProjectCategoryView StatusLast Update
0003390Slicer4Module Markupspublic2017-06-22 12:21
ReporterfedorovAssigned Tonicole 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in VersionSlicer 4.7.0 
Summary0003390: Fiducials names are rendered very poorly
Description

This appears to be the case for tilted volumes, example dataset used is here: http://www.na-mic.org/Bug/file_download.php?file_id=1199&type=bug

As shown in the attached screenshot, the font rendering is so bad that it is not possible to recognize the name of the fiducial. If I scale the font size, it is fine.

TagsNo tags attached.

Relationships

related to 0004388 assignednicole Improve markups fiducial label apperance in slice views 

Activities

2013-09-11 12:06

 

lassoan

lassoan

2017-06-09 16:46

developer   ~0014690

I cannot reproduce this problem with Slicer 4.7.0-2017-05-27

lassoan

lassoan

2017-06-22 12:21

developer   ~0014912

Warping of fiducials was fixed in r26107.

The text quality is still not optimal, as the text is rendered using polygonal data. Implementing anti-aliased text labels is tracked in 0004388.

Issue History

Date Modified Username Field Change
2013-09-11 12:05 fedorov New Issue
2013-09-11 12:05 fedorov Status new => assigned
2013-09-11 12:05 fedorov Assigned To => nicole
2013-09-11 12:06 fedorov File Added: markups_font_rendering_is_poor.png
2017-06-09 16:46 lassoan Status assigned => resolved
2017-06-09 16:46 lassoan Resolution open => unable to reproduce
2017-06-09 16:46 lassoan Fixed in Version => Slicer 4.7.0
2017-06-09 16:46 lassoan Note Added: 0014690
2017-06-22 12:21 lassoan Note Added: 0014912
2017-06-22 12:21 lassoan Relationship added related to 0004388