View Issue Details

IDProjectCategoryView StatusLast Update
0003450Slicer4Module VolumeRenderingpublic2018-05-26 22:25
ReporterinortonAssigned Topinter 
PriorityhighSeveritymajorReproducibilityrandom
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in VersionSlicer 4.9.0 
Summary0003450: VR Module issues
Description

I have found it impossible to apply one set of volume rendering properties to a different volume. Changing the selected volume either has no effect, or creates a new set of Display+ROI+Annotation nodes. If I change those after selecting the volume, at best nothing happens; at worst, the display turns in to garbage with random colors pixelated to the bounds of the volume.

In general, the interactions between the various property selectors are rather non-deterministic and highly confusing.

TagsNo tags attached.

Activities

inorton

inorton

2013-10-16 10:07

developer   ~0010188

Windows 7/64-bit, Slicer 2013-10-15

lassoan

lassoan

2017-06-09 17:05

developer   ~0014693

The problem is still there in Slicer 4.7.0-2017-05-27

lassoan

lassoan

2018-05-26 22:25

developer   ~0015746

cpinter has recently fixed this. Please test and if there are remaining problems related to this then please reopen this issue.

Issue History

Date Modified Username Field Change
2013-10-16 10:06 inorton New Issue
2013-10-16 10:06 inorton Status new => assigned
2013-10-16 10:06 inorton Assigned To => finetjul
2013-10-16 10:07 inorton Note Added: 0010188
2017-06-09 17:05 lassoan Note Added: 0014693
2018-05-26 22:25 lassoan Assigned To finetjul => pinter
2018-05-26 22:25 lassoan Status assigned => resolved
2018-05-26 22:25 lassoan Resolution open => fixed
2018-05-26 22:25 lassoan Fixed in Version => Slicer 4.9.0
2018-05-26 22:25 lassoan Note Added: 0015746