View Issue Details

IDProjectCategoryView StatusLast Update
0003457Slicer4Module DICOMpublic2017-06-14 13:07
ReporterpearsomarkAssigned Topieper 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product VersionSlicer 4.3.0 
Target VersionFixed in Version 
Summary0003457: Loading DICOM SPECT data causes incrrect z spacing and orientation
Description

DICOM SPECT reconstructions which load correctly in version 4.2.2 have the wrong z spacing and orientation in version 4.3.1.

Additional Information

The issue has been reproduced on Linux 64 bit and MAC OS X, not tested on windows.
Attached is files.zip with screenshots showing the same file loaded into each version and a compressed SPECT file.

TagsNo tags attached.

Activities

2013-10-24 17:18

 

files.zip (864,338 bytes)

2013-10-24 17:35

 

Slicer4.2.2-1.jpg (107,218 bytes)
Slicer4.2.2-1.jpg (107,218 bytes)

2013-10-24 17:36

 

Slicer4.3.1.jpg (75,861 bytes)
Slicer4.3.1.jpg (75,861 bytes)
pieper

pieper

2013-11-11 06:45

administrator   ~0010302

Interesting - this is probably a side effect slicer's change to ITKv4.

Looking at the header it seems like the SliceThickness has the same value as the z spacing - in general this is not a reliable place to get the slice spacing but maybe for spect it is the right place.

Running a pure ITK program that just tries to read the file can replicate the issue, as shown below, and the messages even point to where the issue is.

0000009 spect $ ~/slicer4/latest/Slicer-superbuild/Slicer-build/lib/Slicer-4.3/cli-modules/GaussianBlurImageFilter -s 1 file0001 /tmp/file.nrrd
Warning: In /Users/pieper/slicer4/latest/Slicer-superbuild/ITKv4/Modules/ThirdParty/GDCM/src/gdcm/Source/MediaStorageAndFileFormat/gdcmImageHelper.cxx, line 775, function <unknow>
FIXME

Warning: In /Users/pieper/slicer4/latest/Slicer-superbuild/ITKv4/Modules/ThirdParty/GDCM/src/gdcm/Source/MediaStorageAndFileFormat/gdcmImageHelper.cxx, line 974, function <unknow>
Dont know how to handle spacing for: (0028,0009) ?? 4 Loaded:4

Warning: In /Users/pieper/slicer4/latest/Slicer-superbuild/ITKv4/Modules/ThirdParty/GDCM/src/gdcm/Source/MediaStorageAndFileFormat/gdcmImageHelper.cxx, line 775, function <unknow>
FIXME

Warning: In /Users/pieper/slicer4/latest/Slicer-superbuild/ITKv4/Modules/ThirdParty/GDCM/src/gdcm/Source/MediaStorageAndFileFormat/gdcmImageHelper.cxx, line 974, function <unknow>
Dont know how to handle spacing for: (0028,0009) ?? 4 Loaded:4

Warning: In /Users/pieper/slicer4/latest/Slicer-superbuild/ITKv4/Modules/ThirdParty/GDCM/src/gdcm/Source/MediaStorageAndFileFormat/gdcmImageHelper.cxx, line 775, function <unknow>
FIXME

Warning: In /Users/pieper/slicer4/latest/Slicer-superbuild/ITKv4/Modules/ThirdParty/GDCM/src/gdcm/Source/MediaStorageAndFileFormat/gdcmImageHelper.cxx, line 974, function <unknow>
Dont know how to handle spacing for: (0028,0009) ?? 4 Loaded:4

Warning: In /Users/pieper/slicer4/latest/Slicer-superbuild/ITKv4/Modules/ThirdParty/GDCM/src/gdcm/Source/MediaStorageAndFileFormat/gdcmImageHelper.cxx, line 775, function <unknow>
FIXME

Warning: In /Users/pieper/slicer4/latest/Slicer-superbuild/ITKv4/Modules/ThirdParty/GDCM/src/gdcm/Source/MediaStorageAndFileFormat/gdcmImageHelper.cxx, line 974, function <unknow>
Dont know how to handle spacing for: (0028,0009) ?? 4 Loaded:4

Warning: In /Users/pieper/slicer4/latest/Slicer-superbuild/ITKv4/Modules/ThirdParty/GDCM/src/gdcm/Source/MediaStorageAndFileFormat/gdcmImageHelper.cxx, line 775, function <unknow>
FIXME

Warning: In /Users/pieper/slicer4/latest/Slicer-superbuild/ITKv4/Modules/ThirdParty/GDCM/src/gdcm/Source/MediaStorageAndFileFormat/gdcmImageHelper.cxx, line 974, function <unknow>
Dont know how to handle spacing for: (0028,0009) ?? 4 Loaded:4

Here's the header of the resulting file.nrrd (with spacing of 1).

NRRD0004

Complete NRRD file format specification at:

http://teem.sourceforge.net/nrrd/format.html

type: short
dimension: 3
space: left-posterior-superior
sizes: 128 128 128
space directions: (4.4180599999999997,0,0) (0,4.4180599999999997,0) (0,0,1)
kinds: domain domain domain
endian: little
encoding: gzip
space origin: (0,0,0)

pieper

pieper

2013-11-11 06:59

administrator   ~0010304

Issue filed on ITK bug tracker:

https://issues.itk.org/jira/browse/ITK-3221

lassoan

lassoan

2017-06-14 13:07

developer   ~0014837

It works correctly in Slicer 4.7.0-2017-05-27

Issue History

Date Modified Username Field Change
2013-10-24 17:18 pearsomark New Issue
2013-10-24 17:18 pearsomark Status new => assigned
2013-10-24 17:18 pearsomark Assigned To => pieper
2013-10-24 17:18 pearsomark File Added: files.zip
2013-10-24 17:35 pearsomark File Added: Slicer4.2.2-1.jpg
2013-10-24 17:36 pearsomark File Added: Slicer4.3.1.jpg
2013-11-11 06:45 pieper Note Added: 0010302
2013-11-11 06:59 pieper Note Added: 0010304
2017-06-14 13:07 lassoan Status assigned => resolved
2017-06-14 13:07 lassoan Resolution open => unable to reproduce
2017-06-14 13:07 lassoan Note Added: 0014837