View Issue Details

IDProjectCategoryView StatusLast Update
0003475Slicer4Module RobustStatisticsSegmenterpublic2017-09-27 12:24
ReportergaoyiAssigned Togaoyi 
PrioritynormalSeverityfeatureReproducibilityN/A
Status feedbackResolutionfixed 
Product VersionSlicer 4.3.0 
Target VersionbacklogFixed in Version 
Summary0003475: add rejection label region
Description

Currently the way this RSS modules works is that user draw a label map to seed the target region. Then the algorithm grows the seeded region to grab the entire target.

But in cases where leakage is strong, we want to have a "rejection seeds" so that the surface will not grow into those regions.

This is to be added in this issue.

TagsNo tags attached.

Activities

gaoyi

gaoyi

2013-11-05 06:07

developer   ~0010270

Topic pushed to https://github.com/gaoyi/Slicer/tree/3475-add-rejection-label-to-rss-module

gaoyi

gaoyi

2013-11-05 07:33

developer   ~0010272

fixed in 64f1716896929a486ed41b46e4248592ee7cebdc

gaoyi

gaoyi

2013-11-05 07:35

developer   ~0010273

fixed in
https://github.com/gaoyi/Slicer/tree/3475-add-rejection-label-to-rss-module

commit
64f1716896929a486ed41b46e4248592ee7cebdc

gaoyi

gaoyi

2013-11-05 07:56

developer   ~0010277

only change to Resolved after integrated into Slicer.

jcfr

jcfr

2013-11-05 08:17

administrator   ~0010280

Could you tweak the commit messages:

// ---------------
ENH: RSS module has rejection label
// ---------------
->

// ---------------
ENH: RSS module - Add rejection label

Before this commit, it has not possible to ... when applied to XXX type of images.
This commit introduced a new option named YYYY allowing to ..... More specifically it ...

// ---------------

// ---------------
STYLE: clean up code and rename files from txx to hxx
// ---------------

->

// ---------------
STYLE: RSS module - Clean up code

Remove comment code
Rename files from txx to hxx
Remove "omp" preprocessor ... because ...
// ---------------

// ---------------
PERF: only post process when needed
// ---------------

->

// ---------------
ENH: RSS module - Post process only when needed
// ---------------

Other tweaks, ...

you could also renamed "bUseRejctionLabelImage" -> "useRejectionLabelImage"

See also http://wiki.slicer.org/slicerWiki/index.php/Documentation/Nightly/Developers/Style_Guide#Summary

jcfr

jcfr

2014-05-13 15:55

administrator   ~0011835

Hi,

Would it be possible to have an other look at the following pull request: https://github.com/Slicer/Slicer/pull/81 ?

I think with a little more work we could integrate into Slicer before the 4.4 release on May 30th.

lassoan

lassoan

2017-09-27 12:24

developer   ~0015179

It would be nice to fix up RSS effect and migrate to Segment Editor, but Grow from seed effect in Slicer core and Watershed effect in SegmentEditorExtraEffects extension already work quite well.

Issue History

Date Modified Username Field Change
2013-11-05 05:24 gaoyi New Issue
2013-11-05 05:25 gaoyi Status new => assigned
2013-11-05 05:25 gaoyi Assigned To => gaoyi
2013-11-05 06:07 gaoyi Note Added: 0010270
2013-11-05 07:33 gaoyi Note Added: 0010272
2013-11-05 07:35 gaoyi Note Added: 0010273
2013-11-05 07:35 gaoyi Status assigned => resolved
2013-11-05 07:35 gaoyi Resolution open => fixed
2013-11-05 07:56 gaoyi Note Added: 0010277
2013-11-05 07:56 gaoyi Status resolved => assigned
2013-11-05 08:17 jcfr Note Added: 0010280
2013-11-05 08:17 jcfr Target Version => Slicer 4.4.0
2014-05-13 15:55 jcfr Note Added: 0011835
2014-05-13 15:55 jcfr Status assigned => feedback
2014-10-27 21:05 jcfr Target Version Slicer 4.4.0 => Slicer 4.5.0-1
2015-11-02 11:27 jcfr Target Version Slicer 4.5.0-1 => Slicer 4.6.0
2016-10-13 01:22 jcfr Target Version Slicer 4.6.0 => Slicer 4.7.0
2017-09-27 12:24 lassoan Target Version Slicer 4.7.0 => backlog
2017-09-27 12:24 lassoan Note Added: 0015179