View Issue Details

IDProjectCategoryView StatusLast Update
0003531Slicer4Module Markupspublic2018-03-02 11:01
ReporteregibsonAssigned Tonicole 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product VersionSlicer 4.3.1 
Target VersionSlicer 4.7.0Fixed in VersionSlicer 4.7.0 
Summary0003531: Fiducial markup jumps to current cursor position in 2D slice from out of plane
Description

A fiducial jumps from its correct position to the current cursor position in a 2D view when the cursor is moved over the view.

Additional Information

I can consistently reproduce this on my own machine with these steps:
1) Load Slicer 4.3.1 r22599
2) Load a Slicer3 fiducial list (attached). Note that no fiducials are in the current axial slice.
3) Move mouse over axial slice view to the approximate RL and AP position of a fiducial (whose SI coordinate is not the current slice).
4) The fiducial jumps to the current cursor position.

Unsure about severity; this can result in the silent alteration of data.

In the error log, I see the warning:
Warning: In ............\Slicer-431-1\Modules\Loadable\Markups\MRML\vtkMRMLMarkupsFiducialStorageNode.cxx, line 108
vtkMRMLMarkupsFiducialStorageNode (000000000F8A6460): ReadDataInternal: no display node!

Warning: In ............\Slicer-431-1\Modules\Loadable\Markups\MRML\vtkMRMLMarkupsFiducialStorageNode.cxx, line 111
vtkMRMLMarkupsFiducialStorageNode (000000000F8A6460): ReadDataInternal: adding a new display node.

Warning: In ............\Slicer-431-1\Modules\Loadable\Markups\MRML\vtkMRMLMarkupsFiducialStorageNode.cxx, line 244
vtkMRMLMarkupsFiducialStorageNode (000000000F8A6460): Have an unversioned file, assuming Slicer 3 format .fcsv

Followed by the debug message:
"MarkupsFiducials" Reader has successfully read the file "C:/ExVivoToPETMRInVivoAxTPSInVivo.fcsv"

I have also replicated it using a new fiducial list created in Slicer4, yielding the same behaviour and the first two of the above warning messages.

TagsNo tags attached.

Relationships

related to 0003690 assignednicole Markups: Implement hack/workaround for 0001690 and 0003531 

Activities

2013-12-11 15:27

 

ExVivoToPETMRInVivoAxTPSInVivo.fcsv (1,771 bytes)
nicole

nicole

2014-03-03 13:20

administrator   ~0010665

The warnings about the display node aren't critical, they're just informing you that a new node is being added to help display the fiducial list.
I wasn't able to reproduce this problem with the current code (debug build on Mac), are you still seeing this issue?

egibson

egibson

2014-03-04 06:43

reporter   ~0010676

As of nightly build r22919, this appears to no longer be happening on my system either.

nicole

nicole

2014-03-04 07:22

administrator   ~0010677

Okay, I'll resolve the bug and you can reopen it if you see this behaviour again. Thanks for checking!

egibson

egibson

2014-03-04 11:06

reporter   ~0010679

I spoke too soon. I was able to reproduce it on a fresh instance of r22919, following the steps in Additional Information. Specifically, I move the mouse to RAS coordinate <8.6, 22.7, 0.0> on the axial view, without changing the axial slice.

In case this is system dependent, my system is 64-bit Windows 7 Professional Service Pack 1.

lassoan

lassoan

2017-06-09 16:37

developer   ~0014687

I cannot reproduce this anymore with Slicer 4.7.0-2017-05-27

Issue History

Date Modified Username Field Change
2013-12-11 15:27 egibson New Issue
2013-12-11 15:27 egibson File Added: ExVivoToPETMRInVivoAxTPSInVivo.fcsv
2013-12-11 19:00 egibson Additional Information Updated
2014-01-06 12:00 nicole Assigned To => nicole
2014-01-06 12:00 nicole Status new => assigned
2014-01-06 12:00 nicole Category Core: GUI => Module Markups
2014-01-06 12:00 nicole Target Version => Slicer 4.4.0
2014-03-03 13:20 nicole Note Added: 0010665
2014-03-04 06:43 egibson Note Added: 0010676
2014-03-04 07:22 nicole Note Added: 0010677
2014-03-04 07:22 nicole Status assigned => resolved
2014-03-04 07:22 nicole Fixed in Version => Slicer 4.3.2
2014-03-04 07:22 nicole Resolution open => fixed
2014-03-04 11:06 egibson Note Added: 0010679
2014-03-04 11:06 egibson Status resolved => feedback
2014-03-04 11:06 egibson Resolution fixed => reopened
2014-03-06 04:56 nicole Status feedback => assigned
2014-03-06 10:17 nicole Fixed in Version Slicer 4.3.2 => Slicer 4.4.0
2014-03-07 09:31 pieper Priority normal => urgent
2014-03-07 09:31 pieper Fixed in Version Slicer 4.4.0 =>
2014-05-13 10:33 jcfr Relationship added related to 0003690
2014-05-13 10:34 jcfr Target Version Slicer 4.4.0 =>
2015-09-01 10:26 nicole Target Version => Slicer 4.5.0-1
2015-10-28 13:57 nicole Target Version Slicer 4.5.0-1 => Slicer 4.5.1
2016-10-12 02:31 jcfr Target Version Slicer 4.5.1 => Slicer 4.7.0
2017-06-09 16:37 lassoan Status assigned => resolved
2017-06-09 16:37 lassoan Resolution reopened => unable to reproduce
2017-06-09 16:37 lassoan Fixed in Version => Slicer 4.7.0
2017-06-09 16:37 lassoan Note Added: 0014687
2018-03-02 11:01 jcfr Status resolved => closed