View Issue Details

IDProjectCategoryView StatusLast Update
0003555Slicer4Module Markupspublic2017-06-12 21:38
ReporterlassoanAssigned Tonicole 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product VersionSlicer 4.3.1-2 
Target VersionFixed in Version 
Summary0003555: Markups Scale slider is not updated when switching markup list
Description

Markups Scale slider is not updated when switching markup list. Whenever the markup list is changed to another one, the slider should be moved to the scale that is valid for the currently selected markup list.

TagsNo tags attached.

Activities

nicole

nicole

2014-03-03 13:13

administrator   ~0010664

The scale slider is the equivalent of the old small, Medium, LARGE annotation size buttons - it's not set from the display node, it only pushes to it. Setting it would require some estimating because when pushing from the slider to the display node, it sets the text and glyph scales to the same value. From the display node side, the text and glyph scale are set to different values on initialisation and I'd have to figure out how to represent that as one number that made sense to the user.
I think I could make it work with some finessing of ratios between the two scales, but it still might not be very clear to the user.
Another related issue is the lack of hide text and hide glyph options, requiring the user to set the individual scales to 0 (or opacities to 0) to hide part of the fiducial.

So: the harder solution might be to:
take out the text and glyph size sliders
add hide buttons for the text and glyph
update the fiducial scale slider to set/reflect one number for both the text and glyph (this removes the ability to set the scales manually)

The easiest solution:
take out the fiducial scale slider
replace it with small, Medium, LARGE buttons
add hide text and glyph buttons

todo: dig up the bug report/request asking for the single scale functionality and review

lassoan

lassoan

2017-06-12 21:38

developer   ~0014787

It is not reproducible anymore in Slicer 4.7.0-2017-06-02 (Windows 10). Scales are correctly updated when switching between markups lists.

Issue History

Date Modified Username Field Change
2014-01-13 13:32 lassoan New Issue
2014-01-13 13:32 lassoan Status new => assigned
2014-01-13 13:32 lassoan Assigned To => nicole
2014-03-03 13:13 nicole Note Added: 0010664
2017-06-12 21:38 lassoan Status assigned => resolved
2017-06-12 21:38 lassoan Resolution open => unable to reproduce
2017-06-12 21:38 lassoan Note Added: 0014787