View Issue Details

IDProjectCategoryView StatusLast Update
0003580Slicer4Module DICOMpublic2017-07-25 08:54
ReporterboxerabAssigned Tomehrtash 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product VersionSlicer 4.3.1 
Target VersionFixed in Version 
Summary0003580: Crash after query DICOM server with no filter
Description

I ran a DICOM query on dicomserver.co.uk, with time set to any, and modality
set to all. i.e. no filter on the query. The program runs for a while and then crashes. This is 100% repeatable.

Additional Information

windows 8
Slicer 4.3.1 r22599

TagsNo tags attached.

Activities

pieper

pieper

2014-02-07 04:27

administrator   ~0010570

We should check if the ctkDICOM application exhibits the same behavior. It is distributed with the slicer application or can be built from scratch for the commontk source code.

lassoan

lassoan

2017-07-25 08:54

developer   ~0014962

There is no crash (hundreds of series are successfully imported). Tested with Slicer 4.7.0-2017-07-25 on Windows10.

Issue History

Date Modified Username Field Change
2014-02-06 17:15 boxerab New Issue
2014-02-06 17:15 boxerab Status new => assigned
2014-02-06 17:15 boxerab Assigned To => pieper
2014-02-07 04:20 pieper Assigned To pieper => mehrtash
2014-02-07 04:27 pieper Note Added: 0010570
2017-07-25 08:54 lassoan Status assigned => resolved
2017-07-25 08:54 lassoan Resolution open => unable to reproduce
2017-07-25 08:54 lassoan Note Added: 0014962