View Issue Details

IDProjectCategoryView StatusLast Update
0003594Slicer4Core: Base Codepublic2015-08-03 22:57
ReporterlassoanAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0003594: WindowCenter and WindowWidth values are not initialized correctly when reading volumes
Description

The default window width/level should be initialized with the values read from the input file. It worked well in Slicer3.

It is definitely does not work for DICOM files now, but maybe it is broken for other input file types, too.

How to reproduce: Load a volume then go to the Volumes module and check the Window Width and Level values => ERROR: some automatically determined values are used instead of the values stored in the file

For example:
Input volume: https://subversion.assembla.com/svn/slicerrt/trunk/SlicerRt/data/eclipse-8.1.20-phantom-prostate/Original
Window width/level values in the DICOM file:
(0028,1050) DS [40] # 2, 1 WindowCenter
(0028,1051) DS [400] # 4, 1 WindowWidth
Window width/level value after loading in Slicer 4.3.1:
W: 1552, L: -207
Window width/level value after loading in Slicer 3.6.3:
W: 400, L: 40

TagsNo tags attached.

Relationships

duplicate of 0003467 closedpinter Read and apply window/level settings defined in DICOM images 

Activities

pieper

pieper

2014-02-24 09:10

administrator   ~0010622

Yes, we should really wrap that one up - basically we just need to look for the WindowCenter/WindowWidth tags in the dicom header and put them in the display node. It should go in the slicer4 DICOMScalarVolumePlugin (and maybe other plugins?).

Here's the slicer3 code for that around line 676:

http://viewvc.slicer.org/viewvc.cgi/Slicer3/trunk/Base/GUI/Tcl/LoadVolume.tcl?revision=16853&view=markup

I'll add this note to the issues.

-Steve

jcfr

jcfr

2015-08-03 22:57

administrator   ~0013218

This has been fixed for DICOM in r24407
See http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=24407

If there are issue with other file format, this issue should be re-open providing test data.

Issue History

Date Modified Username Field Change
2014-02-24 07:57 lassoan New Issue
2014-02-24 07:57 lassoan Status new => assigned
2014-02-24 07:57 lassoan Assigned To => jcfr
2014-02-24 08:44 lassoan Relationship added related to 0003467
2014-02-24 09:10 pieper Note Added: 0010622
2015-08-03 22:57 jcfr Note Added: 0013218
2015-08-03 22:57 jcfr Relationship replaced duplicate of 0003467
2015-08-03 22:57 jcfr Duplicate ID 0 => 3467
2015-08-03 22:57 jcfr Status assigned => resolved
2015-08-03 22:57 jcfr Resolution open => duplicate