View Issue Details

IDProjectCategoryView StatusLast Update
0003671Slicer4Module DICOMpublic2017-06-14 12:59
ReporterJaymaxAssigned Topieper 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product VersionSlicer 4.3.1-2 
Target VersionFixed in Version 
Summary0003671: Error importing DICOM image set
Description

Message: Slicer has caught an internal error.
You may be able to continue from this point, but results are undefined.
Suggested action is to save your work and restart.
If you have a repeatable sequence of steps that causes this message, please report the issue following instructions available at http://slicer.org

The message detail is:
Exception thrown in event: Calling methods on uninitialized ctkDICOMItem

Additional Information

Processing /home/jaymax/Documents/Health/N/01738871.dcm
QSqlQuery::value: not positioned on a valid record
QSqlQuery::value: not positioned on a valid record
inserting filePath: "/home/jaymax/Documents/Health/N/01738871.dcm"
database filename for "1.3.12.2.1107.5.2.36.40442.201305011132506207940429" is empty - we should insert on top of it
Going to insert this instance with dbPatientID: 1
Used existing study: "1.2.826.0.1.3680043.8.1074.13460"
Statement: SELECT * FROM Series WHERE SeriesInstanceUID = ?
Used existing series: "1.3.12.2.1107.5.2.36.40442.2013050111284192142837953.0.0.0"
Could not load "/home/jaymax/Documents/Health/MRI (Nuala)/01738871.dcm"
DCMTK says: No such file or directory
"Slicer has caught an internal error.

You may be able to continue from this point, but results are undefined.

Suggested action is to save your work and restart.

If you have a repeatable sequence of steps that causes this message, please report the issue following instructions available at http://slicer.org

The message detail is:

Exception thrown in event: Calling methods on uninitialized ctkDICOMItem"

TagsNo tags attached.

Activities

2014-04-24 17:02

 

01738871.dcm (173,752 bytes)
pieper

pieper

2014-04-25 03:21

administrator   ~0011668

Please provide more specific information about how this came about:

  • what data were you trying to load? (provide example of the data if possible)

  • what platform were you using (windows, mac...)

  • what version of slicer

  • are you able to reproduce the issue with the latest nightly build?
Jaymax

Jaymax

2014-04-25 04:47

reporter   ~0011670

  • The dicom file referred to in the error message was/is attached to the initial bug report

  • Ubuntu 64bit

  • 4.3.1 per the initial report - downloaded from
    http://download.slicer.org/bitstream/153901

  • I haven't tried, I can certainly try that if it will be helpful
pieper

pieper

2014-04-25 08:25

administrator   ~0011671

Hi -

Thanks for providing the info and the data. I was able to load it fine on a recent nightly build of slicer so I believe the issue has already been resolved. Please try a recent build.

-Steve

lassoan

lassoan

2017-06-14 12:59

developer   ~0014834

The problem seems to be already resolved, the reporter did not say otherwise.

Issue History

Date Modified Username Field Change
2014-04-24 17:02 Jaymax New Issue
2014-04-24 17:02 Jaymax Status new => assigned
2014-04-24 17:02 Jaymax Assigned To => pieper
2014-04-24 17:02 Jaymax File Added: 01738871.dcm
2014-04-25 03:21 pieper Note Added: 0011668
2014-04-25 03:21 pieper Status assigned => feedback
2014-04-25 04:47 Jaymax Note Added: 0011670
2014-04-25 08:25 pieper Note Added: 0011671
2017-06-14 12:59 lassoan Status feedback => resolved
2017-06-14 12:59 lassoan Resolution open => unable to reproduce
2017-06-14 12:59 lassoan Note Added: 0014834