View Issue Details

IDProjectCategoryView StatusLast Update
0003700Slicer4Core: Base Codepublic2017-06-10 08:51
ReporterjcfrAssigned Tofinetjul 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionSlicer 4.4.0Fixed in VersionSlicer 4.4.0 
Summary0003700: Fix debug message at Slicer startup
Description

With Slicer r23218, the following debug message are now printed at startup:

toInt : value 1 for singleStep 0 is out of integer bounds !
toInt : value 1 for singleStep 0 is out of integer bounds !
toInt : value 1 for singleStep 0 is out of integer bounds !
toInt : value 1 for singleStep 0 is out of integer bounds !
toInt : value 1 for singleStep 0 is out of integer bounds !
toInt : value 1 for singleStep 0 is out of integer bounds !

This seems to be related to your recent CTK slider fixes, would it be possible to remove the message or fix the underlying issue ?

Thanks

TagsNo tags attached.

Activities

finetjul

finetjul

2014-05-21 10:48

administrator   ~0011938

Fixed in r23224

Related Changesets

Import 2017-06-07 23:51:09: master 7a05d88d

2014-05-21 14:42:12

finetjul

Details Diff
BUG: Update qMRMLSliderWidget single step when range changes

The single step can depend on the range of the slider, update it when
needed.

Issues 0003657, 0003700
$ git shortlog 3aaa591..daaf705 --no-merges
Julien Finet (1):
Virtualize ctkRangeWidget and ctkSliderWidget public API

git-svn-id: http://svn.slicer.org/Slicer4/trunk@23224 3bd1e089-480b-0410-8dfb-8563597acbee
mod - Libs/MRML/Widgets/qMRMLSliderWidget.cxx Diff File
mod - Libs/MRML/Widgets/qMRMLSliderWidget.h Diff File
mod - SuperBuild/External_CTK.cmake Diff File

Issue History

Date Modified Username Field Change
2014-05-20 12:41 jcfr New Issue
2014-05-20 12:41 jcfr Status new => assigned
2014-05-20 12:41 jcfr Assigned To => jcfr
2014-05-20 12:41 jcfr Assigned To jcfr => finetjul
2014-05-20 12:41 jcfr Target Version => Slicer 4.4.0
2014-05-21 10:48 finetjul Note Added: 0011938
2014-05-21 10:48 finetjul Status assigned => resolved
2014-05-21 10:48 finetjul Fixed in Version => Slicer 4.4.0
2014-05-21 10:48 finetjul Resolution open => fixed
2014-05-23 22:35 jcfr Status resolved => closed
2017-06-10 08:51 finetjul Changeset attached => Slicer master 7a05d88d