View Issue Details

IDProjectCategoryView StatusLast Update
0003702Slicer4Module Volumespublic2016-02-26 14:07
ReporterspujolAssigned Toalexy 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSlicer 4.3.1-2 
Target VersionFixed in Version 
Summary0003702: Can't display glyphs overlaid on FA map
Description

Hi,

I did the following steps using the DTI sample dataset:

1) Display the Glyphs on red slice
2) Change the Color by Scalar to Color Orientation in the 'Glyphs on slices Display' tab
3) Change the Scalar Mode to FA in the 'Scalar Display Tab'

The glyphs disappear and the Glyphs on Slices Display becomes unavailable to the user (see screenshot).

When I close the Scene, slicer crashes.

Additional Information

Mac OS X 10.9.2

TagsNo tags attached.

Relationships

related to 0003323 closedpieper Slicer crash when I follow the Diffusion Tensor Imaging Tutorial 
related to 0003988 resolvedalexy User can only display diffusion tensor with glyphs if the scalar mode that is selected if colorOrientation 

Activities

2014-05-21 01:07

 

pieper

pieper

2015-10-23 16:01

administrator   ~0013414

Confirmed crash:

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 ??? 0x000000012631b580 typeinfo for vtkObject + 0
1 libqSlicerVolumesModuleWidgets.dylib 0x000000013d1dac65 qSlicerDTISliceDisplayWidget::qt_static_metacall(QObject*, QMetaObject::Call, int, void) + 245 (moc_qSlicerDTISliceDisplayWidget.cxx:78)
2 QtCore 0x000000011feaed6e QMetaObject::activate(QObject, QMetaObject const, int, void
) + 1566
3 libqMRMLWidgets.dylib 0x000000010f16c91a qMRMLNodeComboBox::currentNodeChanged(vtkMRMLNode) + 74 (moc_qMRMLNodeComboBox.cxx:305)
4 libqMRMLWidgets.dylib 0x000000010f0e1258 qMRMLNodeComboBox::emitCurrentNodeChanged() + 184 (qMRMLNodeComboBox.cxx:651)
5 libqMRMLWidgets.dylib 0x000000010f16c5c2 qMRMLNodeComboBox::qt_static_metacall(QObject
, QMetaObject::Call, int, void) + 850 (moc_qMRMLNodeComboBox.cxx:177)
6 QtCore 0x000000011feaed6e QMetaObject::activate(QObject, QMetaObject const, int, void
) + 1566
7 QtGui 0x000000011f302b89 QComboBox::currentIndexChanged(QString const&) + 41
8 QtGui 0x000000011f304889 QComboBoxPrivate::_q_emitCurrentIndexChanged(QModelIndex const&) + 73
9 QtGui 0x000000011f30bb8f QComboBoxPrivate::_q_rowsRemoved(QModelIndex const&, int, int) + 271
10 QtCore 0x000000011feaed6e QMetaObject::activate(QObject, QMetaObject const, int, void) + 1566
11 QtCore 0x000000011ff02edf QAbstractItemModel::rowsRemoved(QModelIndex const&, int, int) + 63
12 QtCore 0x000000011fe8f9bb QAbstractItemModel::endRemoveRows() + 171
13 QtGui 0x000000011f4dc0c2 QSortFilterProxyModelPrivate::remove_source_items(QVector<int>&, QVector<int>&, QVector<int> const&, QModelIndex const&, Qt::Orientation, bool) + 274
14 QtGui 0x000000011f4de00a QSortFilterProxyModelPrivate::source_items_about_to_be_removed(QModelIndex const&, int, int, Qt::Orientation) + 266
15 QtCore 0x000000011feaed6e QMetaObject::activate(QObject, QMetaObject const, int, void
) + 1566
16 QtCore 0x000000011ff02f2f QAbstractItemModel::rowsAboutToBeRemoved(QModelIndex const&, int, int) + 63
17 QtCore 0x000000011fe89752 QAbstractItemModel::beginRemoveRows(QModelIndex const&, int, int) + 130
18 QtGui 0x000000011f4ea4f5 QStandardItemModelPrivate::rowsAboutToBeRemoved(QStandardItem, int, int) + 69
19 QtGui 0x000000011f4ecb7e QStandardItem::removeRows(int, int) + 110
20 libqMRMLWidgets.dylib 0x000000010f0fc7de qMRMLSceneModel::updateScene() + 2398 (qMRMLSceneModel.cxx:763)
21 libqMRMLWidgets.dylib 0x000000010f100a58 qMRMLSceneModel::onMRMLSceneClosed(vtkMRMLScene
) + 40 (qMRMLSceneModel.cxx:1530)
22 libqMRMLWidgets.dylib 0x000000010f0f7be2 qMRMLSceneModel::onMRMLSceneEvent(vtkObject, unsigned long, void, void) + 914 (qMRMLSceneModel.cxx:1183)
23 libvtkCommon-6.3.1.dylib 0x0000000125a1c704 vtkCallbackCommand::Execute(vtkObject
, unsigned long, void) + 84
24 libvtkCommon-6.3.1.dylib 0x0000000125be0bff vtkSubjectHelper::InvokeEvent(unsigned long, void
, vtkObject) + 2495
25 libvtkCommon-6.3.1.dylib 0x0000000125be11b2 vtkObject::InvokeEvent(unsigned long, void
) + 66
26 libMRMLCore.dylib 0x00000001151dac91 vtkObject::InvokeEvent(unsigned long) + 33 (vtkObject.h:215)
27 libMRMLCore.dylib 0x000000011538e577 vtkMRMLScene::EndState(unsigned long) + 199 (vtkMRMLScene.cxx:599)
28 libMRMLCore.dylib 0x000000011538deec vtkMRMLScene::Clear(int) + 284 (vtkMRMLScene.cxx:325)
29 libqSlicerApp.dylib 0x000000010e9ab003 qSlicerAppMainWindow::on_FileCloseSceneAction_triggered() + 35 (qSlicerAppMainWindow.cxx:868)
30 libqSlicerApp.dylib 0x000000010e9c645d qSlicerAppMainWindow::qt_static_metacall(QObject, QMetaObject::Call, int, void) + 461 (moc_qSlicerAppMainWindow.cxx:165)
31 libqSlicerApp.dylib 0x000000010e9c6ace qSlicerAppMainWindow::qt_metacall(QMetaObject::Call, int, void
) + 126 (moc_qSlicerAppMainWindow.cxx:245)
32 QtCore 0x000000011feaefb2 QMetaObject::activate(QObject
, QMetaObject const*, int, void) + 2146
33 QtGui 0x000000011ef413a1 QAction::triggered(bool) + 49
34 QtGui 0x000000011ef42734 QAction::activate(QAction::ActionEvent) + 180
35 QtGui 0x000000011eef4c5a -[QCocoaMenuLoader qtDispatcherToQAction:] + 106
36 libsystem_trace.dylib 0x00007fff9166bcd7 _os_activity_initiate + 75
37 com.apple.AppKit 0x00007fff8628beb1 -[NSApplication sendAction:to:from:] + 452
38 com.apple.AppKit 0x00007fff8628bc4e -[NSMenuItem _corePerformAction] + 382
39 com.apple.AppKit 0x00007fff8628b97c -[NSCarbonMenuImpl performActionWithHighlightingForItemAtIndex:] + 114
40 libsystem_trace.dylib 0x00007fff9166bcd7 _os_activity_initiate + 75
41 com.apple.AppKit 0x00007fff8628a8ad -[NSMenu performKeyEquivalent:] + 359
42 com.apple.AppKit 0x00007fff86289a6f -[NSApplication _handleKeyEquivalent:] + 920
43 com.apple.AppKit 0x00007fff8619483a -[NSApplication sendEvent:] + 4080
44 QtGui 0x000000011eef57d4 -[QNSApplication sendEvent:] + 84
45 com.apple.AppKit 0x00007fff860bdb68 -[NSApplication run] + 711
46 QtGui 0x000000011ef00640 QEventDispatcherMac::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 1824
47 QtCore 0x000000011fe955a4 QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 68
48 QtCore 0x000000011fe95954 QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) + 324
49 QtCore 0x000000011fe981cc QCoreApplication::exec() + 188
50 0x000000010e96053a (anonymous namespace)::SlicerAppMain(int, char
) + 5130 (Main.cxx:220)
51 0x000000010e95f122 main + 34 (Main.cxx:254)
52 libdyld.dylib 0x00007fff8ef585c9 start + 1

pieper

pieper

2015-10-23 16:02

administrator   ~0013415

To display glyphs the tensor pipeline needs to be active so it makes sense that the glyphs are deactivated and the glyph option widgets are disabled when FA mode is selected.

To display glyphs on FA, I suggest putting an FA scalar in the foreground and DTI in the background layer and putting the foreground at 100% opacity.

alexy

alexy

2016-02-26 14:06

developer   ~0013825

Fixed multiple causes of crashes on scene close.
Also enable glyphs display for all scalar components on slices. The glyphs visibility was disabled because of crashes described in
http://na-mic.org/Mantis/view.php?id=3323
which have been fixed.

Issue History

Date Modified Username Field Change
2014-05-21 01:07 spujol New Issue
2014-05-21 01:07 spujol File Added: Screen Shot 2014-05-21 at 11.00.37 AM.png
2015-10-23 16:01 pieper Note Added: 0013414
2015-10-23 16:02 pieper Note Added: 0013415
2016-01-05 14:56 lauren Relationship added related to 0003988
2016-02-26 14:06 alexy Note Added: 0013825
2016-02-26 14:06 alexy Assigned To => alexy
2016-02-26 14:06 alexy Status new => resolved
2016-02-26 14:06 alexy Resolution open => fixed
2016-02-26 14:07 alexy Relationship added related to 0003323