View Issue Details

IDProjectCategoryView StatusLast Update
0003761Slicer4Module Markupspublic2017-06-10 08:51
ReporterjcfrAssigned Tonicole 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionSlicer 4.4.0Fixed in VersionSlicer 4.4.0 
Summary0003761: Markups: test_MarkupsInCompareViewersSelfTest1 is failing
Description

With either VTKv5 or VTKv5, the test is failing.

As illustrated in [1], it seems that commit r23325 [2] caused the test to fail.

[1] http://slicer.cdash.org/testSummary.php?project=1&name=py_MarkupsInCompareViewersSelfTest&date=2014-06-11
[2] http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=23325

// -------------------------
"Volume" Reader has successfully read the file "/tmp/RemoteIO/MR-head.nrrd" 
Load finished

Placed 3 fiducials
ERROR: In /home/kitware/Dashboards/Continuous/Slicer4-0-build-64bits-QT4.8.5-PythonQt-With-Tcl-CLI-Release-continuous/VTKv6/Rendering/Core/vtkRenderer.cxx, line 1296
vtkOpenGLRenderer (0x5c1ce90): WorldToView: no active camera, cannot compute world to view, returning 0,0,0

ERROR: In /home/kitware/Dashboards/Continuous/Slicer4-0-build-64bits-QT4.8.5-PythonQt-With-Tcl-CLI-Release-continuous/VTKv6/Rendering/Core/vtkRenderer.cxx, line 1296
vtkOpenGLRenderer (0x5c1ce90): WorldToView: no active camera, cannot compute world to view, returning 0,0,0
// -------------------------
TagsNo tags attached.

Relationships

related to 0001690 assignednicole fiducial shows in wrong lightbox cell 
has duplicate 0003762 closednicole Markups: test_MarkupsInCompareViewersSelfTest1 is failing 

Activities

nicole

nicole

2014-07-09 12:56

administrator   ~0012159

Last edited: 2014-07-09 12:57

Test is also failing with VTKv6.

This crash returns when events are out of synch in changing layouts. Steve proposed a patch once before in [1] but it didn't get into VTK via gerrit. I'd like to propose patching our VTK[2] to avoid the crash and to give an error message instead, and if it works well with our nightly tests to submit it to gerrit. The vtkOpenGLRenderer is giving an error message instead of crashing so this patch matches that handling of the non active camera case.

[1] http://na-mic.org/Mantis/view.php?id=1690
[2] https://github.com/naucoin/VTK/commit/feace6d70d583ce4f861d279942b164f10c25f30

jcfr

jcfr

2014-07-11 04:50

administrator   ~0012161

@Nicole: Sounds like a plan. Out of curiosity, I couldn't find the patch Steve submitted on Gerrit [1], do you have the link ? In parallel, I think it would make sense to re-submit to Gerrit.

[1] http://review.source.kitware.com/#/q/owner:pieper,n,z

nicole

nicole

2014-07-11 06:41

administrator   ~0012168

It didn't get submitted to gerrit, just posted as a diff on the bug report.
I'll do a pull request on our VTK branch and then look at the gerrit submission process (unless Steve wants to do it - we ended up writing pretty much the same code!).

jcfr

jcfr

2014-07-12 16:33

administrator   ~0012171

Thanks for moving forward with this.

Pull request on Slicer/VTK would be great. (make sure to base the pull request on top of "slicer-4.3-v6.1.0" [1]

[1] https://github.com/Slicer/VTK/commits/slicer-4.3-v6.1.0

The best way to get it integrated into VTK6 is to submit a patch on Gerrit. Let me know if you have any issue with this. See http://www.vtk.org/Wiki/VTK

nicole

nicole

2014-07-14 07:12

administrator   ~0012177

Slicer/VTK pull request:
https://github.com/Slicer/VTK/pull/2

jcfr

jcfr

2014-07-18 00:06

administrator   ~0012191

Partially fixed in r23462. The doesn't crash anymore but still report VTK errors. See below.

//-------------------------------------------------
BUG: Update VTKv6 external project - Fix test MarkupsInCompareViewersSelfTest

$ git shortlog 4d7abb2..169b37b
Nicole Aucoin (1):
BUG: fix null pointer crash in view to world with no active camera

This commit prevent the test from failing but it doesn't avoid the
following error from being displayed:

//------------
338: ERROR: In /home/jchris/Projects/Slicer-2-SuperBuild-Debug/VTKv6/Rendering/Core/vtkRenderer.cxx, line 1252
338: vtkOpenGLRenderer (0x741a1d0): ViewToWorld: no active camera, cannot compute view to world, returning 0,0,0
338:
338:
338: MH Head in background, scrolled to a fiducial
[...]
338: Switched back to conventional layout
338: Switched to Compare grid
338: ERROR: In /home/jchris/Projects/Slicer-2-SuperBuild-Debug/VTKv6/Common/ExecutionModel/vtkAlgorithm.cxx, line 1421
338: vtkOpenGLImageMapper (0x7548770): Attempt to get connection index 0 for input port 0, which has 0 connections.
//------------

See 0003761

nicole

nicole

2014-07-29 14:40

administrator   ~0012281

svn 23493 [1] checks for active cameras before repositioning or enabling the fiducial widget or handles. The test is no longer printing error messages and the updates get called again to update once the renderer has been set up properly.

[1] http://viewvc.slicer.org/viewvc.cgi/Slicer4?view=revision&revision=23493

Related Changesets

Import 2017-06-07 23:51:09: master c7b22bdd

2014-07-29 18:27:54

naucoin

Details Diff
BUG: test for active camera before enabling fiducials

Removes the error message that world to view and view to world
can't compute result due to a missing active camera. Delaying
setting the handles and widgets to be enabled if there's
no active camera defined on their renderers seems to work well
since the next time through the update code once the layout
has stabilised and the renderers are updated, the seeds
will get positioned and enabled.

Issue 0003761


git-svn-id: http://svn.slicer.org/Slicer4/trunk@23493 3bd1e089-480b-0410-8dfb-8563597acbee
mod - Modules/Loadable/Markups/MRMLDM/vtkMRMLMarkupsDisplayableManager2D.cxx Diff File
mod - Modules/Loadable/Markups/MRMLDM/vtkMRMLMarkupsFiducialDisplayableManager2D.cxx Diff File

Issue History

Date Modified Username Field Change
2014-07-03 20:08 jcfr New Issue
2014-07-03 20:08 jcfr Status new => assigned
2014-07-03 20:08 jcfr Assigned To => nicole
2014-07-03 20:08 jcfr Target Version => Slicer 4.4.0
2014-07-03 20:10 jcfr Relationship added has duplicate 0003762
2014-07-03 20:10 jcfr Description Updated
2014-07-09 12:56 nicole Note Added: 0012159
2014-07-09 12:57 nicole Note Edited: 0012159
2014-07-09 12:57 nicole Relationship added related to 0001690
2014-07-11 04:50 jcfr Note Added: 0012161
2014-07-11 06:41 nicole Note Added: 0012168
2014-07-12 16:33 jcfr Note Added: 0012171
2014-07-14 07:12 nicole Note Added: 0012177
2014-07-18 00:06 jcfr Note Added: 0012191
2014-07-29 14:40 nicole Note Added: 0012281
2014-07-29 14:40 nicole Status assigned => resolved
2014-07-29 14:40 nicole Fixed in Version => Slicer 4.4.0
2014-07-29 14:40 nicole Resolution open => fixed
2014-08-29 07:48 jcfr Status resolved => closed
2017-06-10 08:51 Changeset attached => Slicer master c7b22bdd