View Issue Details

IDProjectCategoryView StatusLast Update
0003886Slicer4Module Markupspublic2018-03-02 11:02
ReporterfedorovAssigned Tolassoan 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in VersionSlicer 4.7.0 
Summary0003886: Fiducials are not placed in the middle of the slice along z direction
Description

Attached is the test volume and screenshot illustrating the problem.

1) load the volume
2) go to axial slice, rotate to volume plane
3) place the fiducial
4) jump to fiducial location and look at the sagittal view -- fiducial is at the edge of the slice, not at the middle - this issue can be rather important for IGT applications, when thick slices are not uncommon

Could this be due to the fiducials logic not accounting for the fact that the volume is tilted? On other occasions I saw fiducial being placed not at the edge, but inside the slice, not at the middle though.

Reproducible on Mac with the 2014-11-06 4.4 nightly.

TagsNo tags attached.

Relationships

related to 0003929 resolvedjcfr 3d visualization of image slice does not go through the middle of VR slice 

Activities

2014-11-08 06:13

 

2014-11-08 06:13

 

case9_US_resampled-label.nrrd (16,297 bytes)

2014-11-08 06:13

 

F.fcsv (231 bytes)
fedorov

fedorov

2014-11-08 06:14

developer   ~0012686

Or is this a more serious rendering issue, where the slices are not rendered at the middle of the slice, but in between? Or is this how it is supposed to work?

pieper

pieper

2014-11-10 02:44

administrator   ~0012687

@nicole let me know if you want to review the logic with me. I'd like to see this sorted out asap.

-Steve

nicole

nicole

2014-11-11 13:20

administrator   ~0012689

From the slice controller/logic side, the rotate to volume plane button is calling rotateSliceToBackground on the volume node. Adding the call to the slice logic to SnapSliceOffsetToIJK shows the fiducial still appearing on the edge of the slice in the Sagital and Coronal views. Oddly, it's showing at the other edge of the slice than without the snap call.

I'm still digging into the assumptions in jumping slices and rotating the volume and converting fiducial RAS locations to display positions to try and track down what's happening where.

fedorov

fedorov

2014-11-12 05:04

developer   ~0012691

This might be related or not: when I try to jump slices, very often I do not see the fiducials in the axial view, it's somewhere off. Very annoying. Especially while trying to prepare figures for a paper under a deadline pressure, using analyzed data.

fedorov

fedorov

2014-12-26 09:15

developer   ~0012813

Thsi seems to be related: if I volume render label drawn on a single slice, and make slice viewer visible in 3d, it does not go through the middle of the rendered label. Reproducible with the Dec 25 nightly.

pieper

pieper

2014-12-28 06:47

administrator   ~0012814

Hi Andrey -

The issue you reported in note 12813 sounds independent of the fiducials. Can you create a child bug with exact steps to reproduce it and assign to me? My guess is that this is a volume renderer issue but I would like to confirm.

Thanks,
Steve

lassoan

lassoan

2017-06-11 09:15

developer   ~0014750

Fixed in r26082 by snapping slice viewer to voxel center after rotate to volume plane (same way as done after FOV reset).

Some other issues mentioned in the discussion have been fixed since then, too (computation of slice spacing of oblique volumes, centered jump to slice).

Issue History

Date Modified Username Field Change
2014-11-08 06:13 fedorov New Issue
2014-11-08 06:13 fedorov Status new => assigned
2014-11-08 06:13 fedorov Assigned To => nicole
2014-11-08 06:13 fedorov File Added: Screenshot at Nov 08 10-55-47.png
2014-11-08 06:13 fedorov File Added: case9_US_resampled-label.nrrd
2014-11-08 06:13 fedorov File Added: F.fcsv
2014-11-08 06:14 fedorov Note Added: 0012686
2014-11-10 02:44 pieper Note Added: 0012687
2014-11-11 13:20 nicole Note Added: 0012689
2014-11-12 05:04 fedorov Note Added: 0012691
2014-12-26 09:15 fedorov Note Added: 0012813
2014-12-28 06:47 pieper Note Added: 0012814
2014-12-29 06:15 fedorov Relationship added parent of 0003929
2017-06-11 09:12 lassoan Relationship replaced related to 0003929
2017-06-11 09:15 lassoan Assigned To nicole => lassoan
2017-06-11 09:15 lassoan Status assigned => resolved
2017-06-11 09:15 lassoan Resolution open => fixed
2017-06-11 09:15 lassoan Fixed in Version => Slicer 4.7.0
2017-06-11 09:15 lassoan Note Added: 0014750
2018-03-02 11:02 jcfr Status resolved => closed