View Issue Details

IDProjectCategoryView StatusLast Update
0003896Slicer4Core: Scripting (Wrapping, Python)public2017-06-09 21:20
Reportervincent_agnusAssigned Tojcfr 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionno change required 
Product VersionSlicer 4.3.1-2 
Target VersionFixed in Version 
Summary0003896: OpenIGTLinkIF module : binding missing
Description

c++ method
vtkMRMLIGTLConnectorNode::RegisterIncomingMRMLNode(vtkMRMLNode* node)

is not wrapped in Python (although RegisterOutgoingMRMLNode is).

It is really annoying because I would like to use Python to set OpenIGTLink connections

TagsNo tags attached.

Activities

jcfr

jcfr

2014-11-18 08:19

administrator   ~0012704

Hi Vincent,

The method is not wrapped because it returns an object of type "NodeInfoType*"

See https://github.com/openigtlink/OpenIGTLinkIF/blob/41b5b183e6e1ef4ecd028c71c0b88e5f41dd5b70/MRML/vtkMRMLIGTLConnectorNode.h#L260

Few option to move forward:

  • refactor OpenIGTLinkIF to use type known by VTK wrapper
  • improve VTK wrapped to that it could understand hint / be extented to understand other type ..
lassoan

lassoan

2017-06-09 21:20

developer   ~0014703

Users don't need to call vtkMRMLIGTLConnectorNode::RegisterIncomingMRMLNode, it is for internal use only, by OpenIGTLinkIF module.

If a module wants to create a node that will be updated through OpenIGTLink, then create a node with the expected node name and type. When OpenIGTLinkIF module receives data that matches node name and type, it will automatically reuse the existing node.

Issue History

Date Modified Username Field Change
2014-11-18 05:59 vincent_agnus New Issue
2014-11-18 05:59 vincent_agnus Status new => assigned
2014-11-18 05:59 vincent_agnus Assigned To => jcfr
2014-11-18 08:19 jcfr Note Added: 0012704
2017-06-09 21:20 lassoan Status assigned => resolved
2017-06-09 21:20 lassoan Resolution open => no change required
2017-06-09 21:20 lassoan Note Added: 0014703