View Issue Details

IDProjectCategoryView StatusLast Update
0000039Slicer3Base Codepublic2017-06-10 08:51
ReporternicoleAssigned Tonicole 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Summary0000039: Deleting a selected fiducial list causes unexpected behaviour
Description

When a fiducial list is deleted in the Data module, if it was the currently selected fiducial list as saved in the Selected mrml node, unexpected behaviour is observed. The Fiducials module GUI node selector is out of sync, the Data module tries to add a non existent selected node to it's tree, the Fiducials Logic module can't add a new fiducial to the selected list as it no longer exists. The delete in the Data module should check the Selected node and update it.

Steps To Reproduce

Start Slicer3, control-shift-click to add some fiducials, enter the Data module, select the L1 list, Delete. Try adding new fiducials.

TagsNo tags attached.

Activities

pieper

pieper

2007-03-27 09:03

administrator   ~0000064

This appears to be fixed (at least I could not reproduce). Can it be closed?

nicole

nicole

2007-03-29 08:50

administrator   ~0000085

Watching for the node deleted event in the Fiducials GUI, as well as adding some checks in the mrml tree, seems to have fixed the issue.

Related Changesets

Import 2017-06-07 23:51:09: master ad32fd41

2014-08-12 22:32:22

jcfr

Details Diff
ENH: Update OpenIGTLink from 1.10.4 to 1.10.10 to include bug fixes.

$ git shortlog 3ac5311..849b434 --no-merges
Andras Lasso (1):
Add the MSG_NOSIGNAL flag to socket send calls to prevent application crash on disconnect on linux systems

Gergely Zombori (1):
Bug 0001912 - Merged the changes and enhancements from upstream into 'master'

Isaiah Norton (1):
BUG: use shutdown() instead of close() for sockets

Junichi Tokuda (7):
BUG: Address issue 0000029: copy igtl_win32hearder.h to the install directory.
ENH: Update patch number.
STYLE: Update patch number.
COMP: Fix compilation error due to lack of MSG_NOSIGNAL option in send() in Mac OS X. For Mac OS X, call setsockopt() with SO_NOSIGPIPE instead.
STYLE: Update revision number.
BUG: Set timestamp zero, when no timestamp object is registered to image meta message.
STYLE: Update patch number

Laurent Chauvin (1):
BUG: Initialize ImageMessage matrix to identity (issue 0000039)

Matt Clarkson (3):
0000044: Put nanosleep in loop to ensure sleep is for the correct time.
0000049: Avoid crash on division by zero, which should never happen
0000050: Convenience methods to set/get igtl_image matrix from 4x4 array of floats

z0022myy (1):
BUG: Intializing pointer should not be in a loop

git-svn-id: http://svn.slicer.org/Slicer4/trunk@23565 3bd1e089-480b-0410-8dfb-8563597acbee
mod - SuperBuild/External_OpenIGTLink.cmake Diff File

Issue History

Date Modified Username Field Change
2007-02-08 11:05 nicole New Issue
2007-03-27 09:03 pieper Note Added: 0000064
2007-03-27 09:04 pieper Assigned To => nicole
2007-03-27 09:04 pieper Status new => acknowledged
2007-03-27 09:04 pieper Resolution open => unable to reproduce
2007-03-29 08:50 nicole Note Added: 0000085
2007-03-29 08:50 nicole Status acknowledged => closed
2007-03-29 08:50 nicole Resolution unable to reproduce => fixed
2017-06-10 08:51 jcfr Changeset attached => Slicer master ad32fd41