View Issue Details

IDProjectCategoryView StatusLast Update
0003929Slicer4Core: Renderingpublic2018-05-30 00:32
ReporterfedorovAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionSlicer 4.4.0 
Target VersionFixed in VersionSlicer 4.9.0 
Summary0003929: 3d visualization of image slice does not go through the middle of VR slice
Description

Steps to reproduce:

1) load MR head
2) use Editor to make segmentation in just one slice of the image (e.g., rectangle effect)
3) enable volume rendering of the label image
4) enable visualization of slice in 3d viewer
5) observe image slice does not pass through the middle of the volume rendered label slice

TagsNo tags attached.

Relationships

related to 0003886 closedlassoan Fiducials are not placed in the middle of the slice along z direction 

Activities

pieper

pieper

2014-12-29 06:48

administrator   ~0012815

This appears to be an issue with the resample pipeline modes. The option indicated in the attached screenshot gives the correct rendering. Other modes for resampling may not give the same patient space display. We'd need to investigate to see if this is a fundamental limitation or something to be fixed at the reslice level.

2014-12-29 07:50

 

spacing.png (751,602 bytes)
spacing.png (751,602 bytes)
fedorov

fedorov

2014-12-29 08:01

developer   ~0012816

Thanks Steve. I wonder if this fixes the fiducials visualization problem of the parent bug. I don't even know what these different modes mean, and why they are exposed. I am sure there is history behind this that I do not know, but looks super complicated for a functionality exposed at such high level to the user.

pieper

pieper

2014-12-29 14:53

administrator   ~0012818

Yes, there's a long story - Ron and Alex worked out what modes were desirable and what the default should be. Alex implemented the corresponding changes to the reslice pipeline. I suspect things could be simplified and reworked for consistency.

Regarding the fiducials, I doubt this is the same issue. The reslicing modes shown in the scrrenshot have to do with how the slice views are mapped to a textures for display as slice planes (that is textrured plans forming slice models in threeD views). All of this could stand to be revamped, but I believe it does not come into play with respect to the fiducials in slice views.

fedorov

fedorov

2015-02-06 05:37

developer   ~0012898

Someone else discovered this and pointed to me - if one uses GPU volume rendering, the label is rendered correctly with the volume slice going through the middle. There is apparently a difference between CPU and GPU.

2015-02-06 05:38

 

cpu.png (84,245 bytes)
cpu.png (84,245 bytes)

2015-02-06 05:38

 

gpu.png (122,970 bytes)
gpu.png (122,970 bytes)
pieper

pieper

2015-02-07 12:55

administrator   ~0012900

It sounds like this should be filed as a VTK bug then.

jcfr

jcfr

2015-06-01 13:24

administrator   ~0013113

Last edited: 2015-06-01 13:25

Following investigation by the VTK rendering team. The issue is reproducible within VTK proper using OpenGL mapper and has been fixed within OpenGL2 mapper. See:

OpenGL: PlaneThroughVolume_OpenGL_v1.PNG

OpenGL2: PlaneThroughVolume_OpenGL_v2.PNG

2015-06-01 13:25

 

2015-06-01 13:25

 

pieper

pieper

2015-06-01 14:39

administrator   ~0013114

Great news!

lassoan

lassoan

2018-05-30 00:32

developer   ~0015802

Confirmed working in recent nightly.

Issue History

Date Modified Username Field Change
2014-12-29 06:15 fedorov New Issue
2014-12-29 06:15 fedorov Status new => assigned
2014-12-29 06:15 fedorov Assigned To => jcfr
2014-12-29 06:15 fedorov Relationship added child of 0003886
2014-12-29 06:16 fedorov Assigned To jcfr => pieper
2014-12-29 06:48 pieper Note Added: 0012815
2014-12-29 07:50 pieper File Added: spacing.png
2014-12-29 08:01 fedorov Note Added: 0012816
2014-12-29 14:53 pieper Note Added: 0012818
2015-02-06 05:37 fedorov Note Added: 0012898
2015-02-06 05:38 fedorov File Added: cpu.png
2015-02-06 05:38 fedorov File Added: gpu.png
2015-02-07 12:55 pieper Note Added: 0012900
2015-02-10 10:44 jcfr Assigned To pieper => jcfr
2015-02-10 10:44 jcfr Category Core: Base Code => Core: Rendering
2015-06-01 13:24 jcfr Note Added: 0013113
2015-06-01 13:25 jcfr File Added: PlaneThroughVolume_OpenGL_v1.PNG
2015-06-01 13:25 jcfr File Added: PlaneThroughVolume_OpenGL_v2.PNG
2015-06-01 13:25 jcfr Note Edited: 0013113
2015-06-01 14:39 pieper Note Added: 0013114
2017-06-11 09:12 lassoan Relationship replaced related to 0003886
2018-05-30 00:32 lassoan Status assigned => resolved
2018-05-30 00:32 lassoan Resolution open => fixed
2018-05-30 00:32 lassoan Fixed in Version => Slicer 4.9.0
2018-05-30 00:32 lassoan Note Added: 0015802