View Issue Details

IDProjectCategoryView StatusLast Update
0003934Slicer4Core: Usabilitypublic2015-01-08 05:04
ReporterskylstraAssigned Tofinetjul 
PrioritynormalSeverityminorReproducibilitysometimes
Status assignedResolutionno change required 
Product VersionSlicer 4.4.0 
Target VersionFixed in Version 
Summary0003934: Opening Dicom options inconsistent
Description

When I open a series of Dicom files the settings in the I/O are not consistent between files. Specifically, the selection to open a single file vs. the set of files may be selected or not selected randomly.

TagsNo tags attached.

Activities

pieper

pieper

2015-01-07 08:33

administrator   ~0012848

Thanks for the report - but I don't understand - can you provide more information? Particularly the steps to reproduce the issue your expected result.

skylstra

skylstra

2015-01-07 09:24

reporter   ~0012849

Sorry for the Confusion.

I selected the option to add data for a new session. I would select the Option to select file(s) to add. I would choose a single file. At this point there is an option that can be checked off that says "Single File". It more or less randomly changes between being checked and unchecked without me manually changing it. It is very rare and I think it has to do with data from the file I'm loading but it took some time to figure out. I will add a photo as well.

Hope this helps

2015-01-07 09:25

 

GUIView.tiff (52,274 bytes)
davisb

davisb

2015-01-07 10:18

developer   ~0012850

Are any heuristics used to populate the "Single File" checkbox while preparing for data load?

It seems like the problem is that this checkbox is occasionally, unexpectedly checked when loading DICOM data. Thus if you don't "show options" and uncheck the "Single File" box you end up loading only a single slice when you meant to load a volume.

The unexpected part comes in because it seems that most of the time this box is unchecked when loading DICOM data (selecting a single file form a series to open).

skylstra

skylstra

2015-01-07 10:23

reporter   ~0012851

I'm not sure I understand your question. I need the box to always be unchecked.

The rest of your explanation is exactly right.

davisb

davisb

2015-01-07 10:25

developer   ~0012852

I'm not sure I understand your question. I need the box to always be unchecked.

I'm hoping Steve (or another developer) can answer it :)

pieper

pieper

2015-01-08 05:03

administrator   ~0012858

I know that Julien F added some code that tries to do the right thing - but in general dicom shouldn't be loaded via the Add Data because that pathway relies on file extensions which aren't a required part of the dicom standard (sometimes they will be .dcm or .ima but sometimes nothing). This may explain what you see with the Single File checkbox.

Instead you should be using the DICOM Module, which looks inside the files to map them to slicer data structures.

Issue History

Date Modified Username Field Change
2015-01-07 05:43 skylstra New Issue
2015-01-07 05:43 skylstra Status new => assigned
2015-01-07 05:43 skylstra Assigned To => pieper
2015-01-07 08:33 pieper Note Added: 0012848
2015-01-07 09:24 skylstra Note Added: 0012849
2015-01-07 09:25 skylstra File Added: GUIView.tiff
2015-01-07 10:18 davisb Note Added: 0012850
2015-01-07 10:23 skylstra Note Added: 0012851
2015-01-07 10:25 davisb Note Added: 0012852
2015-01-08 05:03 pieper Note Added: 0012858
2015-01-08 05:04 pieper Status assigned => resolved
2015-01-08 05:04 pieper Resolution open => no change required
2015-01-08 05:04 pieper Status resolved => assigned
2015-01-08 05:04 pieper Assigned To pieper => finetjul