View Issue Details

IDProjectCategoryView StatusLast Update
0003941Slicer4Core: Base Codepublic2017-06-15 10:56
ReporterpieperAssigned Tojcfr 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
PlatformmacOSOS Version
Product VersionSlicer 4.4.0 
Target VersionFixed in Version 
Summary0003941: bad tmp dir due to copied settings
Description

A user got a new mac and copied her home directory. This brought over the .config file that includes the slicer settings. As a result her slicer.app.temporaryPath was pointing to a directory that did not exist on the new mac. Creating the directory also did not work. This apparently has something to do with the way mac allocates the names of user-specific tmp directories.

http://qt-project.org/doc/qt-4.8/qdir.html#tempPath

Tagshelp-wanted

Relationships

duplicate of 0004340 resolvedjcfr Impossible to use Slicer in multi-user setting on Linux 

Activities

pieper

pieper

2015-01-15 02:53

administrator   ~0012885

My suggested fix for this is to detect the case where the temporaryPath cannot be written to. Then we can prompt the user with a dialog warning. One option would be to just clear the settings.

Issue History

Date Modified Username Field Change
2015-01-15 02:49 pieper New Issue
2015-01-15 02:49 pieper Status new => assigned
2015-01-15 02:49 pieper Assigned To => jcfr
2015-01-15 02:53 pieper Note Added: 0012885
2015-10-06 22:43 jcfr Status assigned => acknowledged
2015-10-06 22:44 jcfr Tag Attached: help-wanted
2017-06-15 10:56 lassoan Relationship added duplicate of 0004340
2017-06-15 10:56 lassoan Status acknowledged => closed
2017-06-15 10:56 lassoan Resolution open => duplicate